summaryrefslogtreecommitdiff
path: root/packaging/debian/monkeysphere.postinst
blob: 8e7977173b71fd370194613c7ebdfe88ac3e50be (plain)
  1. #!/bin/sh -e
  2. # postinst script for monkeysphere
  3. # Author: Jameson Rollins <jrollins@finestructure.net>
  4. # Copyright 2008-2009
  5. VARLIB="/var/lib/monkeysphere"
  6. # add a monkeysphere user if one does not already exist
  7. if ! getent passwd monkeysphere >/dev/null ; then
  8. echo "adding monkeysphere user..."
  9. adduser --quiet --system --no-create-home --group \
  10. --home "$VARLIB" \
  11. --shell '/bin/bash' \
  12. --gecos 'monkeysphere authentication user,,,' \
  13. monkeysphere
  14. fi
  15. # setup monkeysphere authentication
  16. monkeysphere-authentication setup
  17. # dh_installdeb will replace this with shell code automatically
  18. # generated by other debhelper scripts.
  19. #DEBHELPER#
  20. exit 0