summaryrefslogtreecommitdiff
path: root/packaging/debian
diff options
context:
space:
mode:
authorMatt Goins <mjgoins@openflows.com>2009-03-10 09:33:05 -0400
committerMatt Goins <mjgoins@openflows.com>2009-03-10 09:33:05 -0400
commit282c489f3101f0d744b66d88853a150e79b0870d (patch)
treeb4028ecbb3d313ba41f956cc00fea7925982bfbb /packaging/debian
parentcec56faf07bb4f3b8d563e4f3c9042b6579356e2 (diff)
parent69b3e256e2017d5664ef37d06aae5e5bcf446575 (diff)
Merge commit 'dkg/master'
Diffstat (limited to 'packaging/debian')
-rw-r--r--packaging/debian/changelog28
-rw-r--r--packaging/debian/control8
-rw-r--r--packaging/debian/copyright2
-rwxr-xr-xpackaging/debian/monkeysphere.postinst45
-rwxr-xr-xpackaging/debian/monkeysphere.postrm13
-rwxr-xr-xpackaging/debian/monkeysphere.preinst25
-rwxr-xr-xpackaging/debian/monkeysphere.prerm27
7 files changed, 96 insertions, 52 deletions
diff --git a/packaging/debian/changelog b/packaging/debian/changelog
index 50a7071..873b058 100644
--- a/packaging/debian/changelog
+++ b/packaging/debian/changelog
@@ -1,3 +1,31 @@
+monkeysphere (0.24-1) unstable; urgency=low
+
+ * New upstream release:
+ - fixed how version information is stored/retrieved
+ - now uses perl-based keytrans for both pem2openpgp and openpgp2ssh
+ - no longer needs base64 in PATH
+ - added "test" make target
+ - improved transitions/0.23 script so it no longer fails in common
+ circumstances (Closes: #517779)
+ - RSA only: no longer handles DSA keys
+ - added ability to specify subkeys to add to ssh agent with
+ new MONKEYSPHERE_SUBKEYS_FOR_AGENT environment variable
+ * update/cleanup maintainer scripts
+ * remove GnuTLS dependency
+ * remove versioned coreutils | base64 dependency
+ * added Build-Deps for dh_autotest
+ * switch to Architecture: all
+ * added cron to Recommends
+
+ -- Jameson Graef Rollins <jrollins@finestructure.net> Tue, 03 Mar 2009 19:38:33 -0500
+
+monkeysphere (0.23.1-1) unstable; urgency=low
+
+ * New Upstrem "Brown Paper Bag" Release:
+ - adjusts internal version numbers
+
+ -- Daniel Kahn Gillmor <dkg@fifthhorseman.net> Sat, 21 Feb 2009 18:09:47 -0500
+
monkeysphere (0.23-1) unstable; urgency=low
"The Golden Bezoar Release"
diff --git a/packaging/debian/control b/packaging/debian/control
index c20b978..616a95a 100644
--- a/packaging/debian/control
+++ b/packaging/debian/control
@@ -3,16 +3,16 @@ Section: net
Priority: extra
Maintainer: Jameson Graef Rollins <jrollins@finestructure.net>
Uploaders: Daniel Kahn Gillmor <dkg@fifthhorseman.net>
-Build-Depends: debhelper (>= 7.0), libgnutls-dev (>= 2.4.0)
+Build-Depends: debhelper (>= 7.0), socat, openssh-server, gnupg, libcrypt-openssl-rsa-perl, libdigest-sha1-perl, lockfile-progs | procmail
Standards-Version: 3.8.0.1
Homepage: http://web.monkeysphere.info/
Vcs-Git: git://git.monkeysphere.info/monkeysphere
Dm-Upload-Allowed: yes
Package: monkeysphere
-Architecture: any
-Depends: openssh-client, gnupg, coreutils (>= 6) | base64, libcrypt-openssl-rsa-perl, libdigest-sha1-perl, lockfile-progs | procmail, adduser, ${shlibs:Depends}
-Recommends: netcat | socat, ssh-askpass
+Architecture: all
+Depends: openssh-client, gnupg, libcrypt-openssl-rsa-perl, libdigest-sha1-perl, lockfile-progs | procmail, adduser, ${misc:Depends}
+Recommends: netcat | socat, ssh-askpass, cron
Enhances: openssh-client, openssh-server
Description: use the OpenPGP web of trust to verify ssh connections
SSH key-based authentication is tried-and-true, but it lacks a true
diff --git a/packaging/debian/copyright b/packaging/debian/copyright
index 4c25286..c85128f 100644
--- a/packaging/debian/copyright
+++ b/packaging/debian/copyright
@@ -21,4 +21,4 @@ License: GPL-3+
(at your option) any later version.
.
On Debian systems, the complete text of the GNU General Public License
- can be found in file "/usr/share/common-licenses/GPL".
+ version 3 can be found in file "/usr/share/common-licenses/GPL-3".
diff --git a/packaging/debian/monkeysphere.postinst b/packaging/debian/monkeysphere.postinst
index 3d0d66f..4e81167 100755
--- a/packaging/debian/monkeysphere.postinst
+++ b/packaging/debian/monkeysphere.postinst
@@ -1,27 +1,40 @@
-#!/bin/sh -e
+#!/bin/sh
# postinst script for monkeysphere
# Author: Jameson Rollins <jrollins@finestructure.net>
# Copyright 2008-2009
+set -e
+
VARLIB="/var/lib/monkeysphere"
-# add a monkeysphere user if one does not already exist
-if ! getent passwd monkeysphere >/dev/null ; then
- echo "adding monkeysphere user..."
- adduser --quiet --system --no-create-home --group \
- --home "$VARLIB" \
- --shell '/bin/bash' \
- --gecos 'monkeysphere authentication user,,,' \
- monkeysphere
-fi
-
-# try to transition from to 0.23:
-/usr/share/monkeysphere/transitions/0.23
-
-# setup monkeysphere authentication
-monkeysphere-authentication setup
+case $1 in
+ configure)
+ # add a monkeysphere user if one does not already exist
+ if ! getent passwd monkeysphere >/dev/null ; then
+ echo "adding monkeysphere user..."
+ adduser --quiet --system --no-create-home --group \
+ --home "$VARLIB" \
+ --shell '/bin/bash' \
+ --gecos 'monkeysphere authentication user,,,' \
+ monkeysphere
+ fi
+
+ # try all available transitions:
+ for trans in 0.23 ; do
+ /usr/share/monkeysphere/transitions/$trans || { \
+ RET=$?
+ echo "Failed running transition script /usr/share/monkeysphere/transitions/$trans" >&2
+ exit $RET
+ }
+ done
+
+
+ # setup monkeysphere authentication
+ monkeysphere-authentication setup
+ ;;
+esac
# dh_installdeb will replace this with shell code automatically
# generated by other debhelper scripts.
diff --git a/packaging/debian/monkeysphere.postrm b/packaging/debian/monkeysphere.postrm
index 79f7245..d789012 100755
--- a/packaging/debian/monkeysphere.postrm
+++ b/packaging/debian/monkeysphere.postrm
@@ -1,14 +1,21 @@
-#!/bin/sh -e
+#!/bin/sh
# postrm script for monkeysphere
# Author: Jameson Rollins <jrollins@finestructure.net>
# Copyright 2008-2009
+set -e
+
case $1 in
purge)
- echo "removing monkeysphere user..."
- userdel monkeysphere > /dev/null || true
+ # delete monkeysphere user
+ # http://wiki.debian.org/AccountHandlingInMaintainerScripts
+ if which deluser >/dev/null 2>&1 ; then
+ deluser --quiet --system monkeysphere > /dev/null || true
+ else
+ echo >&2 "not removing monkeysphere system account because deluser command was not found"
+ fi
;;
esac
diff --git a/packaging/debian/monkeysphere.preinst b/packaging/debian/monkeysphere.preinst
deleted file mode 100755
index fd22f6f..0000000
--- a/packaging/debian/monkeysphere.preinst
+++ /dev/null
@@ -1,25 +0,0 @@
-#!/bin/sh -e
-
-# preinst script for monkeysphere
-
-# Author: Jameson Rollins <jrollins@finestructure.net>
-# Copyright 2008-2009
-
-ETC="/etc/monkeysphere"
-
-# move the old server conf file to be the authentication conf file
-if [ -f "$ETC"/monkeysphere-server.conf -a \
- ! -f "$ETC"/monkeysphere-authentication.conf ] ; then
- mv "$ETC"/monkeysphere-server.conf "$ETC"/monkeysphere-authentication.conf
-fi
-
-# remove the old gpg-*.conf files
-rm -f "$ETC"/gpg-host.conf
-rm -f "$ETC"/gpg-authentication.conf
-
-# dh_installdeb will replace this with shell code automatically
-# generated by other debhelper scripts.
-
-#DEBHELPER#
-
-exit 0
diff --git a/packaging/debian/monkeysphere.prerm b/packaging/debian/monkeysphere.prerm
index 5835f53..1a5135a 100755
--- a/packaging/debian/monkeysphere.prerm
+++ b/packaging/debian/monkeysphere.prerm
@@ -2,10 +2,31 @@
# prerm script for monkeysphere
-# Author: Jameson Rollins <jrollins@finestructure.net>
-# Copyright 2008-2009
+# the only thing we're doing here is making sure that the local
+# administrator is not trying to downgrade to a version below 0.23,
+# since there was such a major reorganization of system data during
+# the transition to 0.23.
-true
+# Author: Daniel Kahn Gillmor <dkg@fifthhorseman.net>
+# Copyright 2009
+
+set -e
+
+case "$1" in
+ upgrade)
+ if dpkg --compare-versions "$2" lt 0.23 ; then
+ cat >&2 <<EOF
+
+Downgrading the monkeysphere to a version earlier than 0.23 can have
+BAD CONSEQUENCES, including potentially locking you out of the system.
+Downgrading in this fashion is NOT SUPPORTED.
+
+EOF
+
+ exit 1
+ fi
+ ;;
+esac
# dh_installdeb will replace this with shell code automatically
# generated by other debhelper scripts.