summaryrefslogtreecommitdiff
path: root/dists/gentoo/ledger-smb-1.2.0_rc4.ebuild
blob: 5ef0d08c3e165b434ff67a3f3c942643ecff746a (plain)
  1. # Copyright 1999-2005 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. # $Header: $
  4. inherit depend.apache webapp eutils
  5. DESCRIPTION="LedgerSMB is an Open source web-based accounting application for Small and Medium buisnesses."
  6. HOMEPAGE="http://www.ledgersmb.org/"
  7. #SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
  8. #SRC_URI="http://downloads.sourceforge.net/ledger-smb/${P}.tar.gz"
  9. SRC_URI="http://downloads.sourceforge.net/ledger-smb/ledger-smb-1.2.0rc4.tar.gz"
  10. # don't use the gentoo mirrors yet, we're not there.
  11. RESTRICT='mirror'
  12. LICENSE="GPL-2"
  13. KEYWORDS="~x86 ~ppc "
  14. # no use flag for now
  15. IUSE=""
  16. DEPEND=""
  17. RDEPEND="
  18. >=dev-db/postgresql-8
  19. >=dev-lang/perl-5.8
  20. dev-perl/DBI
  21. net-www/apache
  22. >=virtual/perl-locale-maketext-1.10
  23. >=dev-perl/locale-maketext-lexicon-0.62
  24. >=dev-perl/DBD-Pg-1.49
  25. dev-perl/MIME-Lite
  26. dev-perl/Parse-RecDescent
  27. dev-perl/HTML-Parser
  28. "
  29. S=${WORKDIR}/${PN}
  30. src_unpack() {
  31. unpack ${A}
  32. }
  33. src_install() {
  34. webapp_src_preinst
  35. webapp_server_configfile apache ${S}/dists/gentoo/ledger-smb-httpd-gentoo.conf
  36. cp -R ${S}/* ${D}/${MY_HTDOCSDIR}
  37. # LedgerSMB needs to write to the users directory
  38. webapp_serverowned -R ${MY_HTDOCSDIR}/users/
  39. webapp_serverowned -R ${MY_HTDOCSDIR}/spool/
  40. webapp_postinst_txt en ${S}/dists/gentoo/post-install.txt
  41. webapp_src_install
  42. }