summaryrefslogtreecommitdiff
path: root/ikiwiki.spec
blob: 9294586df07bd8d643f5ad31c06211831c6598f8 (plain)
  1. Name:           ikiwiki
  2. Version: 3.20091024
  3. Release: 1%{?dist}
  4. Summary: A wiki compiler
  5. Group: Applications/Internet
  6. License: GPLv2+
  7. URL: http://ikiwiki.info/
  8. Source0: http://ftp.debian.org/debian/pool/main/i/%{name}/%{name}_%{version}.tar.gz
  9. Patch0: ikiwiki-3.00-libexecdir.patch
  10. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
  11. BuildArch: noarch
  12. BuildRequires: perl(Text::Markdown)
  13. BuildRequires: perl(Mail::Sendmail)
  14. BuildRequires: perl(HTML::Scrubber)
  15. BuildRequires: perl(XML::Simple)
  16. BuildRequires: perl(Date::Parse)
  17. BuildRequires: perl(Date::Format)
  18. BuildRequires: perl(HTML::Template)
  19. BuildRequires: perl(CGI::FormBuilder)
  20. BuildRequires: perl(CGI::Session)
  21. BuildRequires: perl(File::MimeInfo)
  22. BuildRequires: gettext
  23. BuildRequires: po4a
  24. Requires: perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
  25. Requires: perl(Text::Markdown)
  26. Requires: perl(Mail::Sendmail)
  27. Requires: perl(HTML::Scrubber)
  28. Requires: perl(XML::Simple)
  29. Requires: perl(CGI::FormBuilder)
  30. Requires: perl(CGI::Session)
  31. Requires: perl(Digest::SHA1)
  32. Requires: python-docutils
  33. %define cgi_bin %{_libexecdir}/w3m/cgi-bin
  34. %description
  35. Ikiwiki is a wiki compiler. It converts wiki pages into HTML pages
  36. suitable for publishing on a website. Ikiwiki stores pages and history
  37. in a revision control system such as Subversion or Git. There are many
  38. other features, including support for blogging, as well as a large
  39. array of plugins.
  40. %prep
  41. %setup0 -q -n %{name}
  42. %patch0 -p1 -b .libexecdir
  43. # Filter unwanted Provides:
  44. %{__cat} << \EOF > %{name}-prov
  45. #!/bin/sh
  46. %{__perl_provides} $* |\
  47. %{__sed} -e '/perl(IkiWiki.*)/d'
  48. EOF
  49. %define __perl_provides %{_builddir}/%{name}/%{name}-prov
  50. %{__chmod} +x %{__perl_provides}
  51. # Filter Requires, all used by plugins
  52. # - Monotone: see bz 450267
  53. %{__cat} << \EOF > %{name}-req
  54. #!/bin/sh
  55. %{__perl_requires} $* |\
  56. %{__sed} -e '/perl(IkiWiki.*)/d' \
  57. -e '/perl(Monotone)/d'
  58. EOF
  59. %define __perl_requires %{_builddir}/%{name}/%{name}-req
  60. %{__chmod} +x %{__perl_requires}
  61. # goes into the -w3m subpackage
  62. %{__cat} << \EOF > README.fedora
  63. See http://ikiwiki.info/w3mmode/ for more information.
  64. EOF
  65. %build
  66. %{__perl} Makefile.PL INSTALLDIRS=vendor PREFIX=%{_prefix}
  67. # parallel builds currently don't work
  68. %{__make}
  69. %install
  70. %{__rm} -rf %{buildroot}
  71. %{__make} pure_install DESTDIR=%{buildroot} W3M_CGI_BIN=%{cgi_bin}
  72. %find_lang %{name}
  73. # move external plugins
  74. %{__mkdir_p} %{buildroot}%{_libexecdir}/ikiwiki/plugins
  75. %{__mv} %{buildroot}%{_prefix}/lib/ikiwiki/plugins/* \
  76. %{buildroot}%{_libexecdir}/ikiwiki/plugins
  77. # remove shebang
  78. %{__sed} -e '1{/^#!/d}' -i \
  79. %{buildroot}%{_sysconfdir}/ikiwiki/auto.setup \
  80. %{buildroot}%{_sysconfdir}/ikiwiki/auto-blog.setup \
  81. %{buildroot}%{_libexecdir}/ikiwiki/plugins/proxy.py
  82. %clean
  83. %{__rm} -rf %{buildroot}
  84. %files -f %{name}.lang
  85. %defattr(-,root,root,-)
  86. %{_bindir}/ikiwiki*
  87. %{_sbindir}/ikiwiki*
  88. %{_mandir}/man1/ikiwiki*
  89. %{_mandir}/man8/ikiwiki*
  90. %{_datadir}/ikiwiki
  91. %dir %{_sysconfdir}/ikiwiki
  92. %config(noreplace) %{_sysconfdir}/ikiwiki/*
  93. # contains a packlist only
  94. %exclude %{perl_vendorarch}
  95. %{perl_vendorlib}/IkiWiki*
  96. %exclude %{perl_vendorlib}/IkiWiki*/Plugin/skeleton.pm.example
  97. %{_libexecdir}/ikiwiki
  98. %doc README debian/changelog debian/NEWS html
  99. %doc IkiWiki/Plugin/skeleton.pm.example
  100. %package w3m
  101. Summary: Ikiwiki w3m cgi meta-wrapper
  102. Group: Applications/Internet
  103. Requires: w3m
  104. Requires: %{name} = %{version}-%{release}
  105. %description w3m
  106. Enable usage of all of ikiwiki's web features (page editing, etc) in
  107. the w3m web browser without a web server. w3m supports local CGI
  108. scripts, and ikiwiki can be set up to run that way using the
  109. meta-wrapper in this package.
  110. %files w3m
  111. %defattr(-,root,root,-)
  112. %doc README.fedora
  113. %{cgi_bin}/ikiwiki-w3m.cgi
  114. %changelog
  115. * Thu Oct 8 2009 Thomas Moschny <thomas.moschny@gmx.de> - 3.14159265-1
  116. - Update to 3.14159265.
  117. * Tue Sep 1 2009 Thomas Moschny <thomas.moschny@gmx.de> - 3.1415926-1
  118. - Update to 3.1415926 (fixes CVE-2009-2944, see bz 520543).
  119. * Wed Aug 12 2009 Thomas Moschny <thomas.moschny@gmx.de> - 3.141592-1
  120. - Update to 3.141592.
  121. - po4a is needed now.
  122. * Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.1415-2
  123. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  124. * Fri Jul 17 2009 Thomas Moschny <thomas.moschny@gmx.de> - 3.1415-1
  125. - Update to 3.1415.
  126. * Thu Jun 11 2009 Thomas Moschny <thomas.moschny@gmx.de> - 3.14-1
  127. - Update to 3.14.
  128. * Fri May 15 2009 Thomas Moschny <thomas.moschny@gmx.de> - 3.12-1
  129. - Update to 3.12.
  130. * Tue May 5 2009 Thomas Moschny <thomas.moschny@gmx.de> - 3.11-1
  131. - Update to 3.11.
  132. * Sat Apr 25 2009 Thomas Moschny <thomas.moschny@gmx.de> - 3.10-1
  133. - Update to 3.10.
  134. * Tue Apr 7 2009 Thomas Moschny <thomas.moschny@gmx.de> - 3.09-1
  135. - Update to 3.09.
  136. * Fri Mar 27 2009 Thomas Moschny <thomas.moschny@gmx.de> - 3.08-1
  137. - Update to 3.08.
  138. * Mon Mar 9 2009 Thomas Moschny <thomas.moschny@gmx.de> - 3.07-1
  139. - Update to 3.07.
  140. * Thu Mar 5 2009 Thomas Moschny <thomas.moschny@gmx.de> - 3.06-1
  141. - Update to 3.06.
  142. * Tue Feb 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.04-2
  143. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  144. * Wed Feb 18 2009 Thomas Moschny <thomas.moschny@gmx.de> - 3.04-1
  145. - Update to 3.04.
  146. * Mon Feb 9 2009 Thomas Moschny <thomas.moschny@gmx.de> - 3.03-1
  147. - Update to 3.03.
  148. * Sat Jan 10 2009 Thomas Moschny <thomas.moschny@gmx.de> - 3.01-1
  149. - Update to 3.01.
  150. * Fri Jan 2 2009 Thomas Moschny <thomas.moschny@gmx.de> - 3.00-1
  151. - Update to 3.00.
  152. * Fri Jan 2 2009 Thomas Moschny <thomas.moschny@gmx.de> - 2.72-1
  153. - Update to 2.72.
  154. - Patch for mtn plugin has been applied upstream.
  155. - Encoding of ikiwiki.vim has been changed to utf-8 upstream.
  156. - Use new W3M_CGI_BIN option in %%install.
  157. * Tue Dec 16 2008 Thomas Moschny <thomas.moschny@gmx.de> - 2.70-3
  158. - Patch for monotone plugin: Prevent broken pipe message.
  159. - Cosmetic changes to satisfy rpmlint.
  160. * Mon Dec 01 2008 Ignacio Vazquez-Abrams <ivazqueznet+rpm@gmail.com> - 2.70-2
  161. - Rebuild for Python 2.6
  162. * Thu Nov 20 2008 Thomas Moschny <thomas.moschny@gmx.de> - 2.70-1
  163. - Update to 2.70.
  164. - Install and enable the external rst plugin.
  165. - Stop filtering perl(RPC::XML*) requires.
  166. * Fri Oct 10 2008 Thomas Moschny <thomas.moschny@gmx.de> - 2.66-1
  167. - Update to 2.66.
  168. * Fri Sep 19 2008 Thomas Moschny <thomas.moschny@gmx.de> - 2.64-1
  169. - Update to 2.64.
  170. * Thu Sep 11 2008 Thomas Moschny <thomas.moschny@gmx.de> - 2.63-1
  171. - Update to 2.63.
  172. * Sat Aug 30 2008 Thomas Moschny <thomas.moschny@gmx.de> - 2.62.1-1
  173. - Update to 2.62.1. Add /etc/ikiwiki.
  174. * Thu Aug 7 2008 Thomas Moschny <thomas.moschny@gmx.de> - 2.56-1
  175. - Update to 2.56.
  176. - Stop filtering perl(Net::Amazon::S3), has been approved (bz436481).
  177. * Thu Jul 31 2008 Thomas Moschny <thomas.moschny@gmx.de> - 2.55-1
  178. - Update to 2.55.
  179. * Thu Jul 24 2008 Thomas Moschny <thomas.moschny@gmx.de> - 2.54-1
  180. - Update to 2.54.
  181. - Move example plugin file to doc.
  182. * Sat Jul 12 2008 Thomas Moschny <thomas.moschny@gmx.de> - 2.53-1
  183. - Update to 2.53.
  184. * Thu Jul 10 2008 Thomas Moschny <thomas.moschny@gmx.de> - 2.52-1
  185. - Update to 2.52.
  186. * Sun Jul 6 2008 Thomas Moschny <thomas.moschny@gmx.de> - 2.51-1
  187. - Update to 2.51.
  188. - Save iconv output to a temporary file.
  189. * Sun Jun 15 2008 Thomas Moschny <thomas.moschny@gmx.de> - 2.50-1
  190. - Update to 2.50.
  191. - Move ikiwiki-w3m.cgi into a subpackage.
  192. - Add ikiwiki's own documentation.
  193. - Remove duplicate requirement perl(File::MimeInfo).
  194. - Minor cleanups.
  195. * Mon Jun 2 2008 Thomas Moschny <thomas.moschny@gmx.de> - 2.48-1
  196. - Update to 2.48.
  197. * Wed May 28 2008 Thomas Moschny <thomas.moschny@gmx.de> - 2.47-1
  198. - Update to 2.47.
  199. * Tue May 13 2008 Thomas Moschny <thomas.moschny@gmx.de> - 2.46-1
  200. - Update to 2.46.
  201. * Sat May 10 2008 Thomas Moschny <thomas.moschny@gmx.de> - 2.45-1
  202. - New package.