summaryrefslogtreecommitdiff
path: root/debian/changelog
blob: b6f397f27030a3952f7410ae65c70a45245532e4 (plain)
  1. ikiwiki (1.34) UNRELEASED; urgency=low
  2. * Add an openid plugin to support logging in using OpenID.
  3. * Web commits by OpenID users will record the full OpenID url for the user,
  4. but in recentchanges, these urls will be converted to a simplified display
  5. form+link.
  6. * Modified svn, git, tla backends to recognise such web commits.
  7. * Move httpauth support to a plugin.
  8. * Add openidsignup config option.
  9. * Make the openid plugin support the callbacks from myopenid.com via its
  10. affiliate program.
  11. * Change how post signin actions are propigated through the signin process;
  12. they're now stored in the session.
  13. * Add optional "desc" parameter to shortcut definitions.
  14. * Avoid locking the wiki at all when handling some basic cgi stuff
  15. (searches, recentchanges).
  16. * Add "last" parameter to hook function. Very basic ordering, and hopefully
  17. nothing more spohisticated will be needed.
  18. * Add formbuilder_setup and formbuilder hooks.
  19. * Split out a passwordauth module, that holds all the traditional password
  20. based authentication etc code. It's enabled by default, but can be disabled
  21. if you want only openid or some other auth method.
  22. -- Joey Hess <joeyh@debian.org> Mon, 20 Nov 2006 09:17:07 -0500
  23. ikiwiki (1.33) unstable; urgency=low
  24. * Fix issue with aggregate plugin updating expired pages.
  25. * Avoid syntax errors in templates used by the template plugin crashing
  26. ikiwiki.
  27. * Enable utf8 file IO in aggregate plugin.
  28. * Fix some issues with the new registration form.
  29. * Patch from Ethan Glasser Camp to add a skip option to the inline plugin.
  30. * Make sure to check for errors from every eval.
  31. * Fix img plugin's handling of adding dependencies for images that do not
  32. yet exist.
  33. * Work around a strange bug in CGI::FormBuilder 3.0401 that makes
  34. FORM-SUBMIT unusable on customised formbuilder templates. For now,
  35. hardcode the submit buttons in editpage.tmpl instead of using the
  36. template variable, which is ok, since the buttons are static.
  37. * Work with hyperestraier 1.4.9.
  38. -- Joey Hess <joeyh@debian.org> Wed, 15 Nov 2006 18:32:26 -0500
  39. ikiwiki (1.32) unstable; urgency=low
  40. * Add a separate pass to find page links, and only render each page once,
  41. instead of over and over. Typical speedup is ~4x. Max possible speedup:
  42. 8x.
  43. * Add "scan" parameter to hook(), which is used to make the hook be called
  44. during the scanning pass, as well as the render pass. The meta and tag
  45. plugins need to use the new scan parameter, so will any others that modify
  46. %links.
  47. * Now that links are calculated in a separate pass, it can also
  48. precalculate backlinks in one pass, which is O(N^2) instead of the
  49. previous code that was O(N^3). A very nice speedup for wikis with lots
  50. (thousands) of pages.
  51. * Stylish update to the ikiwiki logo, thanks to Recai Oktaş and Selçuk
  52. Erdem.
  53. * Add a default stylesheet entry for the pagecloud.
  54. * Add examples page with some examples of things that can be done using
  55. ikiwiki, like a weblog. The examples can be copied into a user's wiki
  56. for a quick start, without needing to learn everything about how to put
  57. them together.
  58. * Install the source of the examples into /usr/share/doc/ikiwiki/examples.
  59. * Add perlmagick to build-depends so syntax check of img plugin works.
  60. Closes: #396702
  61. * Improve login/register process, the login dialog has only name and
  62. password fields, which allows more web browsers to regognise it as a login
  63. field, and is less confusing.
  64. * Implemented expiry options for aggregate plugin.
  65. * Use precalculated backlinks info when determining if files need an update
  66. due to a page they link to being added/removed. Mostly significant if
  67. there are lots of pages.
  68. * Remove duplicate link info when saving index. In some cases it could
  69. pile up rather badly. (Probably not the best way to deal with this
  70. problem.)
  71. * Patch from James Westby to support podcasting, photoblogging, vidcasting,
  72. or what have you, by creating enclosures for non-page items that are
  73. included in feeds.
  74. -- Joey Hess <joeyh@debian.org> Fri, 3 Nov 2006 14:46:37 -0500
  75. ikiwiki (1.31) unstable; urgency=low
  76. * Patch from Pawel Tecza to cp -a the templates in the Makefile.
  77. * Change the rss feed title from the wikiname to the page title, with
  78. an exception for the wiki's toplevel index page, which will still use the
  79. wikiname as the feed title.
  80. Overriding the page title with meta title already overrode the rss feed
  81. tittle.
  82. * Add an img plugin, based on Christian Mock's img plugin, but stripped
  83. down to the bare essentials. Useful for handling large images on websites.
  84. * Sanitize possibly problimatic characters out of the polygen grammar names,
  85. just in case. Should not be exploitable anyway, since it only tries to run
  86. polygen after finding the specified grammar file.
  87. * Add missing dependency on the URI perl module.
  88. * Add basic spam fighting tool for admins: An admin's prefs page now allows
  89. editing a list of banned users.
  90. -- Joey Hess <joeyh@debian.org> Fri, 27 Oct 2006 23:16:33 -0400
  91. ikiwiki (1.30) unstable; urgency=low
  92. * Add no_override parameter to hook().
  93. * Add a shortcut plugin, inspired by Victor Moral's contributed shortcuts
  94. plugin, but featuring a more ikiwiki-ish syntax and with shortcuts that
  95. can be configured using a page in wiki.
  96. * Fix support for --pingurl at the command line.
  97. * Fix a subtle bug in will_render that broke some builds, by only clearing
  98. items from renderedfiles the first time per build.
  99. * Wrap entire technortati ping operation in an eval to catch all possible
  100. failure modes, after I observed a simple ->value crashing ikiwiki when
  101. a ping failed.
  102. -- Joey Hess <joeyh@debian.org> Mon, 16 Oct 2006 15:17:38 -0400
  103. ikiwiki (1.29) unstable; urgency=low
  104. * Patch from Paul Tötterman to use CP in the Makefile.
  105. * Patch from Alec Berryman adding a http_auth config item that allows
  106. using HTTP Authentication instead of ikiwiki's built in authentication.
  107. Useful for eg, large sites with their own previously existing user auth
  108. setup. Closes: #384534
  109. * Change %renderedfiles to store an array of files rendered from a given
  110. source file, to allow tracking of extra rendered files like rss feeds.
  111. * Note that plugins that accessed this variable will need to be updated!
  112. The plugin interface has been increased to version 1.01 for this change.
  113. As few plugins use %renderedfiles I haven't done anything else to ensure
  114. compatability of old plugins.
  115. * Add will_render function to the plugin interface, used to register that a
  116. page renders a destination file, and do some security checks. Previously
  117. but no longer rendered files will be cleaned up.
  118. * Use will_render in the inline and linkmap plugins.
  119. * You will need to rebuild your wiki on upgrade to this version.
  120. * Atom feed support based on a patch by Clint Adams.
  121. * Add feeds=no option to inline preprocessor directive to turn off all types
  122. of feeds.
  123. * $IkiWiki::version now holds the program version, and is accessible to
  124. plugins.
  125. * Make the aggregate plugin emphasize error messages.
  126. * Patch from Recai to limit recentchanges to displaying max 10 files for a
  127. given changeset (to avoid large number of file changes excessively
  128. bloating the page).
  129. -- Joey Hess <joeyh@debian.org> Fri, 13 Oct 2006 23:14:28 -0400
  130. ikiwiki (1.28) unstable; urgency=low
  131. * inline: Add ability to sort by page name, based on a patch from
  132. Benjamin A'Lee.
  133. * Fix a forkbomb in various calls to IPC::Open2, which has a highly
  134. braindead interface. Closes: #389383
  135. * Don't rm -rf ikiwiki on distclean, since a) there's no such file
  136. and b) those poor Mac OSX users and their case insensative files!
  137. * Don't fail syntax check if Text::Typography isn't installed.
  138. Closes: #389406
  139. -- Joey Hess <joeyh@debian.org> Tue, 26 Sep 2006 02:08:17 -0400
  140. ikiwiki (1.27) unstable; urgency=low
  141. * Work on firming up the plugin interface:
  142. - Plugins should not need to load IkiWiki::Render to get commonly
  143. used functions, so moved some functions from there to IkiWiki.
  144. - Picked out the set of functions and variables that most plugins
  145. use, documented them, and made IkiWiki export them by default,
  146. like a proper perl module should.
  147. - Use the other functions at your own risk.
  148. - This is not quite complete, I still have to decide whether to
  149. export some other things.
  150. * Changed all plugins included in ikiwiki to not use "IkiWiki::" when
  151. referring to stuff now exported by the IkiWiki module.
  152. * Add a module version number to IkiWiki, so you can "use IkiWiki '1.00'"
  153. to declare which version of the interface your plugin needs.
  154. * Anyone with a third-party ikiwiki plugin is strongly encouraged
  155. to make like changes to it and avoid use of non-exported symbols from
  156. "IkiWiki::".
  157. * Link debian/changelog and debian/news to NEWS and CHANGELOG.
  158. * Support hyperestradier version 1.4.2, which adds a new required phraseform
  159. setting.
  160. * If an inlined page has a permalink, link the page title to that.
  161. * Patch from Recai to use utf8 when reading the setup file, so that
  162. utf8 wikinames from there will be used properly.
  163. * Patch from Recai to kill utf-8 on the wiki name when generating the
  164. session cookie.
  165. * Change ddate plugin to use the DateTime::Calendar::Discordian perl module.
  166. * Fix a baseurl problem in hyperestradier search results.
  167. * Add a stub local.css to avoid problems with 404's.
  168. * Patch from Recai to fix a wide character warning from the search plugin
  169. during setup if the wikiname contains utf8.
  170. * Yet another fix for those poor case-insensative OS X users.
  171. * pagetemplate hooks are now also called when generating cgi pages.
  172. * Add a favicon plugin, which simply adds a link tag for an icon to each
  173. page (and cgis).
  174. * Patch from James Westby to deal with the case where you're editing a
  175. new page, hit cancel, and need to be redirected to somewhere sane.
  176. * Various documentation improvements by various wiki users.
  177. * Support Text::Markdown from CPAN, which has a different interface from
  178. the original markdown or the one in Debian.
  179. * Version the libcgi-session-perl dependency, some features that need
  180. the new version are used in some cases (sslcookie).
  181. * Numerous tla fixes from Clint.
  182. * Updated ikiwiki.svgz from Recai, includes an icon and is used to generate
  183. a multi-resolution favicon.ico.
  184. * README.Debian: typo Closes: #388110
  185. * chomp trailing newline at the end of templates read in by the template
  186. plugin, to allow use of the template preprocessor directive in
  187. whitespace-sensative situations. Closes: #387073
  188. * Patch from James Westby to make the location of the estseek.cgi script
  189. configurable.
  190. * Add typography (SmartyPants) plugin by Recai.
  191. * Add --render mode, which can be used to preview an edit at the command
  192. line by test rendering a single page.
  193. * Add a googlecalendar plugin. A bit special-purpose, but it shows
  194. one way to to deal with user-supplied content that could cause XSS
  195. issues w/o the htmlscrubber, and won't survive the scrubber.
  196. -- Joey Hess <joeyh@debian.org> Sun, 24 Sep 2006 00:02:21 -0400
  197. ikiwiki (1.26) unstable; urgency=low
  198. * Add a missing -n to tla undo call.
  199. * otl2hmtl can't be safely used with IPC::Open2 since it sometimes
  200. writes before consuming its whole stdin. Avoid this deadlock.
  201. * Fix alt tags for outline checkboxes.
  202. -- Joey Hess <joeyh@debian.org> Fri, 8 Sep 2006 16:24:16 -0400
  203. ikiwiki (1.25) unstable; urgency=low
  204. * Add proper waitpid calls for open2ed processes throughout to avoid
  205. zombies; this hit htmltidy especially badly.
  206. * Drop real uid/gid in the suid wrapper, thus allowing commits to remote
  207. subversion repos and fixing some other issues.
  208. * Add support for tla, contributed by Clint Adams. Closes: #385936
  209. * Add support for mercurial, contributed by Emanuele Aina.
  210. * Include <link rel> tag for RSS feeds, used by some aggregators and
  211. firefox to find the feed.
  212. * Add a linkmap plugin (requires graphviz).
  213. -- Joey Hess <joeyh@debian.org> Fri, 8 Sep 2006 01:54:14 -0400
  214. ikiwiki (1.24) unstable; urgency=low
  215. * Simplify the data structure returned by rcs_recentchanges to avoid
  216. each rcs plugin needing to form complex strings on its own.
  217. * Fix another destpage issue in the inline directive. Closes: #385512
  218. again.
  219. -- Joey Hess <joeyh@debian.org> Sun, 3 Sep 2006 15:46:45 -0400
  220. ikiwiki (1.23) unstable; urgency=low
  221. * Allow inline directives to be nested inside eg, sidebars. Closes: #385512
  222. -- Joey Hess <joeyh@debian.org> Sun, 3 Sep 2006 12:14:45 -0400
  223. ikiwiki (1.22) unstable; urgency=low
  224. * Change how the stylesheet url is determined in the templates: Remove
  225. STYLEURL and add BASEURL to all templates (some already had it). This
  226. new more general variable can be used to link to other things (eg, images)
  227. from the template, as well as stylesheets.
  228. * Fix a bug introduced last version to do with nested inlines.
  229. * Allow preprocessor directives to span multiple lines, both to make
  230. long ones with lots of values easier to write, and to allow for ones with
  231. multi-line quoted values.
  232. * Allow preprocessor directives to contain python-like triple-quoted
  233. text blocks, for easy nesting of quotes inside.
  234. * Add a template plugin.
  235. * Make pagespec merge code smarter about merging duplicate pagespecs.
  236. * Patch from Jordà Polo to make Setup::Standard support hashes in config
  237. files.
  238. * Change order of linkify and preprocess; first preprocess and then linkify.
  239. This allows passing a wikilink inside a parameter to a preprocessor
  240. directive without it being expanded to html, and leaking out of the
  241. parameter, which had required some non-obvious use of triple-quoting
  242. to avoid. Note that any preprocessor plugins that output something
  243. that looks like a wikilink will now have it treated as such; AFAIK
  244. this doesn't change any behavior though except for the template plugin.
  245. * Enable preprocessor directives when previewing an edit.
  246. * Make all pages pull in a local.css style sheet, if present. This won't
  247. be included in ikiwiki, but can be created to make local styling changes
  248. w/o needing to merge in every new change to the distributed style.css.
  249. * Use DESTDIR and not PREFIX to specify installation prefix for packaging.
  250. * Support running "perl Makefile.PL PREFIX=foo" to build ikiwiki to run
  251. from a different directory.
  252. * Generalised preprocesser loop protection code.
  253. * Patch from James Westby to allow a description to be set for rss feeds.
  254. * Patch from James Westby to add a template for the search form.
  255. * Added a ddate plugin.
  256. * Patch from James Westby to add a --sslcookie switch, which forces
  257. cookies to only be sent over ssl connections to avoid interception.
  258. * Fix preferences page on anonok wikis; still need to sign in to get
  259. to the preferences page.
  260. * Add toc (table of contents) plugin.
  261. * Change htmlize, format, and sanitize hooks to use named parameters.
  262. * Patch from James Westby to add an actions option to inline; this
  263. adds Edit and Discussion links at the end of blog entries.
  264. * Due to some css changes, you'll want to rebuild your wiki on upgrade
  265. to this version. Will be handled automatically by the deb.
  266. * Add processed date to aggregate preprocessor directive status output.
  267. -- Joey Hess <joeyh@debian.org> Fri, 1 Sep 2006 22:03:34 -0400
  268. ikiwiki (1.21) unstable; urgency=low
  269. * Add a tail fin^W^Wsidebar plugin by Tuomo Valkonen.
  270. * If a page links to itself, mark up the link text in a span with
  271. class="selflink" so that it can be styled. I don't have a useful style
  272. defined for that though.
  273. * Call filter hooks on inlined page content.
  274. * Support inlining pages raw, rather than creating a blog.
  275. * Clean up yes/no parameter parsing in inline plugin.
  276. * Implemented better cycle detection in the inline plugin; nested inlines
  277. will now work.
  278. * Add a map plugin contributed by Alessandro Dotti Contra.
  279. * Add otl format plugin, which handles files as created by vimoutliner.
  280. * Fix ikiwiki-mass-rebuild to work in the way the postinst uses it.
  281. * Add first draft at a Restructured Text (rst) plugin, by Sergio
  282. Talens-Oliag. Note that this has many known issues -- see the caveats on
  283. the plugin's page.
  284. * Credit everyone who wrote a plugin on the plugins' wiki pages.
  285. * Fix utf-8 in blog post form.
  286. -- Joey Hess <joeyh@debian.org> Sun, 20 Aug 2006 16:42:54 -0400
  287. ikiwiki (1.20) unstable; urgency=low
  288. * Relicense the templates and basewiki under the 2-clause BSD license.
  289. Since these can easily become part of other people's websites, they
  290. should be under as permissive a license as possible.
  291. * Add --syslog config option, to log to the syslog.
  292. * Catch failing IPC::Open2 in tidy plugin and retry in case this is a
  293. transient failure to fork (which I've seen happen in the wild).
  294. * Fix a bug in the aggregator introduced last version that caused all
  295. aggregator state to be lost during a non-aggregating build.
  296. -- Joey Hess <joeyh@debian.org> Thu, 17 Aug 2006 19:05:56 -0400
  297. ikiwiki (1.19) unstable; urgency=low
  298. * Fix several related bugs in page type determination during online editing.
  299. * Add some locking to prevent 2 aggregators from running at once.
  300. * Fix an infinite loop in the aggregator when finding a unique filename.
  301. -- Joey Hess <joeyh@debian.org> Wed, 16 Aug 2006 13:46:25 -0400
  302. ikiwiki (1.18) unstable; urgency=low
  303. * The last release accidentially installed ikiwiki as ikiwiki.pl, now fixed.
  304. * Add --version.
  305. * Man page format fixups.
  306. * If the meta plugin overides the page title, set a title_overridden
  307. variable in the template to true. This allows doing things with the
  308. templates conditional on the title being overriden.
  309. * Add a %pagecase which maps lower-case page names to the actual case
  310. used in the filename. Use this in bestlinks calculation instead of
  311. forcing the link to lowercase.
  312. * Also use %pagecase in various other places that want to check if a page
  313. with a given name exists.
  314. * This means that links to pages with mixed case names will now work,
  315. even if the link is in some other case mixture, and mixed case pages
  316. should be fully supported throughout ikiwiki.
  317. * Recommend rebuilding wikis on upgrade to this version.
  318. -- Joey Hess <joeyh@debian.org> Sat, 12 Aug 2006 22:10:48 -0400
  319. ikiwiki (1.17) unstable; urgency=low
  320. * Disable tidy generator tag.
  321. * Move tidy back to sanitize hook, found out how to only show body.
  322. * Turn off tidy indentation too.
  323. * Turn on HTML::Template loop_context_vars; not actually used in stock
  324. templates but can be useful for things like making comma-delimited lists
  325. of tags or what have you.
  326. * Remove <br> from end of aggregate preprocessor directive output.
  327. * Ship ikiwiki executable as ikiwiki.pl in source to avoid issues on
  328. case-sensative filesystems like OSX.
  329. * Improve markdown loading. First, try to load it as a proper perl module,
  330. in case it was installed as one. Then fall back to trying
  331. /usr/bin/markdown.
  332. * Document in install page how to install markdown, since it has no
  333. installation procedure in the upstream tarball.
  334. * Set die_on_bad_params => 0 for all templates, to allow users to modify
  335. them without annoyances.
  336. * Suck in the page content when generating an inline archive page, to work
  337. around the meta plugin's lack of caching of title metadata across runs.
  338. -- Joey Hess <joeyh@debian.org> Sat, 12 Aug 2006 12:52:13 -0400
  339. ikiwiki (1.16) unstable; urgency=low
  340. * Try to handle relative links in aggregated feeds. However,
  341. the current support is a crude hack due to limitations of XML::Feed:
  342. xml:base is not supported, neither is Content-Location. And of course,
  343. relative links in RSS feeds are ill-undefined..
  344. * Make aggregator save permalinks and author name to pages as metadata.
  345. * Add permalink and author support to meta plugin, affecting RSS feeds
  346. and blog pages.
  347. * Various CSS and formatting changes.
  348. * Encode link and guid urls in rss feeds to avoid illegal utf8 slipping in.
  349. * Add xhtml files to the default prune regexp.
  350. * Also generate rel=bookmark links for permalinks.
  351. * Fix the htmltidy plugin, which wasn't working due my breaking it when
  352. I added it..
  353. * Don't run tidy with -xml as that fails if the input is not well-formed.
  354. Run it with -asxhtml instead, so it will output well-formed xhtml no
  355. matter what the input.
  356. * Disable tidy warnings too.
  357. * Add a new format hook, and make tidy use it, since tidy can really only
  358. operate on and output complete html documents, not the body chunks
  359. that sanitise gets.
  360. * Fix dates in rss feeds if running localised, so they're still rfc 822.
  361. -- Joey Hess <joeyh@debian.org> Fri, 4 Aug 2006 20:48:36 -0400
  362. ikiwiki (1.15) unstable; urgency=low
  363. * Remove CDPATH and other env vars perl taint checking doesn't like.
  364. Closes: #381279
  365. * Added created_before and created_after PageSpec limits.
  366. -- Joey Hess <joeyh@debian.org> Thu, 3 Aug 2006 13:00:57 -0400
  367. ikiwiki (1.14) unstable; urgency=low
  368. * Memoize pagespec translation, this speeds up a build of the ikiwiki tree
  369. by 10% or so.
  370. * Fix stupid bug in date matching, patch from Roland Mas. Closes: #381132
  371. * Added many unit tests for pagespec_match.
  372. -- Joey Hess <joeyh@debian.org> Wed, 2 Aug 2006 11:34:06 -0400
  373. ikiwiki (1.13) unstable; urgency=low
  374. * ikiwiki can now download and aggregate feeds with its new aggregate
  375. plugin, so it's possible to implement a Planet using ikiwiki!
  376. * Add a run_hooks function for the common task of running all hooks of a
  377. given type.
  378. * Add a savestate hook.
  379. * Don't put blog post forms on pages if there's no cgiurl set.
  380. * --setup --refresh no longer rebuilds wrappers. Use --setup --refresh
  381. --wrappers to do that.
  382. * Add %IkiWiki::forcerebuild to provide a way for plugins like aggregate
  383. to update pages that haven't changed on disk.
  384. * Change meta tags to use html entity-escaped text for values, so that
  385. quotes and such can be represented in title tags.
  386. * Depend and build-depend on HTML::Parser for HTML::Entities which is used
  387. for the above.
  388. * Make --rebuild also cause --aggregate to re-download and write aggregated
  389. pages.
  390. * Avoid outputting duplicate meta info.
  391. * Include title metadata on aggregated posts for capitalised and un-munged
  392. titles.
  393. * Title metadata of inlined pages now shows up in blogs and rss feeds.
  394. * Fix issue with unicode filenames and updating the hyper estradier search
  395. index. (Aka Please Please Please, let that be the last one.)
  396. * Patch from Roland Mas to support an rss=no parameter to inline directives.
  397. Closes: #380743
  398. * Renamed GlobLists to PageSpecs.
  399. * PageSpecs can now include nested parens, "and", and "or". This remains
  400. backwards compatible to the old GlobList format. It's implemented by
  401. treating the GlobList as a very limited microlanguage that is transformed
  402. to perl code that does the matching.
  403. * The old GlobList format is deprecated, and I encourage users to switch to
  404. using the new PageSpec format. Compatability with the old format will be
  405. removed at some point, possibly by 2.0.
  406. * Wiki rebuild needed on upgrade to this version due to PageSpec change.
  407. * Add support for creation_month and creation_year to PageSpec.
  408. Closes: #380680
  409. * Changes to index file encoding.
  410. -- Joey Hess <joeyh@debian.org> Tue, 1 Aug 2006 21:21:19 -0400
  411. ikiwiki (1.12) unstable; urgency=low
  412. "Viva l'Italia!"
  413. * New pagestats plugin from Enrico, which can generate a table counting
  414. the backlinks for each page, or a del.icio.us style cloud.
  415. * Build-depend on libtext-wikiformat-perl, so that the syntax check of
  416. the wikiformat plugin works. Thanks, Emanuele Aina.
  417. * Patch from Alessandro Dotti Contra to clean up backlinks and navbar
  418. display, running them through pagetitle. This removes ugly underscores and
  419. other gunk from the display, much nicer. You may want to rebuild your wiki
  420. when upgrading to get the cleanup globally.
  421. * Polygen plugin from Enrico.
  422. * htmltidy plugin from Faidon.
  423. * Locale patch from Faidon:
  424. - Adds a locale setting to setup files.
  425. - Proper local time, if the locale configuration option is used.
  426. - Support for UTF-8 (or ISO-8859-X) filenames in SVN. Before this patch,
  427. commiting (or even rcs_updating) on repositories with UTF-8 filenames was
  428. impossible.
  429. * Add getopt hook type, this allows plugins to add new command-line options.
  430. * Add --tagbase option to tag plugin.
  431. * Add exclude option in setup files, works same as --exclude.
  432. * Put categories in rss feeds for tagged items.
  433. * Allow preprocessor directives to be expanded in inlined blog pages.
  434. However, to avoid inlining loops etc, don't expand inline directives in
  435. inlined pages.
  436. * fortune plugin (trivial)
  437. * Tag plugins according to type.
  438. -- Joey Hess <joeyh@debian.org> Sat, 29 Jul 2006 17:12:56 -0400
  439. ikiwiki (1.11) unstable; urgency=low
  440. * Patch from Enrico that
  441. - Adds a tag plugin that allows more easily tagging pages.
  442. The meta plugin can also still be used for that, but the tag plugin
  443. also lists a page's tags at the bottom of the page.
  444. - Allows preprocessor directives to have parameters with no specified
  445. value.
  446. - Fixes preprocessor directive parameter parsing so that
  447. foo=bar baz now means "foo=bar" and a "baz" with no value.
  448. * Run pagetemplate hooks when inlining pages so that inlined pages also
  449. list their tags.
  450. * Make all plugins with pagetemplate hooks check that variables exist
  451. on the template before setting them, for robustness.
  452. * Switch pagetemplate hooks to using named parameters.
  453. * Pass a destpage parameter to preprocessor and pagetemplate hooks.
  454. This will be the page that a source page will be part of, which is
  455. different than the source page for inlined pages.
  456. * Audited all plugins to endure they pass (page, destpage) to htmllink
  457. appropriatly. This means inlining of various plugins will not work
  458. properly, with correct links generated.
  459. -- Joey Hess <joeyh@debian.org> Thu, 27 Jul 2006 20:51:23 -0400
  460. ikiwiki (1.10) unstable; urgency=low
  461. * Run page through any relevant filters when generating a page preview.
  462. * Noticed a bug in the wikitext markup plugin -- it made CamelCase links the
  463. default throughout the wiki, not only on wikitext pages. Decided to call
  464. this a feature, and split the camelcase support out into a separate plugin
  465. that is independant of wikitext.
  466. * Fix CamelCase regexp to not break [[FooBar|BazBar]] WikiLinks.
  467. -- Joey Hess <joeyh@debian.org> Wed, 26 Jul 2006 18:06:35 -0400
  468. ikiwiki (1.9) unstable; urgency=low
  469. * Improve display of parentlinks and page title of toplevel index page.
  470. * Patch from Faidon to use svn --limit when possible for recentchanges,
  471. speeds up recentchanges a lot for wikis with more history.
  472. * Patch from Recai to fix utf8 issues in git backend.
  473. * Add wikitext markup plugin, which supports ".wiki" pages written in the
  474. original wiki syntax, CamelCase links and all.
  475. * Support a w3mmode, which lets w3m run ikiwiki using its local CGI
  476. support, to edit pages etc without a web server.
  477. * Display CGI processing errors if present.
  478. * Fix from Faidon for a XML parser issue that breaks utf-8 for
  479. RecentChanges. Avoid using XML::SAX::PurePerl, which is buggy in this
  480. area, and also way slow.
  481. * Match 'web commit from' in SVN and git, these are web commits too.
  482. (Faidon)
  483. * Consolidated all decode_utf8 in FormBuilder's fields to make the code more
  484. readable and avoid future mistakes. The patch seems to work and for the
  485. first time I have a UTF-8 username ;-) (Faidon)
  486. * Use form->field consistently, not form->param.
  487. * Patch from Recai to allow selection of page type when creating a new page.
  488. Default page type is inherited from the link clicked on to create the new
  489. page.
  490. -- Joey Hess <joeyh@debian.org> Wed, 26 Jul 2006 17:25:30 -0400
  491. ikiwiki (1.8) unstable; urgency=low
  492. * Fix orphans plugin to not count a link to a nonexistant page as a reason
  493. for a page not being an orphan.
  494. * Support pinging services such as Technorati using XML-RPC to notify them
  495. about changes to rss feeds.
  496. * Parse svn log as xml for improved utf8 and security. Note that this makes
  497. ikiwiki depend on XML::Simple. Patch by Faidon Liambotis.
  498. * POSIX::strftime doesn't know about encodings and doesn't return a utf8
  499. flagged string even if the locale causes it to generate utf8 output,
  500. so make sure to let perl know it should be handled as utf8. Also,
  501. the optimised version used for standard time formats won't work if the
  502. user has changed locale, so drop it. Thanks, Faidon Liambotis.
  503. * Fix re-encoding of the comments field to utf8 if a commit fails
  504. due to a conflict. Thanks, Faidon Liambotis.
  505. * Let svn know that commits have utf8 commit messages. Thanks, Faidon
  506. Liambotis.
  507. * Add insane double encode/decode to utf8 around call to markdown.
  508. This works around a truely strange bug, which is apparently a bug in
  509. perl, #376329. Also added a test case for it.
  510. * Improve layout of edit page so formatting help link is always visible w/o
  511. getting in the way of the preview.
  512. * Centralised all calls to HTML::Template and force all the templates
  513. to be read as utf8.
  514. * Support pages with utf8 filenames. Patch by Faidon Liambotis.
  515. * Introduce add_plugins and disable_plugins config options in setup files.
  516. This allows adding or removing plugins w/o overriding the whole list of
  517. default plugins, which makes it easier to upgrade when new default plugins
  518. are added.
  519. * Support htmlize plugins and make mdwn one such plugin, which is enabled by
  520. default (of course!). Based on a patch by Faidon Liambotis.
  521. * Add a html plugin, which can be used to write wikis in raw html,
  522. if you'd ever want to do such a thing. Slightly tricky, since ikiwiki
  523. defaults to not processing .html files, since w/o this plugin they would
  524. be copied unsanitised. With this plugin, it will process and html
  525. sanitise them, like any other page type.
  526. * Rebuilding wrappers is necessary on upgrade to this version.
  527. * Make ikiwiki --setup --refresh rebuild wrappers, so wrapper rebuild
  528. will be automatically done on all upgrades.
  529. * Don't send pings if the wiki is being rebuilt.
  530. * Work around very innefficient behavior in File::Spec::abs2rel. Result
  531. is a savings of 2 pointless fork/execs per link calculation, which
  532. results in ~25% speedup of ikiwiki building its own doc wiki, and
  533. about 35% speedup displaying RecentChanges!
  534. * Make RecentChanges use a table and some CSS, should be much more readable.
  535. No code changes involved.
  536. * Encode & in diffurl in examples, to conform to pedantic rules.
  537. * Speed up RecentChanges by another 40% or so with some memoization.
  538. * Memoize abs2rel, which is still kinda slow, for another 30% speedup
  539. in time to build the doc wiki.
  540. -- Joey Hess <joeyh@debian.org> Tue, 4 Jul 2006 12:46:29 -0400
  541. ikiwiki (1.7) unstable; urgency=low
  542. * Updated logo from Recai with some kerning and alingment tuning.
  543. * Patch from Recai to fix git recentchanges code to work with git 1.4 which
  544. changed some output.
  545. * Copyright update.
  546. -- Joey Hess <joeyh@debian.org> Sun, 18 Jun 2006 23:33:35 -0400
  547. ikiwiki (1.6) unstable; urgency=low
  548. * YA utf-8 patch from Recai, this time to fix previewing a page so that
  549. the text in the input box is re-encoded back to utf-8.
  550. * -CSD does not affect modules, so readfile() was not using the utf-8 input
  551. layer, which led to lots of problems; make it force read files as utf-8.
  552. Closes: #373203
  553. * Note that as a consequence, this version of ikiwiki will actually try to
  554. parse utf8 in source files for the first time, which may expose broken
  555. utf8 in wiki sources that was hidden before. Most common will be
  556. perl warnings like "utf8 "\xE9" does not map to Unicode"
  557. * writefile() likewise needs to use the utf8 output layer.
  558. * Remove the -CSD from ikiwiki's hashbang since it's useless to have it
  559. there.
  560. * Revert some of the decode_utf8 changes in CGI.pm that seem unnecessary
  561. given the readfile fix.
  562. * Add utf-8 testcases for readfile and htmlize.
  563. * Put back the encode_utf8 in the input to markdown; it's really not utf-8
  564. safe.
  565. * More utf-8 fixes from Recai, partly to things I broke above:
  566. - The serious problem is that writefile() saves the content in undecoded
  567. format in CGI, hence all (non-ascii) chars are corrupted permanently.
  568. - Comment field in edit page is not decoded and all the non-ascii chars in
  569. this field are corrupted as the result. We should decode it as we do it
  570. for the content.
  571. - Add 'use encoding "utf8"' to CGI.pm to avoid warnings about wide
  572. character in print.
  573. * New SVG logo from Recai.
  574. -- Joey Hess <joeyh@debian.org> Sun, 18 Jun 2006 19:18:46 -0400
  575. ikiwiki (1.5) unstable; urgency=low
  576. * Add --timeformat config option to allow changing how dates are displayed.
  577. Note that as a side effect, dates will now be displayed using the local
  578. timezone, not as GMT.
  579. * More security review.
  580. * Patch from Dr. Zini to add link() and backlink() to globlists. This allows
  581. for some handy stuff like:
  582. - Using links as a kind of tag; creating blog pages that list all pages
  583. containing a given tag/link or not containing some other tag.
  584. - Subscribing to mail notifications whenever a change is made to a page
  585. that is a backlink of page foo. Ie, "Please notify me of changes in all
  586. pages that link to my home page in the wiki"
  587. - Locking any pages that are linked to from a particular page, so that
  588. lists of locks can be exposed in the wiki.
  589. * Reorganised the doc wiki's todo/* pages, using a link/tag to flag
  590. when a todo item is done, instead of the previous moving it to a different
  591. subdir.
  592. * Allow pagetemplate plugins to override *anything* in the template.
  593. * Add a meta plugin, which allows specifying various metadata about pages,
  594. like license and author. It also allows for inserting html link and meta
  595. tags into html, overriding the title, and adding hidden WikiLinks, which
  596. can be useful when using link-based globbing for page categorisation.
  597. * Remove preprocessor directives from inlined pages.
  598. * Allow simple preprocessor directive values to be specified w/o quotes.
  599. * Add support for using git instead of subversion as the RCS backend,
  600. tremendous thanks to Recai Oktaş for this.
  601. * Doc updates for git.
  602. * Fix absolute url munging in rss generation to support https, ftp, etc urls
  603. not just http urls.
  604. * Patch from Recai Oktaş to improve utf-8 support, it should now use proper
  605. utf-8 for edit and other fields, and for recentchanges. There may still
  606. be utf-8 issues with the preferences page though.
  607. -- Joey Hess <joeyh@debian.org> Sun, 11 Jun 2006 19:56:54 -0400
  608. ikiwiki (1.4) unstable; urgency=low
  609. * Tell HTML::Scrubber to treat "/" as a valid attribute which is its
  610. very strange way of enabling proper XHTML <br /> type tags. Output html
  611. should be always valid again now.
  612. * The page name and parent links has switched from using a <h1> to a styled
  613. <span>, so pages can use <h1> internally instead of needing to use <h2>.
  614. * Updated all of ikiwiki's own wiki pages for that.
  615. * Add pagetemplate hook, which can be used by plugins that want to mess
  616. around with adding new stuff to the page template.
  617. * Remove headercontent; the search plugin now adds the search box to the
  618. header by registering a pagetemplate hook, and other plugins should do
  619. similarly.
  620. * Rebuilding on upgrade to this version is recommended.
  621. * Add a html validity check to the test suite, using the wdg-html-validator,
  622. if available.
  623. * Make the html valid when there is nothing in the actions list.
  624. * Reordered some function call parameters for consistency.
  625. * Enable full utf-8 support for page input and output.
  626. * Add a workaround for markdown, which does not work well with utf-8
  627. strings.
  628. * --getctime had bitrotted (well I only ever used it the once so far..),
  629. fix and make it a bit more flexible
  630. * rcs_getctime is changed, now rather than needing to loop over all pages,
  631. it should just use the rcs to get the ctime of the passed file.
  632. * When inlining a page in another one, links from the inlined page are now
  633. expanded the same as they are when rendering the inlined page as a
  634. standalone page. So rather than being expanded from the POV of the
  635. inlining page, they are expanded from the POV of the inlined page.
  636. For example, a link from blog/foo to "bar" will now link to blog/bar
  637. if it exists. Previously this needed to be a link explicitly to
  638. "blog/bar"; such links will also continue to work.
  639. (This was slightly complex to do as the link still has to be constructed
  640. relative to the inlining page.)
  641. * Make page edit textarea resize to fit browser window.
  642. * Add -refresh option to ikiwiki-mass-rebuild and use that on upgrades that
  643. do not need a full rebuild, in order to update any basewiki pages.
  644. -- Joey Hess <joeyh@debian.org> Sat, 27 May 2006 15:08:49 -0400
  645. ikiwiki (1.3) unstable; urgency=low
  646. * Fix the preinst introduced in the last version. Closes: #367458
  647. -- Joey Hess <joeyh@debian.org> Tue, 16 May 2006 02:43:02 -0500
  648. ikiwiki (1.2) unstable; urgency=low
  649. * Remove dups from the brokenlinks list.
  650. * Add libc6-dev to dependencies, needed to build wrappers.
  651. * Install wikilist in correct location. Closes: #367371
  652. -- Joey Hess <joeyh@debian.org> Mon, 15 May 2006 10:53:49 -0500
  653. ikiwiki (1.1) unstable; urgency=low
  654. * Rename inlinepage to depends, so that it can be used to refer to more
  655. dependency relationships than just inlining. This will require a rebuild
  656. on upgrade to this version.
  657. * Move the rss link, put it in the blogpost form if there is one and at the
  658. top if not. This is both nicer because easier to find, and it cleans up
  659. the code which had used inlinepage as a flag for adding the link later.
  660. * Allow the depends GlobList to be built up from multiple sources (such as
  661. plugins) during a page render.
  662. * Which means that more than one blog is now supported to appear on a
  663. single page. (With some limitations, like only the last one getting an
  664. rss file.)
  665. * Added a plugin system.
  666. * Added a pagecount plugin, enabled by default.
  667. * Support PreProcessorDirectives with no parameters, ie "[[pagecount ]]".
  668. * Fixed/optimised backlinks code, to avoid rebuilding pages to update
  669. backlinks when the backlinks hadn't really changed.
  670. * Moved inline page support, rss generation etc into the inline plugin,
  671. enabled by default.
  672. * Added brokenlinks plugin, not enabled by default, but rather handy.
  673. * Fix several broken links in the doc wiki.
  674. * Smarter behavior when creating a page and a page of the same name (but
  675. different location) already exists.
  676. * Add an orphans plugin for finding pages that nothing links to.
  677. * Removed backlinks page, which it turns out nothing used.
  678. * Split off an IkiWiki.pm out of ikiwiki and have all the other modules use
  679. it, this will allow for adding a unit test suite.
  680. * Add unit tests for several core functions, including globlist_match,
  681. dirname, basename, bestlink, linkify, pagetitle, titlepage.
  682. * Smart globlist merging.
  683. * Patch from Thomas Schwinge to switch from --svn to --rcs=svn, etc,
  684. to pave the way for adding other RCS support. This also changes the
  685. setup files, where before they had svn => 1 or svn => 0, now they have
  686. rcs => "svn" or rcs => "".
  687. * Add a debian/NEWS file with upgrade notes.
  688. * Load whatever rcs module is specified, so new ones can be just dropped in
  689. as plugins and work. (Well, in theory.)
  690. * Add some basic docs about writing RCS modules.
  691. * Broke search capability out into a plugin, removed the --hyperestraier
  692. switch.
  693. * Added smiley plugin, nicely controlled and documented by the smileys page.
  694. * Copied in some smileys from Moin Moin.
  695. * Allow links of the form [[some page|page]], with whitespace in the link
  696. text.
  697. * Removed --sanitize and --no-sanitize, replaced with --plugin htmlscrubber
  698. and --disable-plugin htmlscrubber.
  699. * Allow discussion links on pages to be turned off with --no-discussion.
  700. * Add ikiwiki-mass-rebuild script, ripped out of the postinst.
  701. * Add some new config items to the estseek.conf template, which are needed
  702. by hyperestraier 1.2.3.
  703. -- Joey Hess <joeyh@debian.org> Fri, 5 May 2006 17:00:41 -0400
  704. ikiwiki (1.0) unstable; urgency=low
  705. * First official release.
  706. -- Joey Hess <joeyh@debian.org> Tue, 25 Apr 2006 02:08:17 -0400