summaryrefslogtreecommitdiff
path: root/debian/changelog
blob: 40247ffabc957e6dd746e853d988203e42b4b1b5 (plain)
  1. ikiwiki (1.8) UNRELEASED; urgency=low
  2. * Fix orphans plugin to not count a link to a nonexistant page as a reason
  3. for a page not being an orphan.
  4. * Support pinging services such as Technorati using XML-RPC to notify them
  5. about changes to rss feeds.
  6. * Parse svn log as xml for improved utf8 and security. Note that this makes
  7. ikiwiki depend on XML::Simple. Patch by Faidon Liambotis.
  8. * POSIX::strftime doesn't know about encodings and doesn't return a utf8
  9. flagged string even if the locale causes it to generate utf8 output,
  10. so make sure to let perl know it should be handled as utf8. Also,
  11. the optimised version used for standard time formats won't work if the
  12. user has changed locale, so drop it. Thanks, Faidon Liambotis.
  13. * Fix re-encoding of the comments field to utf8 if a commit fails
  14. due to a conflict. Thanks, Faidon Liambotis.
  15. * Let svn know that commits have utf8 commit messages. Thanks, Faidon
  16. Liambotis.
  17. * Add insane double encode/decode to utf8 around call to markdown.
  18. This works around a truely strange bug, which is apparently a bug in
  19. perl, #376329. Also added a test case for it.
  20. * Improve layout of edit page so formatting help link is always visible w/o
  21. getting in the way of the preview.
  22. * Centralised all calls to HTML::Template and force all the templates
  23. to be read as utf8.
  24. * Support pages with utf8 filenames. Patch by Faidon Liambotis.
  25. * Introduce add_plugins and disable_plugins config options in setup files.
  26. This allows adding or removing plugins w/o overriding the whole list of
  27. default plugins, which makes it easier to upgrade when new default plugins
  28. are added.
  29. * Support htmlize plugins and make mdwn one such plugin, which is enabled by
  30. default (of course!). Based on a patch by Faidon Liambotis.
  31. * Add a html plugin, which can be used to write wikis in raw html,
  32. if you'd ever want to do such a thing. Slightly tricky, since ikiwiki
  33. defaults to not processing .html files, since w/o this plugin they would
  34. be copied unsanitised. With this plugin, it will process and html
  35. sanitise them, like any other page type.
  36. * Rebuilding wrappers is necessary on upgrade to this version.
  37. * Make ikiwiki --setup --refresh rebuild wrappers, so wrapper rebuild
  38. will be automatically done on all upgrades.
  39. * Don't send pings if the wiki is being rebuilt.
  40. * Work around very innefficient behavior in File::Spec::abs2rel. Result
  41. is a savings of 2 pointless fork/execs per link calculation, which
  42. results in ~25% speedup of ikiwiki building its own doc wiki, and
  43. about 35% speedup displaying RecentChanges!
  44. * Make RecentChanges use a table and some CSS, should be much more readable.
  45. No code changes involved.
  46. * Encode & in diffurl in examples, to conform to pedantic rules.
  47. -- Joey Hess <joeyh@debian.org> Tue, 4 Jul 2006 01:42:28 -0400
  48. ikiwiki (1.7) unstable; urgency=low
  49. * Updated logo from Recai with some kerning and alingment tuning.
  50. * Patch from Recai to fix git recentchanges code to work with git 1.4 which
  51. changed some output.
  52. * Copyright update.
  53. -- Joey Hess <joeyh@debian.org> Sun, 18 Jun 2006 23:33:35 -0400
  54. ikiwiki (1.6) unstable; urgency=low
  55. * YA utf-8 patch from Recai, this time to fix previewing a page so that
  56. the text in the input box is re-encoded back to utf-8.
  57. * -CSD does not affect modules, so readfile() was not using the utf-8 input
  58. layer, which led to lots of problems; make it force read files as utf-8.
  59. Closes: #373203
  60. * Note that as a consequence, this version of ikiwiki will actually try to
  61. parse utf8 in source files for the first time, which may expose broken
  62. utf8 in wiki sources that was hidden before. Most common will be
  63. perl warnings like "utf8 "\xE9" does not map to Unicode"
  64. * writefile() likewise needs to use the utf8 output layer.
  65. * Remove the -CSD from ikiwiki's hashbang since it's useless to have it
  66. there.
  67. * Revert some of the decode_utf8 changes in CGI.pm that seem unnecessary
  68. given the readfile fix.
  69. * Add utf-8 testcases for readfile and htmlize.
  70. * Put back the encode_utf8 in the input to markdown; it's really not utf-8
  71. safe.
  72. * More utf-8 fixes from Recai, partly to things I broke above:
  73. - The serious problem is that writefile() saves the content in undecoded
  74. format in CGI, hence all (non-ascii) chars are corrupted permanently.
  75. - Comment field in edit page is not decoded and all the non-ascii chars in
  76. this field are corrupted as the result. We should decode it as we do it
  77. for the content.
  78. - Add 'use encoding "utf8"' to CGI.pm to avoid warnings about wide
  79. character in print.
  80. * New SVG logo from Recai.
  81. -- Joey Hess <joeyh@debian.org> Sun, 18 Jun 2006 19:18:46 -0400
  82. ikiwiki (1.5) unstable; urgency=low
  83. * Add --timeformat config option to allow changing how dates are displayed.
  84. Note that as a side effect, dates will now be displayed using the local
  85. timezone, not as GMT.
  86. * More security review.
  87. * Patch from Dr. Zini to add link() and backlink() to globlists. This allows
  88. for some handy stuff like:
  89. - Using links as a kind of tag; creating blog pages that list all pages
  90. containing a given tag/link or not containing some other tag.
  91. - Subscribing to mail notifications whenever a change is made to a page
  92. that is a backlink of page foo. Ie, "Please notify me of changes in all
  93. pages that link to my home page in the wiki"
  94. - Locking any pages that are linked to from a particular page, so that
  95. lists of locks can be exposed in the wiki.
  96. * Reorganised the doc wiki's todo/* pages, using a link/tag to flag
  97. when a todo item is done, instead of the previous moving it to a different
  98. subdir.
  99. * Allow pagetemplate plugins to override *anything* in the template.
  100. * Add a meta plugin, which allows specifying various metadata about pages,
  101. like license and author. It also allows for inserting html link and meta
  102. tags into html, overriding the title, and adding hidden WikiLinks, which
  103. can be useful when using link-based globbing for page categorisation.
  104. * Remove preprocessor directives from inlined pages.
  105. * Allow simple preprocessor directive values to be specified w/o quotes.
  106. * Add support for using git instead of subversion as the RCS backend,
  107. tremendous thanks to Recai Oktaş for this.
  108. * Doc updates for git.
  109. * Fix absolute url munging in rss generation to support https, ftp, etc urls
  110. not just http urls.
  111. * Patch from Recai Oktaş to improve utf-8 support, it should now use proper
  112. utf-8 for edit and other fields, and for recentchanges. There may still
  113. be utf-8 issues with the preferences page though.
  114. -- Joey Hess <joeyh@debian.org> Sun, 11 Jun 2006 19:56:54 -0400
  115. ikiwiki (1.4) unstable; urgency=low
  116. * Tell HTML::Scrubber to treat "/" as a valid attribute which is its
  117. very strange way of enabling proper XHTML <br /> type tags. Output html
  118. should be always valid again now.
  119. * The page name and parent links has switched from using a <h1> to a styled
  120. <span>, so pages can use <h1> internally instead of needing to use <h2>.
  121. * Updated all of ikiwiki's own wiki pages for that.
  122. * Add pagetemplate hook, which can be used by plugins that want to mess
  123. around with adding new stuff to the page template.
  124. * Remove headercontent; the search plugin now adds the search box to the
  125. header by registering a pagetemplate hook, and other plugins should do
  126. similarly.
  127. * Rebuilding on upgrade to this version is recommended.
  128. * Add a html validity check to the test suite, using the wdg-html-validator,
  129. if available.
  130. * Make the html valid when there is nothing in the actions list.
  131. * Reordered some function call parameters for consistency.
  132. * Enable full utf-8 support for page input and output.
  133. * Add a workaround for markdown, which does not work well with utf-8
  134. strings.
  135. * --getctime had bitrotted (well I only ever used it the once so far..),
  136. fix and make it a bit more flexible
  137. * rcs_getctime is changed, now rather than needing to loop over all pages,
  138. it should just use the rcs to get the ctime of the passed file.
  139. * When inlining a page in another one, links from the inlined page are now
  140. expanded the same as they are when rendering the inlined page as a
  141. standalone page. So rather than being expanded from the POV of the
  142. inlining page, they are expanded from the POV of the inlined page.
  143. For example, a link from blog/foo to "bar" will now link to blog/bar
  144. if it exists. Previously this needed to be a link explicitly to
  145. "blog/bar"; such links will also continue to work.
  146. (This was slightly complex to do as the link still has to be constructed
  147. relative to the inlining page.)
  148. * Make page edit textarea resize to fit browser window.
  149. * Add -refresh option to ikiwiki-mass-rebuild and use that on upgrades that
  150. do not need a full rebuild, in order to update any basewiki pages.
  151. -- Joey Hess <joeyh@debian.org> Sat, 27 May 2006 15:08:49 -0400
  152. ikiwiki (1.3) unstable; urgency=low
  153. * Fix the preinst introduced in the last version. Closes: #367458
  154. -- Joey Hess <joeyh@debian.org> Tue, 16 May 2006 02:43:02 -0500
  155. ikiwiki (1.2) unstable; urgency=low
  156. * Remove dups from the brokenlinks list.
  157. * Add libc6-dev to dependencies, needed to build wrappers.
  158. * Install wikilist in correct location. Closes: #367371
  159. -- Joey Hess <joeyh@debian.org> Mon, 15 May 2006 10:53:49 -0500
  160. ikiwiki (1.1) unstable; urgency=low
  161. * Rename inlinepage to depends, so that it can be used to refer to more
  162. dependency relationships than just inlining. This will require a rebuild
  163. on upgrade to this version.
  164. * Move the rss link, put it in the blogpost form if there is one and at the
  165. top if not. This is both nicer because easier to find, and it cleans up
  166. the code which had used inlinepage as a flag for adding the link later.
  167. * Allow the depends GlobList to be built up from multiple sources (such as
  168. plugins) during a page render.
  169. * Which means that more than one blog is now supported to appear on a
  170. single page. (With some limitations, like only the last one getting an
  171. rss file.)
  172. * Added a plugin system.
  173. * Added a pagecount plugin, enabled by default.
  174. * Support PreProcessorDirectives with no parameters, ie "[[pagecount ]]".
  175. * Fixed/optimised backlinks code, to avoid rebuilding pages to update
  176. backlinks when the backlinks hadn't really changed.
  177. * Moved inline page support, rss generation etc into the inline plugin,
  178. enabled by default.
  179. * Added brokenlinks plugin, not enabled by default, but rather handy.
  180. * Fix several broken links in the doc wiki.
  181. * Smarter behavior when creating a page and a page of the same name (but
  182. different location) already exists.
  183. * Add an orphans plugin for finding pages that nothing links to.
  184. * Removed backlinks page, which it turns out nothing used.
  185. * Split off an IkiWiki.pm out of ikiwiki and have all the other modules use
  186. it, this will allow for adding a unit test suite.
  187. * Add unit tests for several core functions, including globlist_match,
  188. dirname, basename, bestlink, linkify, pagetitle, titlepage.
  189. * Smart globlist merging.
  190. * Patch from Thomas Schwinge to switch from --svn to --rcs=svn, etc,
  191. to pave the way for adding other RCS support. This also changes the
  192. setup files, where before they had svn => 1 or svn => 0, now they have
  193. rcs => "svn" or rcs => "".
  194. * Add a debian/NEWS file with upgrade notes.
  195. * Load whatever rcs module is specified, so new ones can be just dropped in
  196. as plugins and work. (Well, in theory.)
  197. * Add some basic docs about writing RCS modules.
  198. * Broke search capability out into a plugin, removed the --hyperestraier
  199. switch.
  200. * Added smiley plugin, nicely controlled and documented by the smileys page.
  201. * Copied in some smileys from Moin Moin.
  202. * Allow links of the form [[some page|page]], with whitespace in the link
  203. text.
  204. * Removed --sanitize and --no-sanitize, replaced with --plugin htmlscrubber
  205. and --disable-plugin htmlscrubber.
  206. * Allow discussion links on pages to be turned off with --no-discussion.
  207. * Add ikiwiki-mass-rebuild script, ripped out of the postinst.
  208. * Add some new config items to the estseek.conf template, which are needed
  209. by hyperestraier 1.2.3.
  210. -- Joey Hess <joeyh@debian.org> Fri, 5 May 2006 17:00:41 -0400
  211. ikiwiki (1.0) unstable; urgency=low
  212. * First official release.
  213. -- Joey Hess <joeyh@debian.org> Tue, 25 Apr 2006 02:08:17 -0400