summaryrefslogtreecommitdiff
path: root/debian/changelog
blob: 4d1cea8a9b8712e448025e80a5593eb510cc5850 (plain)
  1. ikiwiki (1.9) UNRELEASED; urgency=low
  2. * Improve display of parentlinks and page title of toplevel index page.
  3. * Patch from Faidon to use svn --limit when possible for recentchanges,
  4. speeds up recentchanges a lot for wikis with more history.
  5. -- Joey Hess <joeyh@debian.org> Wed, 5 Jul 2006 13:33:59 -0400
  6. ikiwiki (1.8) unstable; urgency=low
  7. * Fix orphans plugin to not count a link to a nonexistant page as a reason
  8. for a page not being an orphan.
  9. * Support pinging services such as Technorati using XML-RPC to notify them
  10. about changes to rss feeds.
  11. * Parse svn log as xml for improved utf8 and security. Note that this makes
  12. ikiwiki depend on XML::Simple. Patch by Faidon Liambotis.
  13. * POSIX::strftime doesn't know about encodings and doesn't return a utf8
  14. flagged string even if the locale causes it to generate utf8 output,
  15. so make sure to let perl know it should be handled as utf8. Also,
  16. the optimised version used for standard time formats won't work if the
  17. user has changed locale, so drop it. Thanks, Faidon Liambotis.
  18. * Fix re-encoding of the comments field to utf8 if a commit fails
  19. due to a conflict. Thanks, Faidon Liambotis.
  20. * Let svn know that commits have utf8 commit messages. Thanks, Faidon
  21. Liambotis.
  22. * Add insane double encode/decode to utf8 around call to markdown.
  23. This works around a truely strange bug, which is apparently a bug in
  24. perl, #376329. Also added a test case for it.
  25. * Improve layout of edit page so formatting help link is always visible w/o
  26. getting in the way of the preview.
  27. * Centralised all calls to HTML::Template and force all the templates
  28. to be read as utf8.
  29. * Support pages with utf8 filenames. Patch by Faidon Liambotis.
  30. * Introduce add_plugins and disable_plugins config options in setup files.
  31. This allows adding or removing plugins w/o overriding the whole list of
  32. default plugins, which makes it easier to upgrade when new default plugins
  33. are added.
  34. * Support htmlize plugins and make mdwn one such plugin, which is enabled by
  35. default (of course!). Based on a patch by Faidon Liambotis.
  36. * Add a html plugin, which can be used to write wikis in raw html,
  37. if you'd ever want to do such a thing. Slightly tricky, since ikiwiki
  38. defaults to not processing .html files, since w/o this plugin they would
  39. be copied unsanitised. With this plugin, it will process and html
  40. sanitise them, like any other page type.
  41. * Rebuilding wrappers is necessary on upgrade to this version.
  42. * Make ikiwiki --setup --refresh rebuild wrappers, so wrapper rebuild
  43. will be automatically done on all upgrades.
  44. * Don't send pings if the wiki is being rebuilt.
  45. * Work around very innefficient behavior in File::Spec::abs2rel. Result
  46. is a savings of 2 pointless fork/execs per link calculation, which
  47. results in ~25% speedup of ikiwiki building its own doc wiki, and
  48. about 35% speedup displaying RecentChanges!
  49. * Make RecentChanges use a table and some CSS, should be much more readable.
  50. No code changes involved.
  51. * Encode & in diffurl in examples, to conform to pedantic rules.
  52. * Speed up RecentChanges by another 40% or so with some memoization.
  53. * Memoize abs2rel, which is still kinda slow, for another 30% speedup
  54. in time to build the doc wiki.
  55. -- Joey Hess <joeyh@debian.org> Tue, 4 Jul 2006 12:46:29 -0400
  56. ikiwiki (1.7) unstable; urgency=low
  57. * Updated logo from Recai with some kerning and alingment tuning.
  58. * Patch from Recai to fix git recentchanges code to work with git 1.4 which
  59. changed some output.
  60. * Copyright update.
  61. -- Joey Hess <joeyh@debian.org> Sun, 18 Jun 2006 23:33:35 -0400
  62. ikiwiki (1.6) unstable; urgency=low
  63. * YA utf-8 patch from Recai, this time to fix previewing a page so that
  64. the text in the input box is re-encoded back to utf-8.
  65. * -CSD does not affect modules, so readfile() was not using the utf-8 input
  66. layer, which led to lots of problems; make it force read files as utf-8.
  67. Closes: #373203
  68. * Note that as a consequence, this version of ikiwiki will actually try to
  69. parse utf8 in source files for the first time, which may expose broken
  70. utf8 in wiki sources that was hidden before. Most common will be
  71. perl warnings like "utf8 "\xE9" does not map to Unicode"
  72. * writefile() likewise needs to use the utf8 output layer.
  73. * Remove the -CSD from ikiwiki's hashbang since it's useless to have it
  74. there.
  75. * Revert some of the decode_utf8 changes in CGI.pm that seem unnecessary
  76. given the readfile fix.
  77. * Add utf-8 testcases for readfile and htmlize.
  78. * Put back the encode_utf8 in the input to markdown; it's really not utf-8
  79. safe.
  80. * More utf-8 fixes from Recai, partly to things I broke above:
  81. - The serious problem is that writefile() saves the content in undecoded
  82. format in CGI, hence all (non-ascii) chars are corrupted permanently.
  83. - Comment field in edit page is not decoded and all the non-ascii chars in
  84. this field are corrupted as the result. We should decode it as we do it
  85. for the content.
  86. - Add 'use encoding "utf8"' to CGI.pm to avoid warnings about wide
  87. character in print.
  88. * New SVG logo from Recai.
  89. -- Joey Hess <joeyh@debian.org> Sun, 18 Jun 2006 19:18:46 -0400
  90. ikiwiki (1.5) unstable; urgency=low
  91. * Add --timeformat config option to allow changing how dates are displayed.
  92. Note that as a side effect, dates will now be displayed using the local
  93. timezone, not as GMT.
  94. * More security review.
  95. * Patch from Dr. Zini to add link() and backlink() to globlists. This allows
  96. for some handy stuff like:
  97. - Using links as a kind of tag; creating blog pages that list all pages
  98. containing a given tag/link or not containing some other tag.
  99. - Subscribing to mail notifications whenever a change is made to a page
  100. that is a backlink of page foo. Ie, "Please notify me of changes in all
  101. pages that link to my home page in the wiki"
  102. - Locking any pages that are linked to from a particular page, so that
  103. lists of locks can be exposed in the wiki.
  104. * Reorganised the doc wiki's todo/* pages, using a link/tag to flag
  105. when a todo item is done, instead of the previous moving it to a different
  106. subdir.
  107. * Allow pagetemplate plugins to override *anything* in the template.
  108. * Add a meta plugin, which allows specifying various metadata about pages,
  109. like license and author. It also allows for inserting html link and meta
  110. tags into html, overriding the title, and adding hidden WikiLinks, which
  111. can be useful when using link-based globbing for page categorisation.
  112. * Remove preprocessor directives from inlined pages.
  113. * Allow simple preprocessor directive values to be specified w/o quotes.
  114. * Add support for using git instead of subversion as the RCS backend,
  115. tremendous thanks to Recai Oktaş for this.
  116. * Doc updates for git.
  117. * Fix absolute url munging in rss generation to support https, ftp, etc urls
  118. not just http urls.
  119. * Patch from Recai Oktaş to improve utf-8 support, it should now use proper
  120. utf-8 for edit and other fields, and for recentchanges. There may still
  121. be utf-8 issues with the preferences page though.
  122. -- Joey Hess <joeyh@debian.org> Sun, 11 Jun 2006 19:56:54 -0400
  123. ikiwiki (1.4) unstable; urgency=low
  124. * Tell HTML::Scrubber to treat "/" as a valid attribute which is its
  125. very strange way of enabling proper XHTML <br /> type tags. Output html
  126. should be always valid again now.
  127. * The page name and parent links has switched from using a <h1> to a styled
  128. <span>, so pages can use <h1> internally instead of needing to use <h2>.
  129. * Updated all of ikiwiki's own wiki pages for that.
  130. * Add pagetemplate hook, which can be used by plugins that want to mess
  131. around with adding new stuff to the page template.
  132. * Remove headercontent; the search plugin now adds the search box to the
  133. header by registering a pagetemplate hook, and other plugins should do
  134. similarly.
  135. * Rebuilding on upgrade to this version is recommended.
  136. * Add a html validity check to the test suite, using the wdg-html-validator,
  137. if available.
  138. * Make the html valid when there is nothing in the actions list.
  139. * Reordered some function call parameters for consistency.
  140. * Enable full utf-8 support for page input and output.
  141. * Add a workaround for markdown, which does not work well with utf-8
  142. strings.
  143. * --getctime had bitrotted (well I only ever used it the once so far..),
  144. fix and make it a bit more flexible
  145. * rcs_getctime is changed, now rather than needing to loop over all pages,
  146. it should just use the rcs to get the ctime of the passed file.
  147. * When inlining a page in another one, links from the inlined page are now
  148. expanded the same as they are when rendering the inlined page as a
  149. standalone page. So rather than being expanded from the POV of the
  150. inlining page, they are expanded from the POV of the inlined page.
  151. For example, a link from blog/foo to "bar" will now link to blog/bar
  152. if it exists. Previously this needed to be a link explicitly to
  153. "blog/bar"; such links will also continue to work.
  154. (This was slightly complex to do as the link still has to be constructed
  155. relative to the inlining page.)
  156. * Make page edit textarea resize to fit browser window.
  157. * Add -refresh option to ikiwiki-mass-rebuild and use that on upgrades that
  158. do not need a full rebuild, in order to update any basewiki pages.
  159. -- Joey Hess <joeyh@debian.org> Sat, 27 May 2006 15:08:49 -0400
  160. ikiwiki (1.3) unstable; urgency=low
  161. * Fix the preinst introduced in the last version. Closes: #367458
  162. -- Joey Hess <joeyh@debian.org> Tue, 16 May 2006 02:43:02 -0500
  163. ikiwiki (1.2) unstable; urgency=low
  164. * Remove dups from the brokenlinks list.
  165. * Add libc6-dev to dependencies, needed to build wrappers.
  166. * Install wikilist in correct location. Closes: #367371
  167. -- Joey Hess <joeyh@debian.org> Mon, 15 May 2006 10:53:49 -0500
  168. ikiwiki (1.1) unstable; urgency=low
  169. * Rename inlinepage to depends, so that it can be used to refer to more
  170. dependency relationships than just inlining. This will require a rebuild
  171. on upgrade to this version.
  172. * Move the rss link, put it in the blogpost form if there is one and at the
  173. top if not. This is both nicer because easier to find, and it cleans up
  174. the code which had used inlinepage as a flag for adding the link later.
  175. * Allow the depends GlobList to be built up from multiple sources (such as
  176. plugins) during a page render.
  177. * Which means that more than one blog is now supported to appear on a
  178. single page. (With some limitations, like only the last one getting an
  179. rss file.)
  180. * Added a plugin system.
  181. * Added a pagecount plugin, enabled by default.
  182. * Support PreProcessorDirectives with no parameters, ie "[[pagecount ]]".
  183. * Fixed/optimised backlinks code, to avoid rebuilding pages to update
  184. backlinks when the backlinks hadn't really changed.
  185. * Moved inline page support, rss generation etc into the inline plugin,
  186. enabled by default.
  187. * Added brokenlinks plugin, not enabled by default, but rather handy.
  188. * Fix several broken links in the doc wiki.
  189. * Smarter behavior when creating a page and a page of the same name (but
  190. different location) already exists.
  191. * Add an orphans plugin for finding pages that nothing links to.
  192. * Removed backlinks page, which it turns out nothing used.
  193. * Split off an IkiWiki.pm out of ikiwiki and have all the other modules use
  194. it, this will allow for adding a unit test suite.
  195. * Add unit tests for several core functions, including globlist_match,
  196. dirname, basename, bestlink, linkify, pagetitle, titlepage.
  197. * Smart globlist merging.
  198. * Patch from Thomas Schwinge to switch from --svn to --rcs=svn, etc,
  199. to pave the way for adding other RCS support. This also changes the
  200. setup files, where before they had svn => 1 or svn => 0, now they have
  201. rcs => "svn" or rcs => "".
  202. * Add a debian/NEWS file with upgrade notes.
  203. * Load whatever rcs module is specified, so new ones can be just dropped in
  204. as plugins and work. (Well, in theory.)
  205. * Add some basic docs about writing RCS modules.
  206. * Broke search capability out into a plugin, removed the --hyperestraier
  207. switch.
  208. * Added smiley plugin, nicely controlled and documented by the smileys page.
  209. * Copied in some smileys from Moin Moin.
  210. * Allow links of the form [[some page|page]], with whitespace in the link
  211. text.
  212. * Removed --sanitize and --no-sanitize, replaced with --plugin htmlscrubber
  213. and --disable-plugin htmlscrubber.
  214. * Allow discussion links on pages to be turned off with --no-discussion.
  215. * Add ikiwiki-mass-rebuild script, ripped out of the postinst.
  216. * Add some new config items to the estseek.conf template, which are needed
  217. by hyperestraier 1.2.3.
  218. -- Joey Hess <joeyh@debian.org> Fri, 5 May 2006 17:00:41 -0400
  219. ikiwiki (1.0) unstable; urgency=low
  220. * First official release.
  221. -- Joey Hess <joeyh@debian.org> Tue, 25 Apr 2006 02:08:17 -0400