summaryrefslogtreecommitdiff
path: root/debian/changelog
blob: 015c16ff1d383170f5d906566bfc09204d0c643b (plain)
  1. ikiwiki (1.12) UNRELEASED; urgency=low
  2. * Add getopt hook type, this allows plugins to add new command-line options.
  3. * Add --tagbase option to tag plugin.
  4. * Add exclude option in setup files, works same as --exclude.
  5. * Put categories in rss feeds for tagged items.
  6. -- Joey Hess <joeyh@debian.org> Sat, 29 Jul 2006 02:58:23 -0400
  7. ikiwiki (1.11) unstable; urgency=low
  8. * Patch from Enrico that
  9. - Adds a tag plugin that allows more easily tagging pages.
  10. The meta plugin can also still be used for that, but the tag plugin
  11. also lists a page's tags at the bottom of the page.
  12. - Allows preprocessor directives to have parameters with no specified
  13. value.
  14. - Fixes preprocessor directive parameter parsing so that
  15. foo=bar baz now means "foo=bar" and a "baz" with no value.
  16. * Run pagetemplate hooks when inlining pages so that inlined pages also
  17. list their tags.
  18. * Make all plugins with pagetemplate hooks check that variables exist
  19. on the template before setting them, for robustness.
  20. * Switch pagetemplate hooks to using named parameters.
  21. * Pass a destpage parameter to preprocessor and pagetemplate hooks.
  22. This will be the page that a source page will be part of, which is
  23. different than the source page for inlined pages.
  24. * Audited all plugins to endure they pass (page, destpage) to htmllink
  25. appropriatly. This means inlining of various plugins will not work
  26. properly, with correct links generated.
  27. -- Joey Hess <joeyh@debian.org> Thu, 27 Jul 2006 20:51:23 -0400
  28. ikiwiki (1.10) unstable; urgency=low
  29. * Run page through any relevant filters when generating a page preview.
  30. * Noticed a bug in the wikitext markup plugin -- it made CamelCase links the
  31. default throughout the wiki, not only on wikitext pages. Decided to call
  32. this a feature, and split the camelcase support out into a separate plugin
  33. that is independant of wikitext.
  34. * Fix CamelCase regexp to not break [[FooBar|BazBar]] WikiLinks.
  35. -- Joey Hess <joeyh@debian.org> Wed, 26 Jul 2006 18:06:35 -0400
  36. ikiwiki (1.9) unstable; urgency=low
  37. * Improve display of parentlinks and page title of toplevel index page.
  38. * Patch from Faidon to use svn --limit when possible for recentchanges,
  39. speeds up recentchanges a lot for wikis with more history.
  40. * Patch from Recai to fix utf8 issues in git backend.
  41. * Add wikitext markup plugin, which supports ".wiki" pages written in the
  42. original wiki syntax, CamelCase links and all.
  43. * Support a w3mmode, which lets w3m run ikiwiki using its local CGI
  44. support, to edit pages etc without a web server.
  45. * Display CGI processing errors if present.
  46. * Fix from Faidon for a XML parser issue that breaks utf-8 for
  47. RecentChanges. Avoid using XML::SAX::PurePerl, which is buggy in this
  48. area, and also way slow.
  49. * Match 'web commit from' in SVN and git, these are web commits too.
  50. (Faidon)
  51. * Consolidated all decode_utf8 in FormBuilder's fields to make the code more
  52. readable and avoid future mistakes. The patch seems to work and for the
  53. first time I have a UTF-8 username ;-) (Faidon)
  54. * Use form->field consistently, not form->param.
  55. * Patch from Recai to allow selection of page type when creating a new page.
  56. Default page type is inherited from the link clicked on to create the new
  57. page.
  58. -- Joey Hess <joeyh@debian.org> Wed, 26 Jul 2006 17:25:30 -0400
  59. ikiwiki (1.8) unstable; urgency=low
  60. * Fix orphans plugin to not count a link to a nonexistant page as a reason
  61. for a page not being an orphan.
  62. * Support pinging services such as Technorati using XML-RPC to notify them
  63. about changes to rss feeds.
  64. * Parse svn log as xml for improved utf8 and security. Note that this makes
  65. ikiwiki depend on XML::Simple. Patch by Faidon Liambotis.
  66. * POSIX::strftime doesn't know about encodings and doesn't return a utf8
  67. flagged string even if the locale causes it to generate utf8 output,
  68. so make sure to let perl know it should be handled as utf8. Also,
  69. the optimised version used for standard time formats won't work if the
  70. user has changed locale, so drop it. Thanks, Faidon Liambotis.
  71. * Fix re-encoding of the comments field to utf8 if a commit fails
  72. due to a conflict. Thanks, Faidon Liambotis.
  73. * Let svn know that commits have utf8 commit messages. Thanks, Faidon
  74. Liambotis.
  75. * Add insane double encode/decode to utf8 around call to markdown.
  76. This works around a truely strange bug, which is apparently a bug in
  77. perl, #376329. Also added a test case for it.
  78. * Improve layout of edit page so formatting help link is always visible w/o
  79. getting in the way of the preview.
  80. * Centralised all calls to HTML::Template and force all the templates
  81. to be read as utf8.
  82. * Support pages with utf8 filenames. Patch by Faidon Liambotis.
  83. * Introduce add_plugins and disable_plugins config options in setup files.
  84. This allows adding or removing plugins w/o overriding the whole list of
  85. default plugins, which makes it easier to upgrade when new default plugins
  86. are added.
  87. * Support htmlize plugins and make mdwn one such plugin, which is enabled by
  88. default (of course!). Based on a patch by Faidon Liambotis.
  89. * Add a html plugin, which can be used to write wikis in raw html,
  90. if you'd ever want to do such a thing. Slightly tricky, since ikiwiki
  91. defaults to not processing .html files, since w/o this plugin they would
  92. be copied unsanitised. With this plugin, it will process and html
  93. sanitise them, like any other page type.
  94. * Rebuilding wrappers is necessary on upgrade to this version.
  95. * Make ikiwiki --setup --refresh rebuild wrappers, so wrapper rebuild
  96. will be automatically done on all upgrades.
  97. * Don't send pings if the wiki is being rebuilt.
  98. * Work around very innefficient behavior in File::Spec::abs2rel. Result
  99. is a savings of 2 pointless fork/execs per link calculation, which
  100. results in ~25% speedup of ikiwiki building its own doc wiki, and
  101. about 35% speedup displaying RecentChanges!
  102. * Make RecentChanges use a table and some CSS, should be much more readable.
  103. No code changes involved.
  104. * Encode & in diffurl in examples, to conform to pedantic rules.
  105. * Speed up RecentChanges by another 40% or so with some memoization.
  106. * Memoize abs2rel, which is still kinda slow, for another 30% speedup
  107. in time to build the doc wiki.
  108. -- Joey Hess <joeyh@debian.org> Tue, 4 Jul 2006 12:46:29 -0400
  109. ikiwiki (1.7) unstable; urgency=low
  110. * Updated logo from Recai with some kerning and alingment tuning.
  111. * Patch from Recai to fix git recentchanges code to work with git 1.4 which
  112. changed some output.
  113. * Copyright update.
  114. -- Joey Hess <joeyh@debian.org> Sun, 18 Jun 2006 23:33:35 -0400
  115. ikiwiki (1.6) unstable; urgency=low
  116. * YA utf-8 patch from Recai, this time to fix previewing a page so that
  117. the text in the input box is re-encoded back to utf-8.
  118. * -CSD does not affect modules, so readfile() was not using the utf-8 input
  119. layer, which led to lots of problems; make it force read files as utf-8.
  120. Closes: #373203
  121. * Note that as a consequence, this version of ikiwiki will actually try to
  122. parse utf8 in source files for the first time, which may expose broken
  123. utf8 in wiki sources that was hidden before. Most common will be
  124. perl warnings like "utf8 "\xE9" does not map to Unicode"
  125. * writefile() likewise needs to use the utf8 output layer.
  126. * Remove the -CSD from ikiwiki's hashbang since it's useless to have it
  127. there.
  128. * Revert some of the decode_utf8 changes in CGI.pm that seem unnecessary
  129. given the readfile fix.
  130. * Add utf-8 testcases for readfile and htmlize.
  131. * Put back the encode_utf8 in the input to markdown; it's really not utf-8
  132. safe.
  133. * More utf-8 fixes from Recai, partly to things I broke above:
  134. - The serious problem is that writefile() saves the content in undecoded
  135. format in CGI, hence all (non-ascii) chars are corrupted permanently.
  136. - Comment field in edit page is not decoded and all the non-ascii chars in
  137. this field are corrupted as the result. We should decode it as we do it
  138. for the content.
  139. - Add 'use encoding "utf8"' to CGI.pm to avoid warnings about wide
  140. character in print.
  141. * New SVG logo from Recai.
  142. -- Joey Hess <joeyh@debian.org> Sun, 18 Jun 2006 19:18:46 -0400
  143. ikiwiki (1.5) unstable; urgency=low
  144. * Add --timeformat config option to allow changing how dates are displayed.
  145. Note that as a side effect, dates will now be displayed using the local
  146. timezone, not as GMT.
  147. * More security review.
  148. * Patch from Dr. Zini to add link() and backlink() to globlists. This allows
  149. for some handy stuff like:
  150. - Using links as a kind of tag; creating blog pages that list all pages
  151. containing a given tag/link or not containing some other tag.
  152. - Subscribing to mail notifications whenever a change is made to a page
  153. that is a backlink of page foo. Ie, "Please notify me of changes in all
  154. pages that link to my home page in the wiki"
  155. - Locking any pages that are linked to from a particular page, so that
  156. lists of locks can be exposed in the wiki.
  157. * Reorganised the doc wiki's todo/* pages, using a link/tag to flag
  158. when a todo item is done, instead of the previous moving it to a different
  159. subdir.
  160. * Allow pagetemplate plugins to override *anything* in the template.
  161. * Add a meta plugin, which allows specifying various metadata about pages,
  162. like license and author. It also allows for inserting html link and meta
  163. tags into html, overriding the title, and adding hidden WikiLinks, which
  164. can be useful when using link-based globbing for page categorisation.
  165. * Remove preprocessor directives from inlined pages.
  166. * Allow simple preprocessor directive values to be specified w/o quotes.
  167. * Add support for using git instead of subversion as the RCS backend,
  168. tremendous thanks to Recai Oktaş for this.
  169. * Doc updates for git.
  170. * Fix absolute url munging in rss generation to support https, ftp, etc urls
  171. not just http urls.
  172. * Patch from Recai Oktaş to improve utf-8 support, it should now use proper
  173. utf-8 for edit and other fields, and for recentchanges. There may still
  174. be utf-8 issues with the preferences page though.
  175. -- Joey Hess <joeyh@debian.org> Sun, 11 Jun 2006 19:56:54 -0400
  176. ikiwiki (1.4) unstable; urgency=low
  177. * Tell HTML::Scrubber to treat "/" as a valid attribute which is its
  178. very strange way of enabling proper XHTML <br /> type tags. Output html
  179. should be always valid again now.
  180. * The page name and parent links has switched from using a <h1> to a styled
  181. <span>, so pages can use <h1> internally instead of needing to use <h2>.
  182. * Updated all of ikiwiki's own wiki pages for that.
  183. * Add pagetemplate hook, which can be used by plugins that want to mess
  184. around with adding new stuff to the page template.
  185. * Remove headercontent; the search plugin now adds the search box to the
  186. header by registering a pagetemplate hook, and other plugins should do
  187. similarly.
  188. * Rebuilding on upgrade to this version is recommended.
  189. * Add a html validity check to the test suite, using the wdg-html-validator,
  190. if available.
  191. * Make the html valid when there is nothing in the actions list.
  192. * Reordered some function call parameters for consistency.
  193. * Enable full utf-8 support for page input and output.
  194. * Add a workaround for markdown, which does not work well with utf-8
  195. strings.
  196. * --getctime had bitrotted (well I only ever used it the once so far..),
  197. fix and make it a bit more flexible
  198. * rcs_getctime is changed, now rather than needing to loop over all pages,
  199. it should just use the rcs to get the ctime of the passed file.
  200. * When inlining a page in another one, links from the inlined page are now
  201. expanded the same as they are when rendering the inlined page as a
  202. standalone page. So rather than being expanded from the POV of the
  203. inlining page, they are expanded from the POV of the inlined page.
  204. For example, a link from blog/foo to "bar" will now link to blog/bar
  205. if it exists. Previously this needed to be a link explicitly to
  206. "blog/bar"; such links will also continue to work.
  207. (This was slightly complex to do as the link still has to be constructed
  208. relative to the inlining page.)
  209. * Make page edit textarea resize to fit browser window.
  210. * Add -refresh option to ikiwiki-mass-rebuild and use that on upgrades that
  211. do not need a full rebuild, in order to update any basewiki pages.
  212. -- Joey Hess <joeyh@debian.org> Sat, 27 May 2006 15:08:49 -0400
  213. ikiwiki (1.3) unstable; urgency=low
  214. * Fix the preinst introduced in the last version. Closes: #367458
  215. -- Joey Hess <joeyh@debian.org> Tue, 16 May 2006 02:43:02 -0500
  216. ikiwiki (1.2) unstable; urgency=low
  217. * Remove dups from the brokenlinks list.
  218. * Add libc6-dev to dependencies, needed to build wrappers.
  219. * Install wikilist in correct location. Closes: #367371
  220. -- Joey Hess <joeyh@debian.org> Mon, 15 May 2006 10:53:49 -0500
  221. ikiwiki (1.1) unstable; urgency=low
  222. * Rename inlinepage to depends, so that it can be used to refer to more
  223. dependency relationships than just inlining. This will require a rebuild
  224. on upgrade to this version.
  225. * Move the rss link, put it in the blogpost form if there is one and at the
  226. top if not. This is both nicer because easier to find, and it cleans up
  227. the code which had used inlinepage as a flag for adding the link later.
  228. * Allow the depends GlobList to be built up from multiple sources (such as
  229. plugins) during a page render.
  230. * Which means that more than one blog is now supported to appear on a
  231. single page. (With some limitations, like only the last one getting an
  232. rss file.)
  233. * Added a plugin system.
  234. * Added a pagecount plugin, enabled by default.
  235. * Support PreProcessorDirectives with no parameters, ie "[[pagecount ]]".
  236. * Fixed/optimised backlinks code, to avoid rebuilding pages to update
  237. backlinks when the backlinks hadn't really changed.
  238. * Moved inline page support, rss generation etc into the inline plugin,
  239. enabled by default.
  240. * Added brokenlinks plugin, not enabled by default, but rather handy.
  241. * Fix several broken links in the doc wiki.
  242. * Smarter behavior when creating a page and a page of the same name (but
  243. different location) already exists.
  244. * Add an orphans plugin for finding pages that nothing links to.
  245. * Removed backlinks page, which it turns out nothing used.
  246. * Split off an IkiWiki.pm out of ikiwiki and have all the other modules use
  247. it, this will allow for adding a unit test suite.
  248. * Add unit tests for several core functions, including globlist_match,
  249. dirname, basename, bestlink, linkify, pagetitle, titlepage.
  250. * Smart globlist merging.
  251. * Patch from Thomas Schwinge to switch from --svn to --rcs=svn, etc,
  252. to pave the way for adding other RCS support. This also changes the
  253. setup files, where before they had svn => 1 or svn => 0, now they have
  254. rcs => "svn" or rcs => "".
  255. * Add a debian/NEWS file with upgrade notes.
  256. * Load whatever rcs module is specified, so new ones can be just dropped in
  257. as plugins and work. (Well, in theory.)
  258. * Add some basic docs about writing RCS modules.
  259. * Broke search capability out into a plugin, removed the --hyperestraier
  260. switch.
  261. * Added smiley plugin, nicely controlled and documented by the smileys page.
  262. * Copied in some smileys from Moin Moin.
  263. * Allow links of the form [[some page|page]], with whitespace in the link
  264. text.
  265. * Removed --sanitize and --no-sanitize, replaced with --plugin htmlscrubber
  266. and --disable-plugin htmlscrubber.
  267. * Allow discussion links on pages to be turned off with --no-discussion.
  268. * Add ikiwiki-mass-rebuild script, ripped out of the postinst.
  269. * Add some new config items to the estseek.conf template, which are needed
  270. by hyperestraier 1.2.3.
  271. -- Joey Hess <joeyh@debian.org> Fri, 5 May 2006 17:00:41 -0400
  272. ikiwiki (1.0) unstable; urgency=low
  273. * First official release.
  274. -- Joey Hess <joeyh@debian.org> Tue, 25 Apr 2006 02:08:17 -0400