summaryrefslogtreecommitdiff
path: root/debian/changelog
blob: 359ea1c132cb9ce82506e20d321ff1c6e2d4a670 (plain)
  1. ikiwiki (1.9) UNRELEASED; urgency=low
  2. * Improve display of parentlinks and page title of toplevel index page.
  3. * Patch from Faidon to use svn --limit when possible for recentchanges,
  4. speeds up recentchanges a lot for wikis with more history.
  5. * Patch from Recai to fix utf8 issues in git backend.
  6. * Add wikitext markup plugin, which supports ".wiki" pages written in the
  7. original wiki syntax, CamelCase links and all.
  8. * Support a w3mmode, which lets w3m run ikiwiki using its local CGI
  9. support, to edit pages etc without a web server.
  10. -- Joey Hess <joeyh@debian.org> Fri, 7 Jul 2006 14:11:50 -0400
  11. ikiwiki (1.8) unstable; urgency=low
  12. * Fix orphans plugin to not count a link to a nonexistant page as a reason
  13. for a page not being an orphan.
  14. * Support pinging services such as Technorati using XML-RPC to notify them
  15. about changes to rss feeds.
  16. * Parse svn log as xml for improved utf8 and security. Note that this makes
  17. ikiwiki depend on XML::Simple. Patch by Faidon Liambotis.
  18. * POSIX::strftime doesn't know about encodings and doesn't return a utf8
  19. flagged string even if the locale causes it to generate utf8 output,
  20. so make sure to let perl know it should be handled as utf8. Also,
  21. the optimised version used for standard time formats won't work if the
  22. user has changed locale, so drop it. Thanks, Faidon Liambotis.
  23. * Fix re-encoding of the comments field to utf8 if a commit fails
  24. due to a conflict. Thanks, Faidon Liambotis.
  25. * Let svn know that commits have utf8 commit messages. Thanks, Faidon
  26. Liambotis.
  27. * Add insane double encode/decode to utf8 around call to markdown.
  28. This works around a truely strange bug, which is apparently a bug in
  29. perl, #376329. Also added a test case for it.
  30. * Improve layout of edit page so formatting help link is always visible w/o
  31. getting in the way of the preview.
  32. * Centralised all calls to HTML::Template and force all the templates
  33. to be read as utf8.
  34. * Support pages with utf8 filenames. Patch by Faidon Liambotis.
  35. * Introduce add_plugins and disable_plugins config options in setup files.
  36. This allows adding or removing plugins w/o overriding the whole list of
  37. default plugins, which makes it easier to upgrade when new default plugins
  38. are added.
  39. * Support htmlize plugins and make mdwn one such plugin, which is enabled by
  40. default (of course!). Based on a patch by Faidon Liambotis.
  41. * Add a html plugin, which can be used to write wikis in raw html,
  42. if you'd ever want to do such a thing. Slightly tricky, since ikiwiki
  43. defaults to not processing .html files, since w/o this plugin they would
  44. be copied unsanitised. With this plugin, it will process and html
  45. sanitise them, like any other page type.
  46. * Rebuilding wrappers is necessary on upgrade to this version.
  47. * Make ikiwiki --setup --refresh rebuild wrappers, so wrapper rebuild
  48. will be automatically done on all upgrades.
  49. * Don't send pings if the wiki is being rebuilt.
  50. * Work around very innefficient behavior in File::Spec::abs2rel. Result
  51. is a savings of 2 pointless fork/execs per link calculation, which
  52. results in ~25% speedup of ikiwiki building its own doc wiki, and
  53. about 35% speedup displaying RecentChanges!
  54. * Make RecentChanges use a table and some CSS, should be much more readable.
  55. No code changes involved.
  56. * Encode & in diffurl in examples, to conform to pedantic rules.
  57. * Speed up RecentChanges by another 40% or so with some memoization.
  58. * Memoize abs2rel, which is still kinda slow, for another 30% speedup
  59. in time to build the doc wiki.
  60. -- Joey Hess <joeyh@debian.org> Tue, 4 Jul 2006 12:46:29 -0400
  61. ikiwiki (1.7) unstable; urgency=low
  62. * Updated logo from Recai with some kerning and alingment tuning.
  63. * Patch from Recai to fix git recentchanges code to work with git 1.4 which
  64. changed some output.
  65. * Copyright update.
  66. -- Joey Hess <joeyh@debian.org> Sun, 18 Jun 2006 23:33:35 -0400
  67. ikiwiki (1.6) unstable; urgency=low
  68. * YA utf-8 patch from Recai, this time to fix previewing a page so that
  69. the text in the input box is re-encoded back to utf-8.
  70. * -CSD does not affect modules, so readfile() was not using the utf-8 input
  71. layer, which led to lots of problems; make it force read files as utf-8.
  72. Closes: #373203
  73. * Note that as a consequence, this version of ikiwiki will actually try to
  74. parse utf8 in source files for the first time, which may expose broken
  75. utf8 in wiki sources that was hidden before. Most common will be
  76. perl warnings like "utf8 "\xE9" does not map to Unicode"
  77. * writefile() likewise needs to use the utf8 output layer.
  78. * Remove the -CSD from ikiwiki's hashbang since it's useless to have it
  79. there.
  80. * Revert some of the decode_utf8 changes in CGI.pm that seem unnecessary
  81. given the readfile fix.
  82. * Add utf-8 testcases for readfile and htmlize.
  83. * Put back the encode_utf8 in the input to markdown; it's really not utf-8
  84. safe.
  85. * More utf-8 fixes from Recai, partly to things I broke above:
  86. - The serious problem is that writefile() saves the content in undecoded
  87. format in CGI, hence all (non-ascii) chars are corrupted permanently.
  88. - Comment field in edit page is not decoded and all the non-ascii chars in
  89. this field are corrupted as the result. We should decode it as we do it
  90. for the content.
  91. - Add 'use encoding "utf8"' to CGI.pm to avoid warnings about wide
  92. character in print.
  93. * New SVG logo from Recai.
  94. -- Joey Hess <joeyh@debian.org> Sun, 18 Jun 2006 19:18:46 -0400
  95. ikiwiki (1.5) unstable; urgency=low
  96. * Add --timeformat config option to allow changing how dates are displayed.
  97. Note that as a side effect, dates will now be displayed using the local
  98. timezone, not as GMT.
  99. * More security review.
  100. * Patch from Dr. Zini to add link() and backlink() to globlists. This allows
  101. for some handy stuff like:
  102. - Using links as a kind of tag; creating blog pages that list all pages
  103. containing a given tag/link or not containing some other tag.
  104. - Subscribing to mail notifications whenever a change is made to a page
  105. that is a backlink of page foo. Ie, "Please notify me of changes in all
  106. pages that link to my home page in the wiki"
  107. - Locking any pages that are linked to from a particular page, so that
  108. lists of locks can be exposed in the wiki.
  109. * Reorganised the doc wiki's todo/* pages, using a link/tag to flag
  110. when a todo item is done, instead of the previous moving it to a different
  111. subdir.
  112. * Allow pagetemplate plugins to override *anything* in the template.
  113. * Add a meta plugin, which allows specifying various metadata about pages,
  114. like license and author. It also allows for inserting html link and meta
  115. tags into html, overriding the title, and adding hidden WikiLinks, which
  116. can be useful when using link-based globbing for page categorisation.
  117. * Remove preprocessor directives from inlined pages.
  118. * Allow simple preprocessor directive values to be specified w/o quotes.
  119. * Add support for using git instead of subversion as the RCS backend,
  120. tremendous thanks to Recai Oktaş for this.
  121. * Doc updates for git.
  122. * Fix absolute url munging in rss generation to support https, ftp, etc urls
  123. not just http urls.
  124. * Patch from Recai Oktaş to improve utf-8 support, it should now use proper
  125. utf-8 for edit and other fields, and for recentchanges. There may still
  126. be utf-8 issues with the preferences page though.
  127. -- Joey Hess <joeyh@debian.org> Sun, 11 Jun 2006 19:56:54 -0400
  128. ikiwiki (1.4) unstable; urgency=low
  129. * Tell HTML::Scrubber to treat "/" as a valid attribute which is its
  130. very strange way of enabling proper XHTML <br /> type tags. Output html
  131. should be always valid again now.
  132. * The page name and parent links has switched from using a <h1> to a styled
  133. <span>, so pages can use <h1> internally instead of needing to use <h2>.
  134. * Updated all of ikiwiki's own wiki pages for that.
  135. * Add pagetemplate hook, which can be used by plugins that want to mess
  136. around with adding new stuff to the page template.
  137. * Remove headercontent; the search plugin now adds the search box to the
  138. header by registering a pagetemplate hook, and other plugins should do
  139. similarly.
  140. * Rebuilding on upgrade to this version is recommended.
  141. * Add a html validity check to the test suite, using the wdg-html-validator,
  142. if available.
  143. * Make the html valid when there is nothing in the actions list.
  144. * Reordered some function call parameters for consistency.
  145. * Enable full utf-8 support for page input and output.
  146. * Add a workaround for markdown, which does not work well with utf-8
  147. strings.
  148. * --getctime had bitrotted (well I only ever used it the once so far..),
  149. fix and make it a bit more flexible
  150. * rcs_getctime is changed, now rather than needing to loop over all pages,
  151. it should just use the rcs to get the ctime of the passed file.
  152. * When inlining a page in another one, links from the inlined page are now
  153. expanded the same as they are when rendering the inlined page as a
  154. standalone page. So rather than being expanded from the POV of the
  155. inlining page, they are expanded from the POV of the inlined page.
  156. For example, a link from blog/foo to "bar" will now link to blog/bar
  157. if it exists. Previously this needed to be a link explicitly to
  158. "blog/bar"; such links will also continue to work.
  159. (This was slightly complex to do as the link still has to be constructed
  160. relative to the inlining page.)
  161. * Make page edit textarea resize to fit browser window.
  162. * Add -refresh option to ikiwiki-mass-rebuild and use that on upgrades that
  163. do not need a full rebuild, in order to update any basewiki pages.
  164. -- Joey Hess <joeyh@debian.org> Sat, 27 May 2006 15:08:49 -0400
  165. ikiwiki (1.3) unstable; urgency=low
  166. * Fix the preinst introduced in the last version. Closes: #367458
  167. -- Joey Hess <joeyh@debian.org> Tue, 16 May 2006 02:43:02 -0500
  168. ikiwiki (1.2) unstable; urgency=low
  169. * Remove dups from the brokenlinks list.
  170. * Add libc6-dev to dependencies, needed to build wrappers.
  171. * Install wikilist in correct location. Closes: #367371
  172. -- Joey Hess <joeyh@debian.org> Mon, 15 May 2006 10:53:49 -0500
  173. ikiwiki (1.1) unstable; urgency=low
  174. * Rename inlinepage to depends, so that it can be used to refer to more
  175. dependency relationships than just inlining. This will require a rebuild
  176. on upgrade to this version.
  177. * Move the rss link, put it in the blogpost form if there is one and at the
  178. top if not. This is both nicer because easier to find, and it cleans up
  179. the code which had used inlinepage as a flag for adding the link later.
  180. * Allow the depends GlobList to be built up from multiple sources (such as
  181. plugins) during a page render.
  182. * Which means that more than one blog is now supported to appear on a
  183. single page. (With some limitations, like only the last one getting an
  184. rss file.)
  185. * Added a plugin system.
  186. * Added a pagecount plugin, enabled by default.
  187. * Support PreProcessorDirectives with no parameters, ie "[[pagecount ]]".
  188. * Fixed/optimised backlinks code, to avoid rebuilding pages to update
  189. backlinks when the backlinks hadn't really changed.
  190. * Moved inline page support, rss generation etc into the inline plugin,
  191. enabled by default.
  192. * Added brokenlinks plugin, not enabled by default, but rather handy.
  193. * Fix several broken links in the doc wiki.
  194. * Smarter behavior when creating a page and a page of the same name (but
  195. different location) already exists.
  196. * Add an orphans plugin for finding pages that nothing links to.
  197. * Removed backlinks page, which it turns out nothing used.
  198. * Split off an IkiWiki.pm out of ikiwiki and have all the other modules use
  199. it, this will allow for adding a unit test suite.
  200. * Add unit tests for several core functions, including globlist_match,
  201. dirname, basename, bestlink, linkify, pagetitle, titlepage.
  202. * Smart globlist merging.
  203. * Patch from Thomas Schwinge to switch from --svn to --rcs=svn, etc,
  204. to pave the way for adding other RCS support. This also changes the
  205. setup files, where before they had svn => 1 or svn => 0, now they have
  206. rcs => "svn" or rcs => "".
  207. * Add a debian/NEWS file with upgrade notes.
  208. * Load whatever rcs module is specified, so new ones can be just dropped in
  209. as plugins and work. (Well, in theory.)
  210. * Add some basic docs about writing RCS modules.
  211. * Broke search capability out into a plugin, removed the --hyperestraier
  212. switch.
  213. * Added smiley plugin, nicely controlled and documented by the smileys page.
  214. * Copied in some smileys from Moin Moin.
  215. * Allow links of the form [[some page|page]], with whitespace in the link
  216. text.
  217. * Removed --sanitize and --no-sanitize, replaced with --plugin htmlscrubber
  218. and --disable-plugin htmlscrubber.
  219. * Allow discussion links on pages to be turned off with --no-discussion.
  220. * Add ikiwiki-mass-rebuild script, ripped out of the postinst.
  221. * Add some new config items to the estseek.conf template, which are needed
  222. by hyperestraier 1.2.3.
  223. -- Joey Hess <joeyh@debian.org> Fri, 5 May 2006 17:00:41 -0400
  224. ikiwiki (1.0) unstable; urgency=low
  225. * First official release.
  226. -- Joey Hess <joeyh@debian.org> Tue, 25 Apr 2006 02:08:17 -0400