summaryrefslogtreecommitdiff
path: root/Makefile.PL
diff options
context:
space:
mode:
authorjoshtriplett <joshtriplett@0fa5a96a-9a0e-0410-b3b2-a0fd24251071>2007-04-29 21:53:26 +0000
committerjoshtriplett <joshtriplett@0fa5a96a-9a0e-0410-b3b2-a0fd24251071>2007-04-29 21:53:26 +0000
commite97b63c95aad40de6498bd480a38d7a57764ad53 (patch)
tree1e9697955e97a70dab59823ccfe6c94be107c983 /Makefile.PL
parent8583fe7a95646e1da0b02ed5374ba1681414b5d8 (diff)
* Avoid using GNU extensions to cp during "make install", which did
not work on FreeBSD. Thanks to Henrik Brix Andersen for the patch.
Diffstat (limited to 'Makefile.PL')
-rwxr-xr-xMakefile.PL8
1 files changed, 6 insertions, 2 deletions
diff --git a/Makefile.PL b/Makefile.PL
index 676ba06ef..43af95c59 100755
--- a/Makefile.PL
+++ b/Makefile.PL
@@ -47,8 +47,12 @@ extra_clean:
extra_install:
install -d $(DESTDIR)$(PREFIX)/share/ikiwiki
- find basewiki templates \( -type f -or -type l \) ! -regex '.*\.svn.*' \
- -exec cp --parents -aL {} $(DESTDIR)$(PREFIX)/share/ikiwiki \;
+ for dir in `find -L basewiki templates -type d ! -regex '.*\.svn.*'`; do \
+ install -d $(DESTDIR)$(PREFIX)/share/ikiwiki/$$dir; \
+ for file in `find -L $$dir -maxdepth 1 -type f`; do \
+ install -m 644 $$file $(DESTDIR)$(PREFIX)/share/ikiwiki/$$dir; \
+ done; \
+ done
install -d $(DESTDIR)$(PREFIX)/share/man/man1
install -m 644 ikiwiki.man $(DESTDIR)$(PREFIX)/share/man/man1/ikiwiki.1