summaryrefslogtreecommitdiff
path: root/packaging/debian
diff options
context:
space:
mode:
Diffstat (limited to 'packaging/debian')
-rw-r--r--packaging/debian/70monkeysphere_use-validation-agent38
-rw-r--r--packaging/debian/changelog5
-rw-r--r--packaging/debian/control1
-rw-r--r--packaging/debian/monkeysphere.dirs2
-rw-r--r--packaging/debian/monkeysphere.install1
5 files changed, 46 insertions, 1 deletions
diff --git a/packaging/debian/70monkeysphere_use-validation-agent b/packaging/debian/70monkeysphere_use-validation-agent
new file mode 100644
index 0000000..c3135a8
--- /dev/null
+++ b/packaging/debian/70monkeysphere_use-validation-agent
@@ -0,0 +1,38 @@
+# /etc/X11/Xsession.d/70monkeysphere_use-validation-agent
+
+# This is a script to be sourced by Xsession. It wraps the session
+# startup argument with a monkeysphere-validation-agent nested
+# process, if available and none already exist.
+
+# Enable this system-wide by setting
+# MONKEYSPHERE_USE_VALIDATION_AGENT=true in
+# /etc/monkeysphere/monkeysphere.conf
+
+# Note that there is some weird interaction between this and
+# dbus-session at the moment: dbus-launch can start the msva just
+# fine, but if msva tries to start dbus-launch, dbus-launch fails
+# with:
+
+# Failed to waitpid() for babysitter intermediate process: No child processes
+
+# So this is placed at position 70 -- *before* the dbus Xsession
+# startup script, which is at 75 as of 2010-03-12, when i wrote this.
+
+# this is also good, because it means that the MSVA will learn about
+# the dbus session parameters, in case we want the agent to use dbus
+# to communicate with the user.
+
+# Author: Daniel Kahn Gillmor <dkg@fifthhorseman.net>
+
+MSVAGENT=/usr/bin/monkeysphere-validation-agent
+MSSYSCONFIG=/etc/monkeysphere/monkeysphere.conf
+MSUSERCONFIG="$HOME/.monkeysphere/monkeysphere.conf"
+
+if [ -x "$MSVAGENT" ] ; then
+ if [ "$(USE_VALIDATION_AGENT=
+. "$MSSYSCONFIG" 2>/dev/null
+. "$MSUSERCONFIG" 2>/dev/null || :
+printf '%s' "$USE_VALIDATION_AGENT")" = "true" ] ; then
+ STARTUP="$MSVAGENT $STARTUP"
+ fi
+fi
diff --git a/packaging/debian/changelog b/packaging/debian/changelog
index 10429fe..d971ee6 100644
--- a/packaging/debian/changelog
+++ b/packaging/debian/changelog
@@ -6,8 +6,11 @@ monkeysphere (0.29~pre1-1) UNRELEASED; urgency=low
[ Daniel Kahn Gillmor ]
* bumped Standards-Version to 3.8.4 (no changes needed)
* indicated bash dependency on version 3.2 or later (see MS #1687)
+ * including /etc/Xsession.d/70monkeysphere_use_validation_agent so that
+ administrators and users can choose to start up a validation agent for
+ each X session using monkeysphere.conf
- -- Daniel Kahn Gillmor <dkg@fifthhorseman.net> Thu, 18 Feb 2010 12:40:56 -0500
+ -- Daniel Kahn Gillmor <dkg@fifthhorseman.net> Fri, 12 Mar 2010 01:57:39 -0500
monkeysphere (0.28-1) unstable; urgency=low
diff --git a/packaging/debian/control b/packaging/debian/control
index 9a32642..6cd0143 100644
--- a/packaging/debian/control
+++ b/packaging/debian/control
@@ -28,6 +28,7 @@ Depends: openssh-client,
adduser,
${misc:Depends}
Recommends: netcat | socat, ssh-askpass, cron
+Suggests: monkeysphere-validation-agent
Enhances: openssh-client, openssh-server
Description: leverage the OpenPGP web of trust for SSH and TLS authentication
SSH key-based authentication is tried-and-true, but it lacks a true
diff --git a/packaging/debian/monkeysphere.dirs b/packaging/debian/monkeysphere.dirs
index e07fb2c..3e39efe 100644
--- a/packaging/debian/monkeysphere.dirs
+++ b/packaging/debian/monkeysphere.dirs
@@ -8,3 +8,5 @@ usr/share/man/man1
usr/share/man/man7
usr/share/man/man8
etc/monkeysphere
+etc/X11
+etc/X11/Xsession.d
diff --git a/packaging/debian/monkeysphere.install b/packaging/debian/monkeysphere.install
new file mode 100644
index 0000000..63a2dd7
--- /dev/null
+++ b/packaging/debian/monkeysphere.install
@@ -0,0 +1 @@
+debian/70monkeysphere_use-validation-agent etc/X11/Xsession.d