summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog6
-rwxr-xr-xdebian/monkeysphere.postinst4
2 files changed, 7 insertions, 3 deletions
diff --git a/debian/changelog b/debian/changelog
index 1f1db61..48af4d7 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -7,8 +7,12 @@ monkeysphere (0.4-1) UNRELEASED; urgency=low
* Privilege separation: use monkeysphere user to handle maintenance of
the gnupg authentication keychain for server.
* Improved certifier key management.
+ * Fixed variable scoping and config file precedence.
+ * Add options for key generation and add-certifier functions.
+ * Fix return codes for known_host and authorized_keys updating
+ functions.
- -- Jameson Graef Rollins <jrollins@phys.columbia.edu> Sun, 29 Jun 2008 14:14:59 -0400
+ -- Jameson Graef Rollins <jrollins@phys.columbia.edu> Wed, 09 Jul 2008 19:39:44 -0400
monkeysphere (0.3-1) experimental; urgency=low
diff --git a/debian/monkeysphere.postinst b/debian/monkeysphere.postinst
index 87fbe12..a133a4b 100755
--- a/debian/monkeysphere.postinst
+++ b/debian/monkeysphere.postinst
@@ -28,7 +28,7 @@ install --owner monkeysphere --group monkeysphere --mode 700 -d "$VARLIB"/gnupg-
# install authentication gpg.conf
cat <<EOF > "$VARLIB"/gnupg-authentication/gpg.conf
list-options show-uid-validity
-primary-keyring ${VARLIB}/gnupg-authentication/pubring.gpg
-keyring ${VARLIB}/gnupg-host/pubring.gpg
+primary-keyring "$VARLIB"/gnupg-authentication/pubring.gpg
+keyring "$VARLIB"/gnupg-host/pubring.gpg
EOF
chown monkeysphere:monkeysphere "$VARLIB"/gnupg-authentication/gpg.conf