summaryrefslogtreecommitdiff
path: root/debian/changelog
blob: d4a3a9c6fc8bd1da516214fc9c72e413ce9437ca (plain)
  1. ikiwiki (1.33) UNRELEASED; urgency=low
  2. * Fix issue with aggregate plugin updating expired pages.
  3. * Avoid syntax errors in templates used by the template plugin crashing
  4. ikiwiki.
  5. * Enable utf8 file IO in aggregate plugin.
  6. * Fix some issues with the new registration form.
  7. * Patch from Ethan Glasser Camp to add a skip option to the inline plugin.
  8. * Make sure to check for errors from every eval.
  9. -- Joey Hess <joeyh@debian.org> Wed, 8 Nov 2006 15:57:35 -0500
  10. ikiwiki (1.32) unstable; urgency=low
  11. * Add a separate pass to find page links, and only render each page once,
  12. instead of over and over. Typical speedup is ~4x. Max possible speedup:
  13. 8x.
  14. * Add "scan" parameter to hook(), which is used to make the hook be called
  15. during the scanning pass, as well as the render pass. The meta and tag
  16. plugins need to use the new scan parameter, so will any others that modify
  17. %links.
  18. * Now that links are calculated in a separate pass, it can also
  19. precalculate backlinks in one pass, which is O(N^2) instead of the
  20. previous code that was O(N^3). A very nice speedup for wikis with lots
  21. (thousands) of pages.
  22. * Stylish update to the ikiwiki logo, thanks to Recai Oktaş and Selçuk
  23. Erdem.
  24. * Add a default stylesheet entry for the pagecloud.
  25. * Add examples page with some examples of things that can be done using
  26. ikiwiki, like a weblog. The examples can be copied into a user's wiki
  27. for a quick start, without needing to learn everything about how to put
  28. them together.
  29. * Install the source of the examples into /usr/share/doc/ikiwiki/examples.
  30. * Add perlmagick to build-depends so syntax check of img plugin works.
  31. Closes: #396702
  32. * Improve login/register process, the login dialog has only name and
  33. password fields, which allows more web browsers to regognise it as a login
  34. field, and is less confusing.
  35. * Implemented expiry options for aggregate plugin.
  36. * Use precalculated backlinks info when determining if files need an update
  37. due to a page they link to being added/removed. Mostly significant if
  38. there are lots of pages.
  39. * Remove duplicate link info when saving index. In some cases it could
  40. pile up rather badly. (Probably not the best way to deal with this
  41. problem.)
  42. * Patch from James Westby to support podcasting, photoblogging, vidcasting,
  43. or what have you, by creating enclosures for non-page items that are
  44. included in feeds.
  45. -- Joey Hess <joeyh@debian.org> Fri, 3 Nov 2006 14:46:37 -0500
  46. ikiwiki (1.31) unstable; urgency=low
  47. * Patch from Pawel Tecza to cp -a the templates in the Makefile.
  48. * Change the rss feed title from the wikiname to the page title, with
  49. an exception for the wiki's toplevel index page, which will still use the
  50. wikiname as the feed title.
  51. Overriding the page title with meta title already overrode the rss feed
  52. tittle.
  53. * Add an img plugin, based on Christian Mock's img plugin, but stripped
  54. down to the bare essentials. Useful for handling large images on websites.
  55. * Sanitize possibly problimatic characters out of the polygen grammar names,
  56. just in case. Should not be exploitable anyway, since it only tries to run
  57. polygen after finding the specified grammar file.
  58. * Add missing dependency on the URI perl module.
  59. * Add basic spam fighting tool for admins: An admin's prefs page now allows
  60. editing a list of banned users.
  61. -- Joey Hess <joeyh@debian.org> Fri, 27 Oct 2006 23:16:33 -0400
  62. ikiwiki (1.30) unstable; urgency=low
  63. * Add no_override parameter to hook().
  64. * Add a shortcut plugin, inspired by Victor Moral's contributed shortcuts
  65. plugin, but featuring a more ikiwiki-ish syntax and with shortcuts that
  66. can be configured using a page in wiki.
  67. * Fix support for --pingurl at the command line.
  68. * Fix a subtle bug in will_render that broke some builds, by only clearing
  69. items from renderedfiles the first time per build.
  70. * Wrap entire technortati ping operation in an eval to catch all possible
  71. failure modes, after I observed a simple ->value crashing ikiwiki when
  72. a ping failed.
  73. -- Joey Hess <joeyh@debian.org> Mon, 16 Oct 2006 15:17:38 -0400
  74. ikiwiki (1.29) unstable; urgency=low
  75. * Patch from Paul Tötterman to use CP in the Makefile.
  76. * Patch from Alec Berryman adding a http_auth config item that allows
  77. using HTTP Authentication instead of ikiwiki's built in authentication.
  78. Useful for eg, large sites with their own previously existing user auth
  79. setup. Closes: #384534
  80. * Change %renderedfiles to store an array of files rendered from a given
  81. source file, to allow tracking of extra rendered files like rss feeds.
  82. * Note that plugins that accessed this variable will need to be updated!
  83. The plugin interface has been increased to version 1.01 for this change.
  84. As few plugins use %renderedfiles I haven't done anything else to ensure
  85. compatability of old plugins.
  86. * Add will_render function to the plugin interface, used to register that a
  87. page renders a destination file, and do some security checks. Previously
  88. but no longer rendered files will be cleaned up.
  89. * Use will_render in the inline and linkmap plugins.
  90. * You will need to rebuild your wiki on upgrade to this version.
  91. * Atom feed support based on a patch by Clint Adams.
  92. * Add feeds=no option to inline preprocessor directive to turn off all types
  93. of feeds.
  94. * $IkiWiki::version now holds the program version, and is accessible to
  95. plugins.
  96. * Make the aggregate plugin emphasize error messages.
  97. * Patch from Recai to limit recentchanges to displaying max 10 files for a
  98. given changeset (to avoid large number of file changes excessively
  99. bloating the page).
  100. -- Joey Hess <joeyh@debian.org> Fri, 13 Oct 2006 23:14:28 -0400
  101. ikiwiki (1.28) unstable; urgency=low
  102. * inline: Add ability to sort by page name, based on a patch from
  103. Benjamin A'Lee.
  104. * Fix a forkbomb in various calls to IPC::Open2, which has a highly
  105. braindead interface. Closes: #389383
  106. * Don't rm -rf ikiwiki on distclean, since a) there's no such file
  107. and b) those poor Mac OSX users and their case insensative files!
  108. * Don't fail syntax check if Text::Typography isn't installed.
  109. Closes: #389406
  110. -- Joey Hess <joeyh@debian.org> Tue, 26 Sep 2006 02:08:17 -0400
  111. ikiwiki (1.27) unstable; urgency=low
  112. * Work on firming up the plugin interface:
  113. - Plugins should not need to load IkiWiki::Render to get commonly
  114. used functions, so moved some functions from there to IkiWiki.
  115. - Picked out the set of functions and variables that most plugins
  116. use, documented them, and made IkiWiki export them by default,
  117. like a proper perl module should.
  118. - Use the other functions at your own risk.
  119. - This is not quite complete, I still have to decide whether to
  120. export some other things.
  121. * Changed all plugins included in ikiwiki to not use "IkiWiki::" when
  122. referring to stuff now exported by the IkiWiki module.
  123. * Add a module version number to IkiWiki, so you can "use IkiWiki '1.00'"
  124. to declare which version of the interface your plugin needs.
  125. * Anyone with a third-party ikiwiki plugin is strongly encouraged
  126. to make like changes to it and avoid use of non-exported symbols from
  127. "IkiWiki::".
  128. * Link debian/changelog and debian/news to NEWS and CHANGELOG.
  129. * Support hyperestradier version 1.4.2, which adds a new required phraseform
  130. setting.
  131. * If an inlined page has a permalink, link the page title to that.
  132. * Patch from Recai to use utf8 when reading the setup file, so that
  133. utf8 wikinames from there will be used properly.
  134. * Patch from Recai to kill utf-8 on the wiki name when generating the
  135. session cookie.
  136. * Change ddate plugin to use the DateTime::Calendar::Discordian perl module.
  137. * Fix a baseurl problem in hyperestradier search results.
  138. * Add a stub local.css to avoid problems with 404's.
  139. * Patch from Recai to fix a wide character warning from the search plugin
  140. during setup if the wikiname contains utf8.
  141. * Yet another fix for those poor case-insensative OS X users.
  142. * pagetemplate hooks are now also called when generating cgi pages.
  143. * Add a favicon plugin, which simply adds a link tag for an icon to each
  144. page (and cgis).
  145. * Patch from James Westby to deal with the case where you're editing a
  146. new page, hit cancel, and need to be redirected to somewhere sane.
  147. * Various documentation improvements by various wiki users.
  148. * Support Text::Markdown from CPAN, which has a different interface from
  149. the original markdown or the one in Debian.
  150. * Version the libcgi-session-perl dependency, some features that need
  151. the new version are used in some cases (sslcookie).
  152. * Numerous tla fixes from Clint.
  153. * Updated ikiwiki.svgz from Recai, includes an icon and is used to generate
  154. a multi-resolution favicon.ico.
  155. * README.Debian: typo Closes: #388110
  156. * chomp trailing newline at the end of templates read in by the template
  157. plugin, to allow use of the template preprocessor directive in
  158. whitespace-sensative situations. Closes: #387073
  159. * Patch from James Westby to make the location of the estseek.cgi script
  160. configurable.
  161. * Add typography (SmartyPants) plugin by Recai.
  162. * Add --render mode, which can be used to preview an edit at the command
  163. line by test rendering a single page.
  164. * Add a googlecalendar plugin. A bit special-purpose, but it shows
  165. one way to to deal with user-supplied content that could cause XSS
  166. issues w/o the htmlscrubber, and won't survive the scrubber.
  167. -- Joey Hess <joeyh@debian.org> Sun, 24 Sep 2006 00:02:21 -0400
  168. ikiwiki (1.26) unstable; urgency=low
  169. * Add a missing -n to tla undo call.
  170. * otl2hmtl can't be safely used with IPC::Open2 since it sometimes
  171. writes before consuming its whole stdin. Avoid this deadlock.
  172. * Fix alt tags for outline checkboxes.
  173. -- Joey Hess <joeyh@debian.org> Fri, 8 Sep 2006 16:24:16 -0400
  174. ikiwiki (1.25) unstable; urgency=low
  175. * Add proper waitpid calls for open2ed processes throughout to avoid
  176. zombies; this hit htmltidy especially badly.
  177. * Drop real uid/gid in the suid wrapper, thus allowing commits to remote
  178. subversion repos and fixing some other issues.
  179. * Add support for tla, contributed by Clint Adams. Closes: #385936
  180. * Add support for mercurial, contributed by Emanuele Aina.
  181. * Include <link rel> tag for RSS feeds, used by some aggregators and
  182. firefox to find the feed.
  183. * Add a linkmap plugin (requires graphviz).
  184. -- Joey Hess <joeyh@debian.org> Fri, 8 Sep 2006 01:54:14 -0400
  185. ikiwiki (1.24) unstable; urgency=low
  186. * Simplify the data structure returned by rcs_recentchanges to avoid
  187. each rcs plugin needing to form complex strings on its own.
  188. * Fix another destpage issue in the inline directive. Closes: #385512
  189. again.
  190. -- Joey Hess <joeyh@debian.org> Sun, 3 Sep 2006 15:46:45 -0400
  191. ikiwiki (1.23) unstable; urgency=low
  192. * Allow inline directives to be nested inside eg, sidebars. Closes: #385512
  193. -- Joey Hess <joeyh@debian.org> Sun, 3 Sep 2006 12:14:45 -0400
  194. ikiwiki (1.22) unstable; urgency=low
  195. * Change how the stylesheet url is determined in the templates: Remove
  196. STYLEURL and add BASEURL to all templates (some already had it). This
  197. new more general variable can be used to link to other things (eg, images)
  198. from the template, as well as stylesheets.
  199. * Fix a bug introduced last version to do with nested inlines.
  200. * Allow preprocessor directives to span multiple lines, both to make
  201. long ones with lots of values easier to write, and to allow for ones with
  202. multi-line quoted values.
  203. * Allow preprocessor directives to contain python-like triple-quoted
  204. text blocks, for easy nesting of quotes inside.
  205. * Add a template plugin.
  206. * Make pagespec merge code smarter about merging duplicate pagespecs.
  207. * Patch from Jordà Polo to make Setup::Standard support hashes in config
  208. files.
  209. * Change order of linkify and preprocess; first preprocess and then linkify.
  210. This allows passing a wikilink inside a parameter to a preprocessor
  211. directive without it being expanded to html, and leaking out of the
  212. parameter, which had required some non-obvious use of triple-quoting
  213. to avoid. Note that any preprocessor plugins that output something
  214. that looks like a wikilink will now have it treated as such; AFAIK
  215. this doesn't change any behavior though except for the template plugin.
  216. * Enable preprocessor directives when previewing an edit.
  217. * Make all pages pull in a local.css style sheet, if present. This won't
  218. be included in ikiwiki, but can be created to make local styling changes
  219. w/o needing to merge in every new change to the distributed style.css.
  220. * Use DESTDIR and not PREFIX to specify installation prefix for packaging.
  221. * Support running "perl Makefile.PL PREFIX=foo" to build ikiwiki to run
  222. from a different directory.
  223. * Generalised preprocesser loop protection code.
  224. * Patch from James Westby to allow a description to be set for rss feeds.
  225. * Patch from James Westby to add a template for the search form.
  226. * Added a ddate plugin.
  227. * Patch from James Westby to add a --sslcookie switch, which forces
  228. cookies to only be sent over ssl connections to avoid interception.
  229. * Fix preferences page on anonok wikis; still need to sign in to get
  230. to the preferences page.
  231. * Add toc (table of contents) plugin.
  232. * Change htmlize, format, and sanitize hooks to use named parameters.
  233. * Patch from James Westby to add an actions option to inline; this
  234. adds Edit and Discussion links at the end of blog entries.
  235. * Due to some css changes, you'll want to rebuild your wiki on upgrade
  236. to this version. Will be handled automatically by the deb.
  237. * Add processed date to aggregate preprocessor directive status output.
  238. -- Joey Hess <joeyh@debian.org> Fri, 1 Sep 2006 22:03:34 -0400
  239. ikiwiki (1.21) unstable; urgency=low
  240. * Add a tail fin^W^Wsidebar plugin by Tuomo Valkonen.
  241. * If a page links to itself, mark up the link text in a span with
  242. class="selflink" so that it can be styled. I don't have a useful style
  243. defined for that though.
  244. * Call filter hooks on inlined page content.
  245. * Support inlining pages raw, rather than creating a blog.
  246. * Clean up yes/no parameter parsing in inline plugin.
  247. * Implemented better cycle detection in the inline plugin; nested inlines
  248. will now work.
  249. * Add a map plugin contributed by Alessandro Dotti Contra.
  250. * Add otl format plugin, which handles files as created by vimoutliner.
  251. * Fix ikiwiki-mass-rebuild to work in the way the postinst uses it.
  252. * Add first draft at a Restructured Text (rst) plugin, by Sergio
  253. Talens-Oliag. Note that this has many known issues -- see the caveats on
  254. the plugin's page.
  255. * Credit everyone who wrote a plugin on the plugins' wiki pages.
  256. * Fix utf-8 in blog post form.
  257. -- Joey Hess <joeyh@debian.org> Sun, 20 Aug 2006 16:42:54 -0400
  258. ikiwiki (1.20) unstable; urgency=low
  259. * Relicense the templates and basewiki under the 2-clause BSD license.
  260. Since these can easily become part of other people's websites, they
  261. should be under as permissive a license as possible.
  262. * Add --syslog config option, to log to the syslog.
  263. * Catch failing IPC::Open2 in tidy plugin and retry in case this is a
  264. transient failure to fork (which I've seen happen in the wild).
  265. * Fix a bug in the aggregator introduced last version that caused all
  266. aggregator state to be lost during a non-aggregating build.
  267. -- Joey Hess <joeyh@debian.org> Thu, 17 Aug 2006 19:05:56 -0400
  268. ikiwiki (1.19) unstable; urgency=low
  269. * Fix several related bugs in page type determination during online editing.
  270. * Add some locking to prevent 2 aggregators from running at once.
  271. * Fix an infinite loop in the aggregator when finding a unique filename.
  272. -- Joey Hess <joeyh@debian.org> Wed, 16 Aug 2006 13:46:25 -0400
  273. ikiwiki (1.18) unstable; urgency=low
  274. * The last release accidentially installed ikiwiki as ikiwiki.pl, now fixed.
  275. * Add --version.
  276. * Man page format fixups.
  277. * If the meta plugin overides the page title, set a title_overridden
  278. variable in the template to true. This allows doing things with the
  279. templates conditional on the title being overriden.
  280. * Add a %pagecase which maps lower-case page names to the actual case
  281. used in the filename. Use this in bestlinks calculation instead of
  282. forcing the link to lowercase.
  283. * Also use %pagecase in various other places that want to check if a page
  284. with a given name exists.
  285. * This means that links to pages with mixed case names will now work,
  286. even if the link is in some other case mixture, and mixed case pages
  287. should be fully supported throughout ikiwiki.
  288. * Recommend rebuilding wikis on upgrade to this version.
  289. -- Joey Hess <joeyh@debian.org> Sat, 12 Aug 2006 22:10:48 -0400
  290. ikiwiki (1.17) unstable; urgency=low
  291. * Disable tidy generator tag.
  292. * Move tidy back to sanitize hook, found out how to only show body.
  293. * Turn off tidy indentation too.
  294. * Turn on HTML::Template loop_context_vars; not actually used in stock
  295. templates but can be useful for things like making comma-delimited lists
  296. of tags or what have you.
  297. * Remove <br> from end of aggregate preprocessor directive output.
  298. * Ship ikiwiki executable as ikiwiki.pl in source to avoid issues on
  299. case-sensative filesystems like OSX.
  300. * Improve markdown loading. First, try to load it as a proper perl module,
  301. in case it was installed as one. Then fall back to trying
  302. /usr/bin/markdown.
  303. * Document in install page how to install markdown, since it has no
  304. installation procedure in the upstream tarball.
  305. * Set die_on_bad_params => 0 for all templates, to allow users to modify
  306. them without annoyances.
  307. * Suck in the page content when generating an inline archive page, to work
  308. around the meta plugin's lack of caching of title metadata across runs.
  309. -- Joey Hess <joeyh@debian.org> Sat, 12 Aug 2006 12:52:13 -0400
  310. ikiwiki (1.16) unstable; urgency=low
  311. * Try to handle relative links in aggregated feeds. However,
  312. the current support is a crude hack due to limitations of XML::Feed:
  313. xml:base is not supported, neither is Content-Location. And of course,
  314. relative links in RSS feeds are ill-undefined..
  315. * Make aggregator save permalinks and author name to pages as metadata.
  316. * Add permalink and author support to meta plugin, affecting RSS feeds
  317. and blog pages.
  318. * Various CSS and formatting changes.
  319. * Encode link and guid urls in rss feeds to avoid illegal utf8 slipping in.
  320. * Add xhtml files to the default prune regexp.
  321. * Also generate rel=bookmark links for permalinks.
  322. * Fix the htmltidy plugin, which wasn't working due my breaking it when
  323. I added it..
  324. * Don't run tidy with -xml as that fails if the input is not well-formed.
  325. Run it with -asxhtml instead, so it will output well-formed xhtml no
  326. matter what the input.
  327. * Disable tidy warnings too.
  328. * Add a new format hook, and make tidy use it, since tidy can really only
  329. operate on and output complete html documents, not the body chunks
  330. that sanitise gets.
  331. * Fix dates in rss feeds if running localised, so they're still rfc 822.
  332. -- Joey Hess <joeyh@debian.org> Fri, 4 Aug 2006 20:48:36 -0400
  333. ikiwiki (1.15) unstable; urgency=low
  334. * Remove CDPATH and other env vars perl taint checking doesn't like.
  335. Closes: #381279
  336. * Added created_before and created_after PageSpec limits.
  337. -- Joey Hess <joeyh@debian.org> Thu, 3 Aug 2006 13:00:57 -0400
  338. ikiwiki (1.14) unstable; urgency=low
  339. * Memoize pagespec translation, this speeds up a build of the ikiwiki tree
  340. by 10% or so.
  341. * Fix stupid bug in date matching, patch from Roland Mas. Closes: #381132
  342. * Added many unit tests for pagespec_match.
  343. -- Joey Hess <joeyh@debian.org> Wed, 2 Aug 2006 11:34:06 -0400
  344. ikiwiki (1.13) unstable; urgency=low
  345. * ikiwiki can now download and aggregate feeds with its new aggregate
  346. plugin, so it's possible to implement a Planet using ikiwiki!
  347. * Add a run_hooks function for the common task of running all hooks of a
  348. given type.
  349. * Add a savestate hook.
  350. * Don't put blog post forms on pages if there's no cgiurl set.
  351. * --setup --refresh no longer rebuilds wrappers. Use --setup --refresh
  352. --wrappers to do that.
  353. * Add %IkiWiki::forcerebuild to provide a way for plugins like aggregate
  354. to update pages that haven't changed on disk.
  355. * Change meta tags to use html entity-escaped text for values, so that
  356. quotes and such can be represented in title tags.
  357. * Depend and build-depend on HTML::Parser for HTML::Entities which is used
  358. for the above.
  359. * Make --rebuild also cause --aggregate to re-download and write aggregated
  360. pages.
  361. * Avoid outputting duplicate meta info.
  362. * Include title metadata on aggregated posts for capitalised and un-munged
  363. titles.
  364. * Title metadata of inlined pages now shows up in blogs and rss feeds.
  365. * Fix issue with unicode filenames and updating the hyper estradier search
  366. index. (Aka Please Please Please, let that be the last one.)
  367. * Patch from Roland Mas to support an rss=no parameter to inline directives.
  368. Closes: #380743
  369. * Renamed GlobLists to PageSpecs.
  370. * PageSpecs can now include nested parens, "and", and "or". This remains
  371. backwards compatible to the old GlobList format. It's implemented by
  372. treating the GlobList as a very limited microlanguage that is transformed
  373. to perl code that does the matching.
  374. * The old GlobList format is deprecated, and I encourage users to switch to
  375. using the new PageSpec format. Compatability with the old format will be
  376. removed at some point, possibly by 2.0.
  377. * Wiki rebuild needed on upgrade to this version due to PageSpec change.
  378. * Add support for creation_month and creation_year to PageSpec.
  379. Closes: #380680
  380. * Changes to index file encoding.
  381. -- Joey Hess <joeyh@debian.org> Tue, 1 Aug 2006 21:21:19 -0400
  382. ikiwiki (1.12) unstable; urgency=low
  383. "Viva l'Italia!"
  384. * New pagestats plugin from Enrico, which can generate a table counting
  385. the backlinks for each page, or a del.icio.us style cloud.
  386. * Build-depend on libtext-wikiformat-perl, so that the syntax check of
  387. the wikiformat plugin works. Thanks, Emanuele Aina.
  388. * Patch from Alessandro Dotti Contra to clean up backlinks and navbar
  389. display, running them through pagetitle. This removes ugly underscores and
  390. other gunk from the display, much nicer. You may want to rebuild your wiki
  391. when upgrading to get the cleanup globally.
  392. * Polygen plugin from Enrico.
  393. * htmltidy plugin from Faidon.
  394. * Locale patch from Faidon:
  395. - Adds a locale setting to setup files.
  396. - Proper local time, if the locale configuration option is used.
  397. - Support for UTF-8 (or ISO-8859-X) filenames in SVN. Before this patch,
  398. commiting (or even rcs_updating) on repositories with UTF-8 filenames was
  399. impossible.
  400. * Add getopt hook type, this allows plugins to add new command-line options.
  401. * Add --tagbase option to tag plugin.
  402. * Add exclude option in setup files, works same as --exclude.
  403. * Put categories in rss feeds for tagged items.
  404. * Allow preprocessor directives to be expanded in inlined blog pages.
  405. However, to avoid inlining loops etc, don't expand inline directives in
  406. inlined pages.
  407. * fortune plugin (trivial)
  408. * Tag plugins according to type.
  409. -- Joey Hess <joeyh@debian.org> Sat, 29 Jul 2006 17:12:56 -0400
  410. ikiwiki (1.11) unstable; urgency=low
  411. * Patch from Enrico that
  412. - Adds a tag plugin that allows more easily tagging pages.
  413. The meta plugin can also still be used for that, but the tag plugin
  414. also lists a page's tags at the bottom of the page.
  415. - Allows preprocessor directives to have parameters with no specified
  416. value.
  417. - Fixes preprocessor directive parameter parsing so that
  418. foo=bar baz now means "foo=bar" and a "baz" with no value.
  419. * Run pagetemplate hooks when inlining pages so that inlined pages also
  420. list their tags.
  421. * Make all plugins with pagetemplate hooks check that variables exist
  422. on the template before setting them, for robustness.
  423. * Switch pagetemplate hooks to using named parameters.
  424. * Pass a destpage parameter to preprocessor and pagetemplate hooks.
  425. This will be the page that a source page will be part of, which is
  426. different than the source page for inlined pages.
  427. * Audited all plugins to endure they pass (page, destpage) to htmllink
  428. appropriatly. This means inlining of various plugins will not work
  429. properly, with correct links generated.
  430. -- Joey Hess <joeyh@debian.org> Thu, 27 Jul 2006 20:51:23 -0400
  431. ikiwiki (1.10) unstable; urgency=low
  432. * Run page through any relevant filters when generating a page preview.
  433. * Noticed a bug in the wikitext markup plugin -- it made CamelCase links the
  434. default throughout the wiki, not only on wikitext pages. Decided to call
  435. this a feature, and split the camelcase support out into a separate plugin
  436. that is independant of wikitext.
  437. * Fix CamelCase regexp to not break [[FooBar|BazBar]] WikiLinks.
  438. -- Joey Hess <joeyh@debian.org> Wed, 26 Jul 2006 18:06:35 -0400
  439. ikiwiki (1.9) unstable; urgency=low
  440. * Improve display of parentlinks and page title of toplevel index page.
  441. * Patch from Faidon to use svn --limit when possible for recentchanges,
  442. speeds up recentchanges a lot for wikis with more history.
  443. * Patch from Recai to fix utf8 issues in git backend.
  444. * Add wikitext markup plugin, which supports ".wiki" pages written in the
  445. original wiki syntax, CamelCase links and all.
  446. * Support a w3mmode, which lets w3m run ikiwiki using its local CGI
  447. support, to edit pages etc without a web server.
  448. * Display CGI processing errors if present.
  449. * Fix from Faidon for a XML parser issue that breaks utf-8 for
  450. RecentChanges. Avoid using XML::SAX::PurePerl, which is buggy in this
  451. area, and also way slow.
  452. * Match 'web commit from' in SVN and git, these are web commits too.
  453. (Faidon)
  454. * Consolidated all decode_utf8 in FormBuilder's fields to make the code more
  455. readable and avoid future mistakes. The patch seems to work and for the
  456. first time I have a UTF-8 username ;-) (Faidon)
  457. * Use form->field consistently, not form->param.
  458. * Patch from Recai to allow selection of page type when creating a new page.
  459. Default page type is inherited from the link clicked on to create the new
  460. page.
  461. -- Joey Hess <joeyh@debian.org> Wed, 26 Jul 2006 17:25:30 -0400
  462. ikiwiki (1.8) unstable; urgency=low
  463. * Fix orphans plugin to not count a link to a nonexistant page as a reason
  464. for a page not being an orphan.
  465. * Support pinging services such as Technorati using XML-RPC to notify them
  466. about changes to rss feeds.
  467. * Parse svn log as xml for improved utf8 and security. Note that this makes
  468. ikiwiki depend on XML::Simple. Patch by Faidon Liambotis.
  469. * POSIX::strftime doesn't know about encodings and doesn't return a utf8
  470. flagged string even if the locale causes it to generate utf8 output,
  471. so make sure to let perl know it should be handled as utf8. Also,
  472. the optimised version used for standard time formats won't work if the
  473. user has changed locale, so drop it. Thanks, Faidon Liambotis.
  474. * Fix re-encoding of the comments field to utf8 if a commit fails
  475. due to a conflict. Thanks, Faidon Liambotis.
  476. * Let svn know that commits have utf8 commit messages. Thanks, Faidon
  477. Liambotis.
  478. * Add insane double encode/decode to utf8 around call to markdown.
  479. This works around a truely strange bug, which is apparently a bug in
  480. perl, #376329. Also added a test case for it.
  481. * Improve layout of edit page so formatting help link is always visible w/o
  482. getting in the way of the preview.
  483. * Centralised all calls to HTML::Template and force all the templates
  484. to be read as utf8.
  485. * Support pages with utf8 filenames. Patch by Faidon Liambotis.
  486. * Introduce add_plugins and disable_plugins config options in setup files.
  487. This allows adding or removing plugins w/o overriding the whole list of
  488. default plugins, which makes it easier to upgrade when new default plugins
  489. are added.
  490. * Support htmlize plugins and make mdwn one such plugin, which is enabled by
  491. default (of course!). Based on a patch by Faidon Liambotis.
  492. * Add a html plugin, which can be used to write wikis in raw html,
  493. if you'd ever want to do such a thing. Slightly tricky, since ikiwiki
  494. defaults to not processing .html files, since w/o this plugin they would
  495. be copied unsanitised. With this plugin, it will process and html
  496. sanitise them, like any other page type.
  497. * Rebuilding wrappers is necessary on upgrade to this version.
  498. * Make ikiwiki --setup --refresh rebuild wrappers, so wrapper rebuild
  499. will be automatically done on all upgrades.
  500. * Don't send pings if the wiki is being rebuilt.
  501. * Work around very innefficient behavior in File::Spec::abs2rel. Result
  502. is a savings of 2 pointless fork/execs per link calculation, which
  503. results in ~25% speedup of ikiwiki building its own doc wiki, and
  504. about 35% speedup displaying RecentChanges!
  505. * Make RecentChanges use a table and some CSS, should be much more readable.
  506. No code changes involved.
  507. * Encode & in diffurl in examples, to conform to pedantic rules.
  508. * Speed up RecentChanges by another 40% or so with some memoization.
  509. * Memoize abs2rel, which is still kinda slow, for another 30% speedup
  510. in time to build the doc wiki.
  511. -- Joey Hess <joeyh@debian.org> Tue, 4 Jul 2006 12:46:29 -0400
  512. ikiwiki (1.7) unstable; urgency=low
  513. * Updated logo from Recai with some kerning and alingment tuning.
  514. * Patch from Recai to fix git recentchanges code to work with git 1.4 which
  515. changed some output.
  516. * Copyright update.
  517. -- Joey Hess <joeyh@debian.org> Sun, 18 Jun 2006 23:33:35 -0400
  518. ikiwiki (1.6) unstable; urgency=low
  519. * YA utf-8 patch from Recai, this time to fix previewing a page so that
  520. the text in the input box is re-encoded back to utf-8.
  521. * -CSD does not affect modules, so readfile() was not using the utf-8 input
  522. layer, which led to lots of problems; make it force read files as utf-8.
  523. Closes: #373203
  524. * Note that as a consequence, this version of ikiwiki will actually try to
  525. parse utf8 in source files for the first time, which may expose broken
  526. utf8 in wiki sources that was hidden before. Most common will be
  527. perl warnings like "utf8 "\xE9" does not map to Unicode"
  528. * writefile() likewise needs to use the utf8 output layer.
  529. * Remove the -CSD from ikiwiki's hashbang since it's useless to have it
  530. there.
  531. * Revert some of the decode_utf8 changes in CGI.pm that seem unnecessary
  532. given the readfile fix.
  533. * Add utf-8 testcases for readfile and htmlize.
  534. * Put back the encode_utf8 in the input to markdown; it's really not utf-8
  535. safe.
  536. * More utf-8 fixes from Recai, partly to things I broke above:
  537. - The serious problem is that writefile() saves the content in undecoded
  538. format in CGI, hence all (non-ascii) chars are corrupted permanently.
  539. - Comment field in edit page is not decoded and all the non-ascii chars in
  540. this field are corrupted as the result. We should decode it as we do it
  541. for the content.
  542. - Add 'use encoding "utf8"' to CGI.pm to avoid warnings about wide
  543. character in print.
  544. * New SVG logo from Recai.
  545. -- Joey Hess <joeyh@debian.org> Sun, 18 Jun 2006 19:18:46 -0400
  546. ikiwiki (1.5) unstable; urgency=low
  547. * Add --timeformat config option to allow changing how dates are displayed.
  548. Note that as a side effect, dates will now be displayed using the local
  549. timezone, not as GMT.
  550. * More security review.
  551. * Patch from Dr. Zini to add link() and backlink() to globlists. This allows
  552. for some handy stuff like:
  553. - Using links as a kind of tag; creating blog pages that list all pages
  554. containing a given tag/link or not containing some other tag.
  555. - Subscribing to mail notifications whenever a change is made to a page
  556. that is a backlink of page foo. Ie, "Please notify me of changes in all
  557. pages that link to my home page in the wiki"
  558. - Locking any pages that are linked to from a particular page, so that
  559. lists of locks can be exposed in the wiki.
  560. * Reorganised the doc wiki's todo/* pages, using a link/tag to flag
  561. when a todo item is done, instead of the previous moving it to a different
  562. subdir.
  563. * Allow pagetemplate plugins to override *anything* in the template.
  564. * Add a meta plugin, which allows specifying various metadata about pages,
  565. like license and author. It also allows for inserting html link and meta
  566. tags into html, overriding the title, and adding hidden WikiLinks, which
  567. can be useful when using link-based globbing for page categorisation.
  568. * Remove preprocessor directives from inlined pages.
  569. * Allow simple preprocessor directive values to be specified w/o quotes.
  570. * Add support for using git instead of subversion as the RCS backend,
  571. tremendous thanks to Recai Oktaş for this.
  572. * Doc updates for git.
  573. * Fix absolute url munging in rss generation to support https, ftp, etc urls
  574. not just http urls.
  575. * Patch from Recai Oktaş to improve utf-8 support, it should now use proper
  576. utf-8 for edit and other fields, and for recentchanges. There may still
  577. be utf-8 issues with the preferences page though.
  578. -- Joey Hess <joeyh@debian.org> Sun, 11 Jun 2006 19:56:54 -0400
  579. ikiwiki (1.4) unstable; urgency=low
  580. * Tell HTML::Scrubber to treat "/" as a valid attribute which is its
  581. very strange way of enabling proper XHTML <br /> type tags. Output html
  582. should be always valid again now.
  583. * The page name and parent links has switched from using a <h1> to a styled
  584. <span>, so pages can use <h1> internally instead of needing to use <h2>.
  585. * Updated all of ikiwiki's own wiki pages for that.
  586. * Add pagetemplate hook, which can be used by plugins that want to mess
  587. around with adding new stuff to the page template.
  588. * Remove headercontent; the search plugin now adds the search box to the
  589. header by registering a pagetemplate hook, and other plugins should do
  590. similarly.
  591. * Rebuilding on upgrade to this version is recommended.
  592. * Add a html validity check to the test suite, using the wdg-html-validator,
  593. if available.
  594. * Make the html valid when there is nothing in the actions list.
  595. * Reordered some function call parameters for consistency.
  596. * Enable full utf-8 support for page input and output.
  597. * Add a workaround for markdown, which does not work well with utf-8
  598. strings.
  599. * --getctime had bitrotted (well I only ever used it the once so far..),
  600. fix and make it a bit more flexible
  601. * rcs_getctime is changed, now rather than needing to loop over all pages,
  602. it should just use the rcs to get the ctime of the passed file.
  603. * When inlining a page in another one, links from the inlined page are now
  604. expanded the same as they are when rendering the inlined page as a
  605. standalone page. So rather than being expanded from the POV of the
  606. inlining page, they are expanded from the POV of the inlined page.
  607. For example, a link from blog/foo to "bar" will now link to blog/bar
  608. if it exists. Previously this needed to be a link explicitly to
  609. "blog/bar"; such links will also continue to work.
  610. (This was slightly complex to do as the link still has to be constructed
  611. relative to the inlining page.)
  612. * Make page edit textarea resize to fit browser window.
  613. * Add -refresh option to ikiwiki-mass-rebuild and use that on upgrades that
  614. do not need a full rebuild, in order to update any basewiki pages.
  615. -- Joey Hess <joeyh@debian.org> Sat, 27 May 2006 15:08:49 -0400
  616. ikiwiki (1.3) unstable; urgency=low
  617. * Fix the preinst introduced in the last version. Closes: #367458
  618. -- Joey Hess <joeyh@debian.org> Tue, 16 May 2006 02:43:02 -0500
  619. ikiwiki (1.2) unstable; urgency=low
  620. * Remove dups from the brokenlinks list.
  621. * Add libc6-dev to dependencies, needed to build wrappers.
  622. * Install wikilist in correct location. Closes: #367371
  623. -- Joey Hess <joeyh@debian.org> Mon, 15 May 2006 10:53:49 -0500
  624. ikiwiki (1.1) unstable; urgency=low
  625. * Rename inlinepage to depends, so that it can be used to refer to more
  626. dependency relationships than just inlining. This will require a rebuild
  627. on upgrade to this version.
  628. * Move the rss link, put it in the blogpost form if there is one and at the
  629. top if not. This is both nicer because easier to find, and it cleans up
  630. the code which had used inlinepage as a flag for adding the link later.
  631. * Allow the depends GlobList to be built up from multiple sources (such as
  632. plugins) during a page render.
  633. * Which means that more than one blog is now supported to appear on a
  634. single page. (With some limitations, like only the last one getting an
  635. rss file.)
  636. * Added a plugin system.
  637. * Added a pagecount plugin, enabled by default.
  638. * Support PreProcessorDirectives with no parameters, ie "[[pagecount ]]".
  639. * Fixed/optimised backlinks code, to avoid rebuilding pages to update
  640. backlinks when the backlinks hadn't really changed.
  641. * Moved inline page support, rss generation etc into the inline plugin,
  642. enabled by default.
  643. * Added brokenlinks plugin, not enabled by default, but rather handy.
  644. * Fix several broken links in the doc wiki.
  645. * Smarter behavior when creating a page and a page of the same name (but
  646. different location) already exists.
  647. * Add an orphans plugin for finding pages that nothing links to.
  648. * Removed backlinks page, which it turns out nothing used.
  649. * Split off an IkiWiki.pm out of ikiwiki and have all the other modules use
  650. it, this will allow for adding a unit test suite.
  651. * Add unit tests for several core functions, including globlist_match,
  652. dirname, basename, bestlink, linkify, pagetitle, titlepage.
  653. * Smart globlist merging.
  654. * Patch from Thomas Schwinge to switch from --svn to --rcs=svn, etc,
  655. to pave the way for adding other RCS support. This also changes the
  656. setup files, where before they had svn => 1 or svn => 0, now they have
  657. rcs => "svn" or rcs => "".
  658. * Add a debian/NEWS file with upgrade notes.
  659. * Load whatever rcs module is specified, so new ones can be just dropped in
  660. as plugins and work. (Well, in theory.)
  661. * Add some basic docs about writing RCS modules.
  662. * Broke search capability out into a plugin, removed the --hyperestraier
  663. switch.
  664. * Added smiley plugin, nicely controlled and documented by the smileys page.
  665. * Copied in some smileys from Moin Moin.
  666. * Allow links of the form [[some page|page]], with whitespace in the link
  667. text.
  668. * Removed --sanitize and --no-sanitize, replaced with --plugin htmlscrubber
  669. and --disable-plugin htmlscrubber.
  670. * Allow discussion links on pages to be turned off with --no-discussion.
  671. * Add ikiwiki-mass-rebuild script, ripped out of the postinst.
  672. * Add some new config items to the estseek.conf template, which are needed
  673. by hyperestraier 1.2.3.
  674. -- Joey Hess <joeyh@debian.org> Fri, 5 May 2006 17:00:41 -0400
  675. ikiwiki (1.0) unstable; urgency=low
  676. * First official release.
  677. -- Joey Hess <joeyh@debian.org> Tue, 25 Apr 2006 02:08:17 -0400