summaryrefslogtreecommitdiff
path: root/debian/changelog
blob: 2c59130435d0fbbeaa6aac589d1ded7f1c14202c (plain)
  1. ikiwiki (1.33) UNRELEASED; urgency=low
  2. * Fix issue with aggregate plugin updating expired pages.
  3. -- Joey Hess <joeyh@debian.org> Sat, 4 Nov 2006 14:19:47 -0500
  4. ikiwiki (1.32) unstable; urgency=low
  5. * Add a separate pass to find page links, and only render each page once,
  6. instead of over and over. Typical speedup is ~4x. Max possible speedup:
  7. 8x.
  8. * Add "scan" parameter to hook(), which is used to make the hook be called
  9. during the scanning pass, as well as the render pass. The meta and tag
  10. plugins need to use the new scan parameter, so will any others that modify
  11. %links.
  12. * Now that links are calculated in a separate pass, it can also
  13. precalculate backlinks in one pass, which is O(N^2) instead of the
  14. previous code that was O(N^3). A very nice speedup for wikis with lots
  15. (thousands) of pages.
  16. * Stylish update to the ikiwiki logo, thanks to Recai Oktaş and Selçuk
  17. Erdem.
  18. * Add a default stylesheet entry for the pagecloud.
  19. * Add examples page with some examples of things that can be done using
  20. ikiwiki, like a weblog. The examples can be copied into a user's wiki
  21. for a quick start, without needing to learn everything about how to put
  22. them together.
  23. * Install the source of the examples into /usr/share/doc/ikiwiki/examples.
  24. * Add perlmagick to build-depends so syntax check of img plugin works.
  25. Closes: #396702
  26. * Improve login/register process, the login dialog has only name and
  27. password fields, which allows more web browsers to regognise it as a login
  28. field, and is less confusing.
  29. * Implemented expiry options for aggregate plugin.
  30. * Use precalculated backlinks info when determining if files need an update
  31. due to a page they link to being added/removed. Mostly significant if
  32. there are lots of pages.
  33. * Remove duplicate link info when saving index. In some cases it could
  34. pile up rather badly. (Probably not the best way to deal with this
  35. problem.)
  36. * Patch from James Westby to support podcasting, photoblogging, vidcasting,
  37. or what have you, by creating enclosures for non-page items that are
  38. included in feeds.
  39. -- Joey Hess <joeyh@debian.org> Fri, 3 Nov 2006 14:46:37 -0500
  40. ikiwiki (1.31) unstable; urgency=low
  41. * Patch from Pawel Tecza to cp -a the templates in the Makefile.
  42. * Change the rss feed title from the wikiname to the page title, with
  43. an exception for the wiki's toplevel index page, which will still use the
  44. wikiname as the feed title.
  45. Overriding the page title with meta title already overrode the rss feed
  46. tittle.
  47. * Add an img plugin, based on Christian Mock's img plugin, but stripped
  48. down to the bare essentials. Useful for handling large images on websites.
  49. * Sanitize possibly problimatic characters out of the polygen grammar names,
  50. just in case. Should not be exploitable anyway, since it only tries to run
  51. polygen after finding the specified grammar file.
  52. * Add missing dependency on the URI perl module.
  53. * Add basic spam fighting tool for admins: An admin's prefs page now allows
  54. editing a list of banned users.
  55. -- Joey Hess <joeyh@debian.org> Fri, 27 Oct 2006 23:16:33 -0400
  56. ikiwiki (1.30) unstable; urgency=low
  57. * Add no_override parameter to hook().
  58. * Add a shortcut plugin, inspired by Victor Moral's contributed shortcuts
  59. plugin, but featuring a more ikiwiki-ish syntax and with shortcuts that
  60. can be configured using a page in wiki.
  61. * Fix support for --pingurl at the command line.
  62. * Fix a subtle bug in will_render that broke some builds, by only clearing
  63. items from renderedfiles the first time per build.
  64. * Wrap entire technortati ping operation in an eval to catch all possible
  65. failure modes, after I observed a simple ->value crashing ikiwiki when
  66. a ping failed.
  67. -- Joey Hess <joeyh@debian.org> Mon, 16 Oct 2006 15:17:38 -0400
  68. ikiwiki (1.29) unstable; urgency=low
  69. * Patch from Paul Tötterman to use CP in the Makefile.
  70. * Patch from Alec Berryman adding a http_auth config item that allows
  71. using HTTP Authentication instead of ikiwiki's built in authentication.
  72. Useful for eg, large sites with their own previously existing user auth
  73. setup. Closes: #384534
  74. * Change %renderedfiles to store an array of files rendered from a given
  75. source file, to allow tracking of extra rendered files like rss feeds.
  76. * Note that plugins that accessed this variable will need to be updated!
  77. The plugin interface has been increased to version 1.01 for this change.
  78. As few plugins use %renderedfiles I haven't done anything else to ensure
  79. compatability of old plugins.
  80. * Add will_render function to the plugin interface, used to register that a
  81. page renders a destination file, and do some security checks. Previously
  82. but no longer rendered files will be cleaned up.
  83. * Use will_render in the inline and linkmap plugins.
  84. * You will need to rebuild your wiki on upgrade to this version.
  85. * Atom feed support based on a patch by Clint Adams.
  86. * Add feeds=no option to inline preprocessor directive to turn off all types
  87. of feeds.
  88. * $IkiWiki::version now holds the program version, and is accessible to
  89. plugins.
  90. * Make the aggregate plugin emphasize error messages.
  91. * Patch from Recai to limit recentchanges to displaying max 10 files for a
  92. given changeset (to avoid large number of file changes excessively
  93. bloating the page).
  94. -- Joey Hess <joeyh@debian.org> Fri, 13 Oct 2006 23:14:28 -0400
  95. ikiwiki (1.28) unstable; urgency=low
  96. * inline: Add ability to sort by page name, based on a patch from
  97. Benjamin A'Lee.
  98. * Fix a forkbomb in various calls to IPC::Open2, which has a highly
  99. braindead interface. Closes: #389383
  100. * Don't rm -rf ikiwiki on distclean, since a) there's no such file
  101. and b) those poor Mac OSX users and their case insensative files!
  102. * Don't fail syntax check if Text::Typography isn't installed.
  103. Closes: #389406
  104. -- Joey Hess <joeyh@debian.org> Tue, 26 Sep 2006 02:08:17 -0400
  105. ikiwiki (1.27) unstable; urgency=low
  106. * Work on firming up the plugin interface:
  107. - Plugins should not need to load IkiWiki::Render to get commonly
  108. used functions, so moved some functions from there to IkiWiki.
  109. - Picked out the set of functions and variables that most plugins
  110. use, documented them, and made IkiWiki export them by default,
  111. like a proper perl module should.
  112. - Use the other functions at your own risk.
  113. - This is not quite complete, I still have to decide whether to
  114. export some other things.
  115. * Changed all plugins included in ikiwiki to not use "IkiWiki::" when
  116. referring to stuff now exported by the IkiWiki module.
  117. * Add a module version number to IkiWiki, so you can "use IkiWiki '1.00'"
  118. to declare which version of the interface your plugin needs.
  119. * Anyone with a third-party ikiwiki plugin is strongly encouraged
  120. to make like changes to it and avoid use of non-exported symbols from
  121. "IkiWiki::".
  122. * Link debian/changelog and debian/news to NEWS and CHANGELOG.
  123. * Support hyperestradier version 1.4.2, which adds a new required phraseform
  124. setting.
  125. * If an inlined page has a permalink, link the page title to that.
  126. * Patch from Recai to use utf8 when reading the setup file, so that
  127. utf8 wikinames from there will be used properly.
  128. * Patch from Recai to kill utf-8 on the wiki name when generating the
  129. session cookie.
  130. * Change ddate plugin to use the DateTime::Calendar::Discordian perl module.
  131. * Fix a baseurl problem in hyperestradier search results.
  132. * Add a stub local.css to avoid problems with 404's.
  133. * Patch from Recai to fix a wide character warning from the search plugin
  134. during setup if the wikiname contains utf8.
  135. * Yet another fix for those poor case-insensative OS X users.
  136. * pagetemplate hooks are now also called when generating cgi pages.
  137. * Add a favicon plugin, which simply adds a link tag for an icon to each
  138. page (and cgis).
  139. * Patch from James Westby to deal with the case where you're editing a
  140. new page, hit cancel, and need to be redirected to somewhere sane.
  141. * Various documentation improvements by various wiki users.
  142. * Support Text::Markdown from CPAN, which has a different interface from
  143. the original markdown or the one in Debian.
  144. * Version the libcgi-session-perl dependency, some features that need
  145. the new version are used in some cases (sslcookie).
  146. * Numerous tla fixes from Clint.
  147. * Updated ikiwiki.svgz from Recai, includes an icon and is used to generate
  148. a multi-resolution favicon.ico.
  149. * README.Debian: typo Closes: #388110
  150. * chomp trailing newline at the end of templates read in by the template
  151. plugin, to allow use of the template preprocessor directive in
  152. whitespace-sensative situations. Closes: #387073
  153. * Patch from James Westby to make the location of the estseek.cgi script
  154. configurable.
  155. * Add typography (SmartyPants) plugin by Recai.
  156. * Add --render mode, which can be used to preview an edit at the command
  157. line by test rendering a single page.
  158. * Add a googlecalendar plugin. A bit special-purpose, but it shows
  159. one way to to deal with user-supplied content that could cause XSS
  160. issues w/o the htmlscrubber, and won't survive the scrubber.
  161. -- Joey Hess <joeyh@debian.org> Sun, 24 Sep 2006 00:02:21 -0400
  162. ikiwiki (1.26) unstable; urgency=low
  163. * Add a missing -n to tla undo call.
  164. * otl2hmtl can't be safely used with IPC::Open2 since it sometimes
  165. writes before consuming its whole stdin. Avoid this deadlock.
  166. * Fix alt tags for outline checkboxes.
  167. -- Joey Hess <joeyh@debian.org> Fri, 8 Sep 2006 16:24:16 -0400
  168. ikiwiki (1.25) unstable; urgency=low
  169. * Add proper waitpid calls for open2ed processes throughout to avoid
  170. zombies; this hit htmltidy especially badly.
  171. * Drop real uid/gid in the suid wrapper, thus allowing commits to remote
  172. subversion repos and fixing some other issues.
  173. * Add support for tla, contributed by Clint Adams. Closes: #385936
  174. * Add support for mercurial, contributed by Emanuele Aina.
  175. * Include <link rel> tag for RSS feeds, used by some aggregators and
  176. firefox to find the feed.
  177. * Add a linkmap plugin (requires graphviz).
  178. -- Joey Hess <joeyh@debian.org> Fri, 8 Sep 2006 01:54:14 -0400
  179. ikiwiki (1.24) unstable; urgency=low
  180. * Simplify the data structure returned by rcs_recentchanges to avoid
  181. each rcs plugin needing to form complex strings on its own.
  182. * Fix another destpage issue in the inline directive. Closes: #385512
  183. again.
  184. -- Joey Hess <joeyh@debian.org> Sun, 3 Sep 2006 15:46:45 -0400
  185. ikiwiki (1.23) unstable; urgency=low
  186. * Allow inline directives to be nested inside eg, sidebars. Closes: #385512
  187. -- Joey Hess <joeyh@debian.org> Sun, 3 Sep 2006 12:14:45 -0400
  188. ikiwiki (1.22) unstable; urgency=low
  189. * Change how the stylesheet url is determined in the templates: Remove
  190. STYLEURL and add BASEURL to all templates (some already had it). This
  191. new more general variable can be used to link to other things (eg, images)
  192. from the template, as well as stylesheets.
  193. * Fix a bug introduced last version to do with nested inlines.
  194. * Allow preprocessor directives to span multiple lines, both to make
  195. long ones with lots of values easier to write, and to allow for ones with
  196. multi-line quoted values.
  197. * Allow preprocessor directives to contain python-like triple-quoted
  198. text blocks, for easy nesting of quotes inside.
  199. * Add a template plugin.
  200. * Make pagespec merge code smarter about merging duplicate pagespecs.
  201. * Patch from Jordà Polo to make Setup::Standard support hashes in config
  202. files.
  203. * Change order of linkify and preprocess; first preprocess and then linkify.
  204. This allows passing a wikilink inside a parameter to a preprocessor
  205. directive without it being expanded to html, and leaking out of the
  206. parameter, which had required some non-obvious use of triple-quoting
  207. to avoid. Note that any preprocessor plugins that output something
  208. that looks like a wikilink will now have it treated as such; AFAIK
  209. this doesn't change any behavior though except for the template plugin.
  210. * Enable preprocessor directives when previewing an edit.
  211. * Make all pages pull in a local.css style sheet, if present. This won't
  212. be included in ikiwiki, but can be created to make local styling changes
  213. w/o needing to merge in every new change to the distributed style.css.
  214. * Use DESTDIR and not PREFIX to specify installation prefix for packaging.
  215. * Support running "perl Makefile.PL PREFIX=foo" to build ikiwiki to run
  216. from a different directory.
  217. * Generalised preprocesser loop protection code.
  218. * Patch from James Westby to allow a description to be set for rss feeds.
  219. * Patch from James Westby to add a template for the search form.
  220. * Added a ddate plugin.
  221. * Patch from James Westby to add a --sslcookie switch, which forces
  222. cookies to only be sent over ssl connections to avoid interception.
  223. * Fix preferences page on anonok wikis; still need to sign in to get
  224. to the preferences page.
  225. * Add toc (table of contents) plugin.
  226. * Change htmlize, format, and sanitize hooks to use named parameters.
  227. * Patch from James Westby to add an actions option to inline; this
  228. adds Edit and Discussion links at the end of blog entries.
  229. * Due to some css changes, you'll want to rebuild your wiki on upgrade
  230. to this version. Will be handled automatically by the deb.
  231. * Add processed date to aggregate preprocessor directive status output.
  232. -- Joey Hess <joeyh@debian.org> Fri, 1 Sep 2006 22:03:34 -0400
  233. ikiwiki (1.21) unstable; urgency=low
  234. * Add a tail fin^W^Wsidebar plugin by Tuomo Valkonen.
  235. * If a page links to itself, mark up the link text in a span with
  236. class="selflink" so that it can be styled. I don't have a useful style
  237. defined for that though.
  238. * Call filter hooks on inlined page content.
  239. * Support inlining pages raw, rather than creating a blog.
  240. * Clean up yes/no parameter parsing in inline plugin.
  241. * Implemented better cycle detection in the inline plugin; nested inlines
  242. will now work.
  243. * Add a map plugin contributed by Alessandro Dotti Contra.
  244. * Add otl format plugin, which handles files as created by vimoutliner.
  245. * Fix ikiwiki-mass-rebuild to work in the way the postinst uses it.
  246. * Add first draft at a Restructured Text (rst) plugin, by Sergio
  247. Talens-Oliag. Note that this has many known issues -- see the caveats on
  248. the plugin's page.
  249. * Credit everyone who wrote a plugin on the plugins' wiki pages.
  250. * Fix utf-8 in blog post form.
  251. -- Joey Hess <joeyh@debian.org> Sun, 20 Aug 2006 16:42:54 -0400
  252. ikiwiki (1.20) unstable; urgency=low
  253. * Relicense the templates and basewiki under the 2-clause BSD license.
  254. Since these can easily become part of other people's websites, they
  255. should be under as permissive a license as possible.
  256. * Add --syslog config option, to log to the syslog.
  257. * Catch failing IPC::Open2 in tidy plugin and retry in case this is a
  258. transient failure to fork (which I've seen happen in the wild).
  259. * Fix a bug in the aggregator introduced last version that caused all
  260. aggregator state to be lost during a non-aggregating build.
  261. -- Joey Hess <joeyh@debian.org> Thu, 17 Aug 2006 19:05:56 -0400
  262. ikiwiki (1.19) unstable; urgency=low
  263. * Fix several related bugs in page type determination during online editing.
  264. * Add some locking to prevent 2 aggregators from running at once.
  265. * Fix an infinite loop in the aggregator when finding a unique filename.
  266. -- Joey Hess <joeyh@debian.org> Wed, 16 Aug 2006 13:46:25 -0400
  267. ikiwiki (1.18) unstable; urgency=low
  268. * The last release accidentially installed ikiwiki as ikiwiki.pl, now fixed.
  269. * Add --version.
  270. * Man page format fixups.
  271. * If the meta plugin overides the page title, set a title_overridden
  272. variable in the template to true. This allows doing things with the
  273. templates conditional on the title being overriden.
  274. * Add a %pagecase which maps lower-case page names to the actual case
  275. used in the filename. Use this in bestlinks calculation instead of
  276. forcing the link to lowercase.
  277. * Also use %pagecase in various other places that want to check if a page
  278. with a given name exists.
  279. * This means that links to pages with mixed case names will now work,
  280. even if the link is in some other case mixture, and mixed case pages
  281. should be fully supported throughout ikiwiki.
  282. * Recommend rebuilding wikis on upgrade to this version.
  283. -- Joey Hess <joeyh@debian.org> Sat, 12 Aug 2006 22:10:48 -0400
  284. ikiwiki (1.17) unstable; urgency=low
  285. * Disable tidy generator tag.
  286. * Move tidy back to sanitize hook, found out how to only show body.
  287. * Turn off tidy indentation too.
  288. * Turn on HTML::Template loop_context_vars; not actually used in stock
  289. templates but can be useful for things like making comma-delimited lists
  290. of tags or what have you.
  291. * Remove <br> from end of aggregate preprocessor directive output.
  292. * Ship ikiwiki executable as ikiwiki.pl in source to avoid issues on
  293. case-sensative filesystems like OSX.
  294. * Improve markdown loading. First, try to load it as a proper perl module,
  295. in case it was installed as one. Then fall back to trying
  296. /usr/bin/markdown.
  297. * Document in install page how to install markdown, since it has no
  298. installation procedure in the upstream tarball.
  299. * Set die_on_bad_params => 0 for all templates, to allow users to modify
  300. them without annoyances.
  301. * Suck in the page content when generating an inline archive page, to work
  302. around the meta plugin's lack of caching of title metadata across runs.
  303. -- Joey Hess <joeyh@debian.org> Sat, 12 Aug 2006 12:52:13 -0400
  304. ikiwiki (1.16) unstable; urgency=low
  305. * Try to handle relative links in aggregated feeds. However,
  306. the current support is a crude hack due to limitations of XML::Feed:
  307. xml:base is not supported, neither is Content-Location. And of course,
  308. relative links in RSS feeds are ill-undefined..
  309. * Make aggregator save permalinks and author name to pages as metadata.
  310. * Add permalink and author support to meta plugin, affecting RSS feeds
  311. and blog pages.
  312. * Various CSS and formatting changes.
  313. * Encode link and guid urls in rss feeds to avoid illegal utf8 slipping in.
  314. * Add xhtml files to the default prune regexp.
  315. * Also generate rel=bookmark links for permalinks.
  316. * Fix the htmltidy plugin, which wasn't working due my breaking it when
  317. I added it..
  318. * Don't run tidy with -xml as that fails if the input is not well-formed.
  319. Run it with -asxhtml instead, so it will output well-formed xhtml no
  320. matter what the input.
  321. * Disable tidy warnings too.
  322. * Add a new format hook, and make tidy use it, since tidy can really only
  323. operate on and output complete html documents, not the body chunks
  324. that sanitise gets.
  325. * Fix dates in rss feeds if running localised, so they're still rfc 822.
  326. -- Joey Hess <joeyh@debian.org> Fri, 4 Aug 2006 20:48:36 -0400
  327. ikiwiki (1.15) unstable; urgency=low
  328. * Remove CDPATH and other env vars perl taint checking doesn't like.
  329. Closes: #381279
  330. * Added created_before and created_after PageSpec limits.
  331. -- Joey Hess <joeyh@debian.org> Thu, 3 Aug 2006 13:00:57 -0400
  332. ikiwiki (1.14) unstable; urgency=low
  333. * Memoize pagespec translation, this speeds up a build of the ikiwiki tree
  334. by 10% or so.
  335. * Fix stupid bug in date matching, patch from Roland Mas. Closes: #381132
  336. * Added many unit tests for pagespec_match.
  337. -- Joey Hess <joeyh@debian.org> Wed, 2 Aug 2006 11:34:06 -0400
  338. ikiwiki (1.13) unstable; urgency=low
  339. * ikiwiki can now download and aggregate feeds with its new aggregate
  340. plugin, so it's possible to implement a Planet using ikiwiki!
  341. * Add a run_hooks function for the common task of running all hooks of a
  342. given type.
  343. * Add a savestate hook.
  344. * Don't put blog post forms on pages if there's no cgiurl set.
  345. * --setup --refresh no longer rebuilds wrappers. Use --setup --refresh
  346. --wrappers to do that.
  347. * Add %IkiWiki::forcerebuild to provide a way for plugins like aggregate
  348. to update pages that haven't changed on disk.
  349. * Change meta tags to use html entity-escaped text for values, so that
  350. quotes and such can be represented in title tags.
  351. * Depend and build-depend on HTML::Parser for HTML::Entities which is used
  352. for the above.
  353. * Make --rebuild also cause --aggregate to re-download and write aggregated
  354. pages.
  355. * Avoid outputting duplicate meta info.
  356. * Include title metadata on aggregated posts for capitalised and un-munged
  357. titles.
  358. * Title metadata of inlined pages now shows up in blogs and rss feeds.
  359. * Fix issue with unicode filenames and updating the hyper estradier search
  360. index. (Aka Please Please Please, let that be the last one.)
  361. * Patch from Roland Mas to support an rss=no parameter to inline directives.
  362. Closes: #380743
  363. * Renamed GlobLists to PageSpecs.
  364. * PageSpecs can now include nested parens, "and", and "or". This remains
  365. backwards compatible to the old GlobList format. It's implemented by
  366. treating the GlobList as a very limited microlanguage that is transformed
  367. to perl code that does the matching.
  368. * The old GlobList format is deprecated, and I encourage users to switch to
  369. using the new PageSpec format. Compatability with the old format will be
  370. removed at some point, possibly by 2.0.
  371. * Wiki rebuild needed on upgrade to this version due to PageSpec change.
  372. * Add support for creation_month and creation_year to PageSpec.
  373. Closes: #380680
  374. * Changes to index file encoding.
  375. -- Joey Hess <joeyh@debian.org> Tue, 1 Aug 2006 21:21:19 -0400
  376. ikiwiki (1.12) unstable; urgency=low
  377. "Viva l'Italia!"
  378. * New pagestats plugin from Enrico, which can generate a table counting
  379. the backlinks for each page, or a del.icio.us style cloud.
  380. * Build-depend on libtext-wikiformat-perl, so that the syntax check of
  381. the wikiformat plugin works. Thanks, Emanuele Aina.
  382. * Patch from Alessandro Dotti Contra to clean up backlinks and navbar
  383. display, running them through pagetitle. This removes ugly underscores and
  384. other gunk from the display, much nicer. You may want to rebuild your wiki
  385. when upgrading to get the cleanup globally.
  386. * Polygen plugin from Enrico.
  387. * htmltidy plugin from Faidon.
  388. * Locale patch from Faidon:
  389. - Adds a locale setting to setup files.
  390. - Proper local time, if the locale configuration option is used.
  391. - Support for UTF-8 (or ISO-8859-X) filenames in SVN. Before this patch,
  392. commiting (or even rcs_updating) on repositories with UTF-8 filenames was
  393. impossible.
  394. * Add getopt hook type, this allows plugins to add new command-line options.
  395. * Add --tagbase option to tag plugin.
  396. * Add exclude option in setup files, works same as --exclude.
  397. * Put categories in rss feeds for tagged items.
  398. * Allow preprocessor directives to be expanded in inlined blog pages.
  399. However, to avoid inlining loops etc, don't expand inline directives in
  400. inlined pages.
  401. * fortune plugin (trivial)
  402. * Tag plugins according to type.
  403. -- Joey Hess <joeyh@debian.org> Sat, 29 Jul 2006 17:12:56 -0400
  404. ikiwiki (1.11) unstable; urgency=low
  405. * Patch from Enrico that
  406. - Adds a tag plugin that allows more easily tagging pages.
  407. The meta plugin can also still be used for that, but the tag plugin
  408. also lists a page's tags at the bottom of the page.
  409. - Allows preprocessor directives to have parameters with no specified
  410. value.
  411. - Fixes preprocessor directive parameter parsing so that
  412. foo=bar baz now means "foo=bar" and a "baz" with no value.
  413. * Run pagetemplate hooks when inlining pages so that inlined pages also
  414. list their tags.
  415. * Make all plugins with pagetemplate hooks check that variables exist
  416. on the template before setting them, for robustness.
  417. * Switch pagetemplate hooks to using named parameters.
  418. * Pass a destpage parameter to preprocessor and pagetemplate hooks.
  419. This will be the page that a source page will be part of, which is
  420. different than the source page for inlined pages.
  421. * Audited all plugins to endure they pass (page, destpage) to htmllink
  422. appropriatly. This means inlining of various plugins will not work
  423. properly, with correct links generated.
  424. -- Joey Hess <joeyh@debian.org> Thu, 27 Jul 2006 20:51:23 -0400
  425. ikiwiki (1.10) unstable; urgency=low
  426. * Run page through any relevant filters when generating a page preview.
  427. * Noticed a bug in the wikitext markup plugin -- it made CamelCase links the
  428. default throughout the wiki, not only on wikitext pages. Decided to call
  429. this a feature, and split the camelcase support out into a separate plugin
  430. that is independant of wikitext.
  431. * Fix CamelCase regexp to not break [[FooBar|BazBar]] WikiLinks.
  432. -- Joey Hess <joeyh@debian.org> Wed, 26 Jul 2006 18:06:35 -0400
  433. ikiwiki (1.9) unstable; urgency=low
  434. * Improve display of parentlinks and page title of toplevel index page.
  435. * Patch from Faidon to use svn --limit when possible for recentchanges,
  436. speeds up recentchanges a lot for wikis with more history.
  437. * Patch from Recai to fix utf8 issues in git backend.
  438. * Add wikitext markup plugin, which supports ".wiki" pages written in the
  439. original wiki syntax, CamelCase links and all.
  440. * Support a w3mmode, which lets w3m run ikiwiki using its local CGI
  441. support, to edit pages etc without a web server.
  442. * Display CGI processing errors if present.
  443. * Fix from Faidon for a XML parser issue that breaks utf-8 for
  444. RecentChanges. Avoid using XML::SAX::PurePerl, which is buggy in this
  445. area, and also way slow.
  446. * Match 'web commit from' in SVN and git, these are web commits too.
  447. (Faidon)
  448. * Consolidated all decode_utf8 in FormBuilder's fields to make the code more
  449. readable and avoid future mistakes. The patch seems to work and for the
  450. first time I have a UTF-8 username ;-) (Faidon)
  451. * Use form->field consistently, not form->param.
  452. * Patch from Recai to allow selection of page type when creating a new page.
  453. Default page type is inherited from the link clicked on to create the new
  454. page.
  455. -- Joey Hess <joeyh@debian.org> Wed, 26 Jul 2006 17:25:30 -0400
  456. ikiwiki (1.8) unstable; urgency=low
  457. * Fix orphans plugin to not count a link to a nonexistant page as a reason
  458. for a page not being an orphan.
  459. * Support pinging services such as Technorati using XML-RPC to notify them
  460. about changes to rss feeds.
  461. * Parse svn log as xml for improved utf8 and security. Note that this makes
  462. ikiwiki depend on XML::Simple. Patch by Faidon Liambotis.
  463. * POSIX::strftime doesn't know about encodings and doesn't return a utf8
  464. flagged string even if the locale causes it to generate utf8 output,
  465. so make sure to let perl know it should be handled as utf8. Also,
  466. the optimised version used for standard time formats won't work if the
  467. user has changed locale, so drop it. Thanks, Faidon Liambotis.
  468. * Fix re-encoding of the comments field to utf8 if a commit fails
  469. due to a conflict. Thanks, Faidon Liambotis.
  470. * Let svn know that commits have utf8 commit messages. Thanks, Faidon
  471. Liambotis.
  472. * Add insane double encode/decode to utf8 around call to markdown.
  473. This works around a truely strange bug, which is apparently a bug in
  474. perl, #376329. Also added a test case for it.
  475. * Improve layout of edit page so formatting help link is always visible w/o
  476. getting in the way of the preview.
  477. * Centralised all calls to HTML::Template and force all the templates
  478. to be read as utf8.
  479. * Support pages with utf8 filenames. Patch by Faidon Liambotis.
  480. * Introduce add_plugins and disable_plugins config options in setup files.
  481. This allows adding or removing plugins w/o overriding the whole list of
  482. default plugins, which makes it easier to upgrade when new default plugins
  483. are added.
  484. * Support htmlize plugins and make mdwn one such plugin, which is enabled by
  485. default (of course!). Based on a patch by Faidon Liambotis.
  486. * Add a html plugin, which can be used to write wikis in raw html,
  487. if you'd ever want to do such a thing. Slightly tricky, since ikiwiki
  488. defaults to not processing .html files, since w/o this plugin they would
  489. be copied unsanitised. With this plugin, it will process and html
  490. sanitise them, like any other page type.
  491. * Rebuilding wrappers is necessary on upgrade to this version.
  492. * Make ikiwiki --setup --refresh rebuild wrappers, so wrapper rebuild
  493. will be automatically done on all upgrades.
  494. * Don't send pings if the wiki is being rebuilt.
  495. * Work around very innefficient behavior in File::Spec::abs2rel. Result
  496. is a savings of 2 pointless fork/execs per link calculation, which
  497. results in ~25% speedup of ikiwiki building its own doc wiki, and
  498. about 35% speedup displaying RecentChanges!
  499. * Make RecentChanges use a table and some CSS, should be much more readable.
  500. No code changes involved.
  501. * Encode & in diffurl in examples, to conform to pedantic rules.
  502. * Speed up RecentChanges by another 40% or so with some memoization.
  503. * Memoize abs2rel, which is still kinda slow, for another 30% speedup
  504. in time to build the doc wiki.
  505. -- Joey Hess <joeyh@debian.org> Tue, 4 Jul 2006 12:46:29 -0400
  506. ikiwiki (1.7) unstable; urgency=low
  507. * Updated logo from Recai with some kerning and alingment tuning.
  508. * Patch from Recai to fix git recentchanges code to work with git 1.4 which
  509. changed some output.
  510. * Copyright update.
  511. -- Joey Hess <joeyh@debian.org> Sun, 18 Jun 2006 23:33:35 -0400
  512. ikiwiki (1.6) unstable; urgency=low
  513. * YA utf-8 patch from Recai, this time to fix previewing a page so that
  514. the text in the input box is re-encoded back to utf-8.
  515. * -CSD does not affect modules, so readfile() was not using the utf-8 input
  516. layer, which led to lots of problems; make it force read files as utf-8.
  517. Closes: #373203
  518. * Note that as a consequence, this version of ikiwiki will actually try to
  519. parse utf8 in source files for the first time, which may expose broken
  520. utf8 in wiki sources that was hidden before. Most common will be
  521. perl warnings like "utf8 "\xE9" does not map to Unicode"
  522. * writefile() likewise needs to use the utf8 output layer.
  523. * Remove the -CSD from ikiwiki's hashbang since it's useless to have it
  524. there.
  525. * Revert some of the decode_utf8 changes in CGI.pm that seem unnecessary
  526. given the readfile fix.
  527. * Add utf-8 testcases for readfile and htmlize.
  528. * Put back the encode_utf8 in the input to markdown; it's really not utf-8
  529. safe.
  530. * More utf-8 fixes from Recai, partly to things I broke above:
  531. - The serious problem is that writefile() saves the content in undecoded
  532. format in CGI, hence all (non-ascii) chars are corrupted permanently.
  533. - Comment field in edit page is not decoded and all the non-ascii chars in
  534. this field are corrupted as the result. We should decode it as we do it
  535. for the content.
  536. - Add 'use encoding "utf8"' to CGI.pm to avoid warnings about wide
  537. character in print.
  538. * New SVG logo from Recai.
  539. -- Joey Hess <joeyh@debian.org> Sun, 18 Jun 2006 19:18:46 -0400
  540. ikiwiki (1.5) unstable; urgency=low
  541. * Add --timeformat config option to allow changing how dates are displayed.
  542. Note that as a side effect, dates will now be displayed using the local
  543. timezone, not as GMT.
  544. * More security review.
  545. * Patch from Dr. Zini to add link() and backlink() to globlists. This allows
  546. for some handy stuff like:
  547. - Using links as a kind of tag; creating blog pages that list all pages
  548. containing a given tag/link or not containing some other tag.
  549. - Subscribing to mail notifications whenever a change is made to a page
  550. that is a backlink of page foo. Ie, "Please notify me of changes in all
  551. pages that link to my home page in the wiki"
  552. - Locking any pages that are linked to from a particular page, so that
  553. lists of locks can be exposed in the wiki.
  554. * Reorganised the doc wiki's todo/* pages, using a link/tag to flag
  555. when a todo item is done, instead of the previous moving it to a different
  556. subdir.
  557. * Allow pagetemplate plugins to override *anything* in the template.
  558. * Add a meta plugin, which allows specifying various metadata about pages,
  559. like license and author. It also allows for inserting html link and meta
  560. tags into html, overriding the title, and adding hidden WikiLinks, which
  561. can be useful when using link-based globbing for page categorisation.
  562. * Remove preprocessor directives from inlined pages.
  563. * Allow simple preprocessor directive values to be specified w/o quotes.
  564. * Add support for using git instead of subversion as the RCS backend,
  565. tremendous thanks to Recai Oktaş for this.
  566. * Doc updates for git.
  567. * Fix absolute url munging in rss generation to support https, ftp, etc urls
  568. not just http urls.
  569. * Patch from Recai Oktaş to improve utf-8 support, it should now use proper
  570. utf-8 for edit and other fields, and for recentchanges. There may still
  571. be utf-8 issues with the preferences page though.
  572. -- Joey Hess <joeyh@debian.org> Sun, 11 Jun 2006 19:56:54 -0400
  573. ikiwiki (1.4) unstable; urgency=low
  574. * Tell HTML::Scrubber to treat "/" as a valid attribute which is its
  575. very strange way of enabling proper XHTML <br /> type tags. Output html
  576. should be always valid again now.
  577. * The page name and parent links has switched from using a <h1> to a styled
  578. <span>, so pages can use <h1> internally instead of needing to use <h2>.
  579. * Updated all of ikiwiki's own wiki pages for that.
  580. * Add pagetemplate hook, which can be used by plugins that want to mess
  581. around with adding new stuff to the page template.
  582. * Remove headercontent; the search plugin now adds the search box to the
  583. header by registering a pagetemplate hook, and other plugins should do
  584. similarly.
  585. * Rebuilding on upgrade to this version is recommended.
  586. * Add a html validity check to the test suite, using the wdg-html-validator,
  587. if available.
  588. * Make the html valid when there is nothing in the actions list.
  589. * Reordered some function call parameters for consistency.
  590. * Enable full utf-8 support for page input and output.
  591. * Add a workaround for markdown, which does not work well with utf-8
  592. strings.
  593. * --getctime had bitrotted (well I only ever used it the once so far..),
  594. fix and make it a bit more flexible
  595. * rcs_getctime is changed, now rather than needing to loop over all pages,
  596. it should just use the rcs to get the ctime of the passed file.
  597. * When inlining a page in another one, links from the inlined page are now
  598. expanded the same as they are when rendering the inlined page as a
  599. standalone page. So rather than being expanded from the POV of the
  600. inlining page, they are expanded from the POV of the inlined page.
  601. For example, a link from blog/foo to "bar" will now link to blog/bar
  602. if it exists. Previously this needed to be a link explicitly to
  603. "blog/bar"; such links will also continue to work.
  604. (This was slightly complex to do as the link still has to be constructed
  605. relative to the inlining page.)
  606. * Make page edit textarea resize to fit browser window.
  607. * Add -refresh option to ikiwiki-mass-rebuild and use that on upgrades that
  608. do not need a full rebuild, in order to update any basewiki pages.
  609. -- Joey Hess <joeyh@debian.org> Sat, 27 May 2006 15:08:49 -0400
  610. ikiwiki (1.3) unstable; urgency=low
  611. * Fix the preinst introduced in the last version. Closes: #367458
  612. -- Joey Hess <joeyh@debian.org> Tue, 16 May 2006 02:43:02 -0500
  613. ikiwiki (1.2) unstable; urgency=low
  614. * Remove dups from the brokenlinks list.
  615. * Add libc6-dev to dependencies, needed to build wrappers.
  616. * Install wikilist in correct location. Closes: #367371
  617. -- Joey Hess <joeyh@debian.org> Mon, 15 May 2006 10:53:49 -0500
  618. ikiwiki (1.1) unstable; urgency=low
  619. * Rename inlinepage to depends, so that it can be used to refer to more
  620. dependency relationships than just inlining. This will require a rebuild
  621. on upgrade to this version.
  622. * Move the rss link, put it in the blogpost form if there is one and at the
  623. top if not. This is both nicer because easier to find, and it cleans up
  624. the code which had used inlinepage as a flag for adding the link later.
  625. * Allow the depends GlobList to be built up from multiple sources (such as
  626. plugins) during a page render.
  627. * Which means that more than one blog is now supported to appear on a
  628. single page. (With some limitations, like only the last one getting an
  629. rss file.)
  630. * Added a plugin system.
  631. * Added a pagecount plugin, enabled by default.
  632. * Support PreProcessorDirectives with no parameters, ie "[[pagecount ]]".
  633. * Fixed/optimised backlinks code, to avoid rebuilding pages to update
  634. backlinks when the backlinks hadn't really changed.
  635. * Moved inline page support, rss generation etc into the inline plugin,
  636. enabled by default.
  637. * Added brokenlinks plugin, not enabled by default, but rather handy.
  638. * Fix several broken links in the doc wiki.
  639. * Smarter behavior when creating a page and a page of the same name (but
  640. different location) already exists.
  641. * Add an orphans plugin for finding pages that nothing links to.
  642. * Removed backlinks page, which it turns out nothing used.
  643. * Split off an IkiWiki.pm out of ikiwiki and have all the other modules use
  644. it, this will allow for adding a unit test suite.
  645. * Add unit tests for several core functions, including globlist_match,
  646. dirname, basename, bestlink, linkify, pagetitle, titlepage.
  647. * Smart globlist merging.
  648. * Patch from Thomas Schwinge to switch from --svn to --rcs=svn, etc,
  649. to pave the way for adding other RCS support. This also changes the
  650. setup files, where before they had svn => 1 or svn => 0, now they have
  651. rcs => "svn" or rcs => "".
  652. * Add a debian/NEWS file with upgrade notes.
  653. * Load whatever rcs module is specified, so new ones can be just dropped in
  654. as plugins and work. (Well, in theory.)
  655. * Add some basic docs about writing RCS modules.
  656. * Broke search capability out into a plugin, removed the --hyperestraier
  657. switch.
  658. * Added smiley plugin, nicely controlled and documented by the smileys page.
  659. * Copied in some smileys from Moin Moin.
  660. * Allow links of the form [[some page|page]], with whitespace in the link
  661. text.
  662. * Removed --sanitize and --no-sanitize, replaced with --plugin htmlscrubber
  663. and --disable-plugin htmlscrubber.
  664. * Allow discussion links on pages to be turned off with --no-discussion.
  665. * Add ikiwiki-mass-rebuild script, ripped out of the postinst.
  666. * Add some new config items to the estseek.conf template, which are needed
  667. by hyperestraier 1.2.3.
  668. -- Joey Hess <joeyh@debian.org> Fri, 5 May 2006 17:00:41 -0400
  669. ikiwiki (1.0) unstable; urgency=low
  670. * First official release.
  671. -- Joey Hess <joeyh@debian.org> Tue, 25 Apr 2006 02:08:17 -0400