summaryrefslogtreecommitdiff
path: root/debian/changelog
blob: 0e7a07669dfdb25afb02a227abaae7190a889b38 (plain)
  1. ikiwiki (1.11) UNRELEASED; urgency=low
  2. * Patch from Enrico that
  3. - Adds a tag plugin that allows more easily tagging pages.
  4. The meta plugin can also still be used for that, but the tag plugin
  5. also lists a page's tags at the bottom of the page.
  6. - Allows preprocessor directives to have parameters with no specified
  7. value.
  8. - Fixes preprocessor directive parameter parsing so that
  9. foo=bar baz now means "foo=bar" and a "baz" with no value.
  10. * Run pagetemplate hooks when inlining pages so that inlined pages also
  11. list their tags.
  12. * Make all plugins with pagetemplate hooks check that variables exist
  13. on the template before setting them, for robustness.
  14. * Switch pagetemplate hooks to using named parameters.
  15. * Pass a "destpage" parameter to preprocessor and pagetemplate hooks.
  16. This will be the page that a source page will be part of, which is
  17. different than the source page for inlined pages.
  18. * Audited all plugins to endure they pass page, destpage to htmllink
  19. appropriatly. This means inlining of various plugins will not work
  20. properly, with correct links generated.
  21. -- Joey Hess <joeyh@debian.org> Thu, 27 Jul 2006 17:03:09 -0400
  22. ikiwiki (1.10) unstable; urgency=low
  23. * Run page through any relevant filters when generating a page preview.
  24. * Noticed a bug in the wikitext markup plugin -- it made CamelCase links the
  25. default throughout the wiki, not only on wikitext pages. Decided to call
  26. this a feature, and split the camelcase support out into a separate plugin
  27. that is independant of wikitext.
  28. * Fix CamelCase regexp to not break [[FooBar|BazBar]] WikiLinks.
  29. -- Joey Hess <joeyh@debian.org> Wed, 26 Jul 2006 18:06:35 -0400
  30. ikiwiki (1.9) unstable; urgency=low
  31. * Improve display of parentlinks and page title of toplevel index page.
  32. * Patch from Faidon to use svn --limit when possible for recentchanges,
  33. speeds up recentchanges a lot for wikis with more history.
  34. * Patch from Recai to fix utf8 issues in git backend.
  35. * Add wikitext markup plugin, which supports ".wiki" pages written in the
  36. original wiki syntax, CamelCase links and all.
  37. * Support a w3mmode, which lets w3m run ikiwiki using its local CGI
  38. support, to edit pages etc without a web server.
  39. * Display CGI processing errors if present.
  40. * Fix from Faidon for a XML parser issue that breaks utf-8 for
  41. RecentChanges. Avoid using XML::SAX::PurePerl, which is buggy in this
  42. area, and also way slow.
  43. * Match 'web commit from' in SVN and git, these are web commits too.
  44. (Faidon)
  45. * Consolidated all decode_utf8 in FormBuilder's fields to make the code more
  46. readable and avoid future mistakes. The patch seems to work and for the
  47. first time I have a UTF-8 username ;-) (Faidon)
  48. * Use form->field consistently, not form->param.
  49. * Patch from Recai to allow selection of page type when creating a new page.
  50. Default page type is inherited from the link clicked on to create the new
  51. page.
  52. -- Joey Hess <joeyh@debian.org> Wed, 26 Jul 2006 17:25:30 -0400
  53. ikiwiki (1.8) unstable; urgency=low
  54. * Fix orphans plugin to not count a link to a nonexistant page as a reason
  55. for a page not being an orphan.
  56. * Support pinging services such as Technorati using XML-RPC to notify them
  57. about changes to rss feeds.
  58. * Parse svn log as xml for improved utf8 and security. Note that this makes
  59. ikiwiki depend on XML::Simple. Patch by Faidon Liambotis.
  60. * POSIX::strftime doesn't know about encodings and doesn't return a utf8
  61. flagged string even if the locale causes it to generate utf8 output,
  62. so make sure to let perl know it should be handled as utf8. Also,
  63. the optimised version used for standard time formats won't work if the
  64. user has changed locale, so drop it. Thanks, Faidon Liambotis.
  65. * Fix re-encoding of the comments field to utf8 if a commit fails
  66. due to a conflict. Thanks, Faidon Liambotis.
  67. * Let svn know that commits have utf8 commit messages. Thanks, Faidon
  68. Liambotis.
  69. * Add insane double encode/decode to utf8 around call to markdown.
  70. This works around a truely strange bug, which is apparently a bug in
  71. perl, #376329. Also added a test case for it.
  72. * Improve layout of edit page so formatting help link is always visible w/o
  73. getting in the way of the preview.
  74. * Centralised all calls to HTML::Template and force all the templates
  75. to be read as utf8.
  76. * Support pages with utf8 filenames. Patch by Faidon Liambotis.
  77. * Introduce add_plugins and disable_plugins config options in setup files.
  78. This allows adding or removing plugins w/o overriding the whole list of
  79. default plugins, which makes it easier to upgrade when new default plugins
  80. are added.
  81. * Support htmlize plugins and make mdwn one such plugin, which is enabled by
  82. default (of course!). Based on a patch by Faidon Liambotis.
  83. * Add a html plugin, which can be used to write wikis in raw html,
  84. if you'd ever want to do such a thing. Slightly tricky, since ikiwiki
  85. defaults to not processing .html files, since w/o this plugin they would
  86. be copied unsanitised. With this plugin, it will process and html
  87. sanitise them, like any other page type.
  88. * Rebuilding wrappers is necessary on upgrade to this version.
  89. * Make ikiwiki --setup --refresh rebuild wrappers, so wrapper rebuild
  90. will be automatically done on all upgrades.
  91. * Don't send pings if the wiki is being rebuilt.
  92. * Work around very innefficient behavior in File::Spec::abs2rel. Result
  93. is a savings of 2 pointless fork/execs per link calculation, which
  94. results in ~25% speedup of ikiwiki building its own doc wiki, and
  95. about 35% speedup displaying RecentChanges!
  96. * Make RecentChanges use a table and some CSS, should be much more readable.
  97. No code changes involved.
  98. * Encode & in diffurl in examples, to conform to pedantic rules.
  99. * Speed up RecentChanges by another 40% or so with some memoization.
  100. * Memoize abs2rel, which is still kinda slow, for another 30% speedup
  101. in time to build the doc wiki.
  102. -- Joey Hess <joeyh@debian.org> Tue, 4 Jul 2006 12:46:29 -0400
  103. ikiwiki (1.7) unstable; urgency=low
  104. * Updated logo from Recai with some kerning and alingment tuning.
  105. * Patch from Recai to fix git recentchanges code to work with git 1.4 which
  106. changed some output.
  107. * Copyright update.
  108. -- Joey Hess <joeyh@debian.org> Sun, 18 Jun 2006 23:33:35 -0400
  109. ikiwiki (1.6) unstable; urgency=low
  110. * YA utf-8 patch from Recai, this time to fix previewing a page so that
  111. the text in the input box is re-encoded back to utf-8.
  112. * -CSD does not affect modules, so readfile() was not using the utf-8 input
  113. layer, which led to lots of problems; make it force read files as utf-8.
  114. Closes: #373203
  115. * Note that as a consequence, this version of ikiwiki will actually try to
  116. parse utf8 in source files for the first time, which may expose broken
  117. utf8 in wiki sources that was hidden before. Most common will be
  118. perl warnings like "utf8 "\xE9" does not map to Unicode"
  119. * writefile() likewise needs to use the utf8 output layer.
  120. * Remove the -CSD from ikiwiki's hashbang since it's useless to have it
  121. there.
  122. * Revert some of the decode_utf8 changes in CGI.pm that seem unnecessary
  123. given the readfile fix.
  124. * Add utf-8 testcases for readfile and htmlize.
  125. * Put back the encode_utf8 in the input to markdown; it's really not utf-8
  126. safe.
  127. * More utf-8 fixes from Recai, partly to things I broke above:
  128. - The serious problem is that writefile() saves the content in undecoded
  129. format in CGI, hence all (non-ascii) chars are corrupted permanently.
  130. - Comment field in edit page is not decoded and all the non-ascii chars in
  131. this field are corrupted as the result. We should decode it as we do it
  132. for the content.
  133. - Add 'use encoding "utf8"' to CGI.pm to avoid warnings about wide
  134. character in print.
  135. * New SVG logo from Recai.
  136. -- Joey Hess <joeyh@debian.org> Sun, 18 Jun 2006 19:18:46 -0400
  137. ikiwiki (1.5) unstable; urgency=low
  138. * Add --timeformat config option to allow changing how dates are displayed.
  139. Note that as a side effect, dates will now be displayed using the local
  140. timezone, not as GMT.
  141. * More security review.
  142. * Patch from Dr. Zini to add link() and backlink() to globlists. This allows
  143. for some handy stuff like:
  144. - Using links as a kind of tag; creating blog pages that list all pages
  145. containing a given tag/link or not containing some other tag.
  146. - Subscribing to mail notifications whenever a change is made to a page
  147. that is a backlink of page foo. Ie, "Please notify me of changes in all
  148. pages that link to my home page in the wiki"
  149. - Locking any pages that are linked to from a particular page, so that
  150. lists of locks can be exposed in the wiki.
  151. * Reorganised the doc wiki's todo/* pages, using a link/tag to flag
  152. when a todo item is done, instead of the previous moving it to a different
  153. subdir.
  154. * Allow pagetemplate plugins to override *anything* in the template.
  155. * Add a meta plugin, which allows specifying various metadata about pages,
  156. like license and author. It also allows for inserting html link and meta
  157. tags into html, overriding the title, and adding hidden WikiLinks, which
  158. can be useful when using link-based globbing for page categorisation.
  159. * Remove preprocessor directives from inlined pages.
  160. * Allow simple preprocessor directive values to be specified w/o quotes.
  161. * Add support for using git instead of subversion as the RCS backend,
  162. tremendous thanks to Recai Oktaş for this.
  163. * Doc updates for git.
  164. * Fix absolute url munging in rss generation to support https, ftp, etc urls
  165. not just http urls.
  166. * Patch from Recai Oktaş to improve utf-8 support, it should now use proper
  167. utf-8 for edit and other fields, and for recentchanges. There may still
  168. be utf-8 issues with the preferences page though.
  169. -- Joey Hess <joeyh@debian.org> Sun, 11 Jun 2006 19:56:54 -0400
  170. ikiwiki (1.4) unstable; urgency=low
  171. * Tell HTML::Scrubber to treat "/" as a valid attribute which is its
  172. very strange way of enabling proper XHTML <br /> type tags. Output html
  173. should be always valid again now.
  174. * The page name and parent links has switched from using a <h1> to a styled
  175. <span>, so pages can use <h1> internally instead of needing to use <h2>.
  176. * Updated all of ikiwiki's own wiki pages for that.
  177. * Add pagetemplate hook, which can be used by plugins that want to mess
  178. around with adding new stuff to the page template.
  179. * Remove headercontent; the search plugin now adds the search box to the
  180. header by registering a pagetemplate hook, and other plugins should do
  181. similarly.
  182. * Rebuilding on upgrade to this version is recommended.
  183. * Add a html validity check to the test suite, using the wdg-html-validator,
  184. if available.
  185. * Make the html valid when there is nothing in the actions list.
  186. * Reordered some function call parameters for consistency.
  187. * Enable full utf-8 support for page input and output.
  188. * Add a workaround for markdown, which does not work well with utf-8
  189. strings.
  190. * --getctime had bitrotted (well I only ever used it the once so far..),
  191. fix and make it a bit more flexible
  192. * rcs_getctime is changed, now rather than needing to loop over all pages,
  193. it should just use the rcs to get the ctime of the passed file.
  194. * When inlining a page in another one, links from the inlined page are now
  195. expanded the same as they are when rendering the inlined page as a
  196. standalone page. So rather than being expanded from the POV of the
  197. inlining page, they are expanded from the POV of the inlined page.
  198. For example, a link from blog/foo to "bar" will now link to blog/bar
  199. if it exists. Previously this needed to be a link explicitly to
  200. "blog/bar"; such links will also continue to work.
  201. (This was slightly complex to do as the link still has to be constructed
  202. relative to the inlining page.)
  203. * Make page edit textarea resize to fit browser window.
  204. * Add -refresh option to ikiwiki-mass-rebuild and use that on upgrades that
  205. do not need a full rebuild, in order to update any basewiki pages.
  206. -- Joey Hess <joeyh@debian.org> Sat, 27 May 2006 15:08:49 -0400
  207. ikiwiki (1.3) unstable; urgency=low
  208. * Fix the preinst introduced in the last version. Closes: #367458
  209. -- Joey Hess <joeyh@debian.org> Tue, 16 May 2006 02:43:02 -0500
  210. ikiwiki (1.2) unstable; urgency=low
  211. * Remove dups from the brokenlinks list.
  212. * Add libc6-dev to dependencies, needed to build wrappers.
  213. * Install wikilist in correct location. Closes: #367371
  214. -- Joey Hess <joeyh@debian.org> Mon, 15 May 2006 10:53:49 -0500
  215. ikiwiki (1.1) unstable; urgency=low
  216. * Rename inlinepage to depends, so that it can be used to refer to more
  217. dependency relationships than just inlining. This will require a rebuild
  218. on upgrade to this version.
  219. * Move the rss link, put it in the blogpost form if there is one and at the
  220. top if not. This is both nicer because easier to find, and it cleans up
  221. the code which had used inlinepage as a flag for adding the link later.
  222. * Allow the depends GlobList to be built up from multiple sources (such as
  223. plugins) during a page render.
  224. * Which means that more than one blog is now supported to appear on a
  225. single page. (With some limitations, like only the last one getting an
  226. rss file.)
  227. * Added a plugin system.
  228. * Added a pagecount plugin, enabled by default.
  229. * Support PreProcessorDirectives with no parameters, ie "[[pagecount ]]".
  230. * Fixed/optimised backlinks code, to avoid rebuilding pages to update
  231. backlinks when the backlinks hadn't really changed.
  232. * Moved inline page support, rss generation etc into the inline plugin,
  233. enabled by default.
  234. * Added brokenlinks plugin, not enabled by default, but rather handy.
  235. * Fix several broken links in the doc wiki.
  236. * Smarter behavior when creating a page and a page of the same name (but
  237. different location) already exists.
  238. * Add an orphans plugin for finding pages that nothing links to.
  239. * Removed backlinks page, which it turns out nothing used.
  240. * Split off an IkiWiki.pm out of ikiwiki and have all the other modules use
  241. it, this will allow for adding a unit test suite.
  242. * Add unit tests for several core functions, including globlist_match,
  243. dirname, basename, bestlink, linkify, pagetitle, titlepage.
  244. * Smart globlist merging.
  245. * Patch from Thomas Schwinge to switch from --svn to --rcs=svn, etc,
  246. to pave the way for adding other RCS support. This also changes the
  247. setup files, where before they had svn => 1 or svn => 0, now they have
  248. rcs => "svn" or rcs => "".
  249. * Add a debian/NEWS file with upgrade notes.
  250. * Load whatever rcs module is specified, so new ones can be just dropped in
  251. as plugins and work. (Well, in theory.)
  252. * Add some basic docs about writing RCS modules.
  253. * Broke search capability out into a plugin, removed the --hyperestraier
  254. switch.
  255. * Added smiley plugin, nicely controlled and documented by the smileys page.
  256. * Copied in some smileys from Moin Moin.
  257. * Allow links of the form [[some page|page]], with whitespace in the link
  258. text.
  259. * Removed --sanitize and --no-sanitize, replaced with --plugin htmlscrubber
  260. and --disable-plugin htmlscrubber.
  261. * Allow discussion links on pages to be turned off with --no-discussion.
  262. * Add ikiwiki-mass-rebuild script, ripped out of the postinst.
  263. * Add some new config items to the estseek.conf template, which are needed
  264. by hyperestraier 1.2.3.
  265. -- Joey Hess <joeyh@debian.org> Fri, 5 May 2006 17:00:41 -0400
  266. ikiwiki (1.0) unstable; urgency=low
  267. * First official release.
  268. -- Joey Hess <joeyh@debian.org> Tue, 25 Apr 2006 02:08:17 -0400