summaryrefslogtreecommitdiff
path: root/debian/changelog
blob: 9a280ab6f7c9a00bd2b4a5bf5211a3dfabbe7428 (plain)
  1. ikiwiki (1.32) UNRELEASED; urgency=low
  2. * Add a separate pass to find page links, and only render each page once,
  3. instead of over and over. Typical speedup is ~4x. Max possible speedup:
  4. 8x.
  5. * Add "scan" parameter to hook(), which is used to make the hook be called
  6. during the scanning pass, as well as the render pass. The meta and tag
  7. plugins need to use the new scan parameter, so will any others that modify
  8. %links.
  9. * Now that links are calculated in a separate pass, it can also
  10. precalculate backlinks in one pass, which is O(N^2) instead of the
  11. previous code that was O(N^3). A very nice speedup for wikis with lots
  12. (thousands) of pages.
  13. * Stylish update to the ikiwiki logo, thanks to Recai Oktaş and Selçuk
  14. Erdem.
  15. * Add a default stylesheet entry for the pagecloud.
  16. * Add examples page with some examples of things that can be done using
  17. ikiwiki, like a weblog. The examples can be copied into a user's wiki
  18. for a quick start, without needing to learn everything about how to put
  19. them together.
  20. * Install the source of the examples into /usr/share/doc/ikiwiki/examples.
  21. -- Joey Hess <joeyh@debian.org> Sat, 28 Oct 2006 19:43:53 -0400
  22. ikiwiki (1.31) unstable; urgency=low
  23. * Patch from Pawel Tecza to cp -a the templates in the Makefile.
  24. * Change the rss feed title from the wikiname to the page title, with
  25. an exception for the wiki's toplevel index page, which will still use the
  26. wikiname as the feed title.
  27. Overriding the page title with meta title already overrode the rss feed
  28. tittle.
  29. * Add an img plugin, based on Christian Mock's img plugin, but stripped
  30. down to the bare essentials. Useful for handling large images on websites.
  31. * Sanitize possibly problimatic characters out of the polygen grammar names,
  32. just in case. Should not be exploitable anyway, since it only tries to run
  33. polygen after finding the specified grammar file.
  34. * Add missing dependency on the URI perl module.
  35. * Add basic spam fighting tool for admins: An admin's prefs page now allows
  36. editing a list of banned users.
  37. -- Joey Hess <joeyh@debian.org> Fri, 27 Oct 2006 23:16:33 -0400
  38. ikiwiki (1.30) unstable; urgency=low
  39. * Add no_override parameter to hook().
  40. * Add a shortcut plugin, inspired by Victor Moral's contributed shortcuts
  41. plugin, but featuring a more ikiwiki-ish syntax and with shortcuts that
  42. can be configured using a page in wiki.
  43. * Fix support for --pingurl at the command line.
  44. * Fix a subtle bug in will_render that broke some builds, by only clearing
  45. items from renderedfiles the first time per build.
  46. * Wrap entire technortati ping operation in an eval to catch all possible
  47. failure modes, after I observed a simple ->value crashing ikiwiki when
  48. a ping failed.
  49. -- Joey Hess <joeyh@debian.org> Mon, 16 Oct 2006 15:17:38 -0400
  50. ikiwiki (1.29) unstable; urgency=low
  51. * Patch from Paul Tötterman to use CP in the Makefile.
  52. * Patch from Alec Berryman adding a http_auth config item that allows
  53. using HTTP Authentication instead of ikiwiki's built in authentication.
  54. Useful for eg, large sites with their own previously existing user auth
  55. setup. Closes: #384534
  56. * Change %renderedfiles to store an array of files rendered from a given
  57. source file, to allow tracking of extra rendered files like rss feeds.
  58. * Note that plugins that accessed this variable will need to be updated!
  59. The plugin interface has been increased to version 1.01 for this change.
  60. As few plugins use %renderedfiles I haven't done anything else to ensure
  61. compatability of old plugins.
  62. * Add will_render function to the plugin interface, used to register that a
  63. page renders a destination file, and do some security checks. Previously
  64. but no longer rendered files will be cleaned up.
  65. * Use will_render in the inline and linkmap plugins.
  66. * You will need to rebuild your wiki on upgrade to this version.
  67. * Atom feed support based on a patch by Clint Adams.
  68. * Add feeds=no option to inline preprocessor directive to turn off all types
  69. of feeds.
  70. * $IkiWiki::version now holds the program version, and is accessible to
  71. plugins.
  72. * Make the aggregate plugin emphasize error messages.
  73. * Patch from Recai to limit recentchanges to displaying max 10 files for a
  74. given changeset (to avoid large number of file changes excessively
  75. bloating the page).
  76. -- Joey Hess <joeyh@debian.org> Fri, 13 Oct 2006 23:14:28 -0400
  77. ikiwiki (1.28) unstable; urgency=low
  78. * inline: Add ability to sort by page name, based on a patch from
  79. Benjamin A'Lee.
  80. * Fix a forkbomb in various calls to IPC::Open2, which has a highly
  81. braindead interface. Closes: #389383
  82. * Don't rm -rf ikiwiki on distclean, since a) there's no such file
  83. and b) those poor Mac OSX users and their case insensative files!
  84. * Don't fail syntax check if Text::Typography isn't installed.
  85. Closes: #389406
  86. -- Joey Hess <joeyh@debian.org> Tue, 26 Sep 2006 02:08:17 -0400
  87. ikiwiki (1.27) unstable; urgency=low
  88. * Work on firming up the plugin interface:
  89. - Plugins should not need to load IkiWiki::Render to get commonly
  90. used functions, so moved some functions from there to IkiWiki.
  91. - Picked out the set of functions and variables that most plugins
  92. use, documented them, and made IkiWiki export them by default,
  93. like a proper perl module should.
  94. - Use the other functions at your own risk.
  95. - This is not quite complete, I still have to decide whether to
  96. export some other things.
  97. * Changed all plugins included in ikiwiki to not use "IkiWiki::" when
  98. referring to stuff now exported by the IkiWiki module.
  99. * Add a module version number to IkiWiki, so you can "use IkiWiki '1.00'"
  100. to declare which version of the interface your plugin needs.
  101. * Anyone with a third-party ikiwiki plugin is strongly encouraged
  102. to make like changes to it and avoid use of non-exported symbols from
  103. "IkiWiki::".
  104. * Link debian/changelog and debian/news to NEWS and CHANGELOG.
  105. * Support hyperestradier version 1.4.2, which adds a new required phraseform
  106. setting.
  107. * If an inlined page has a permalink, link the page title to that.
  108. * Patch from Recai to use utf8 when reading the setup file, so that
  109. utf8 wikinames from there will be used properly.
  110. * Patch from Recai to kill utf-8 on the wiki name when generating the
  111. session cookie.
  112. * Change ddate plugin to use the DateTime::Calendar::Discordian perl module.
  113. * Fix a baseurl problem in hyperestradier search results.
  114. * Add a stub local.css to avoid problems with 404's.
  115. * Patch from Recai to fix a wide character warning from the search plugin
  116. during setup if the wikiname contains utf8.
  117. * Yet another fix for those poor case-insensative OS X users.
  118. * pagetemplate hooks are now also called when generating cgi pages.
  119. * Add a favicon plugin, which simply adds a link tag for an icon to each
  120. page (and cgis).
  121. * Patch from James Westby to deal with the case where you're editing a
  122. new page, hit cancel, and need to be redirected to somewhere sane.
  123. * Various documentation improvements by various wiki users.
  124. * Support Text::Markdown from CPAN, which has a different interface from
  125. the original markdown or the one in Debian.
  126. * Version the libcgi-session-perl dependency, some features that need
  127. the new version are used in some cases (sslcookie).
  128. * Numerous tla fixes from Clint.
  129. * Updated ikiwiki.svgz from Recai, includes an icon and is used to generate
  130. a multi-resolution favicon.ico.
  131. * README.Debian: typo Closes: #388110
  132. * chomp trailing newline at the end of templates read in by the template
  133. plugin, to allow use of the template preprocessor directive in
  134. whitespace-sensative situations. Closes: #387073
  135. * Patch from James Westby to make the location of the estseek.cgi script
  136. configurable.
  137. * Add typography (SmartyPants) plugin by Recai.
  138. * Add --render mode, which can be used to preview an edit at the command
  139. line by test rendering a single page.
  140. * Add a googlecalendar plugin. A bit special-purpose, but it shows
  141. one way to to deal with user-supplied content that could cause XSS
  142. issues w/o the htmlscrubber, and won't survive the scrubber.
  143. -- Joey Hess <joeyh@debian.org> Sun, 24 Sep 2006 00:02:21 -0400
  144. ikiwiki (1.26) unstable; urgency=low
  145. * Add a missing -n to tla undo call.
  146. * otl2hmtl can't be safely used with IPC::Open2 since it sometimes
  147. writes before consuming its whole stdin. Avoid this deadlock.
  148. * Fix alt tags for outline checkboxes.
  149. -- Joey Hess <joeyh@debian.org> Fri, 8 Sep 2006 16:24:16 -0400
  150. ikiwiki (1.25) unstable; urgency=low
  151. * Add proper waitpid calls for open2ed processes throughout to avoid
  152. zombies; this hit htmltidy especially badly.
  153. * Drop real uid/gid in the suid wrapper, thus allowing commits to remote
  154. subversion repos and fixing some other issues.
  155. * Add support for tla, contributed by Clint Adams. Closes: #385936
  156. * Add support for mercurial, contributed by Emanuele Aina.
  157. * Include <link rel> tag for RSS feeds, used by some aggregators and
  158. firefox to find the feed.
  159. * Add a linkmap plugin (requires graphviz).
  160. -- Joey Hess <joeyh@debian.org> Fri, 8 Sep 2006 01:54:14 -0400
  161. ikiwiki (1.24) unstable; urgency=low
  162. * Simplify the data structure returned by rcs_recentchanges to avoid
  163. each rcs plugin needing to form complex strings on its own.
  164. * Fix another destpage issue in the inline directive. Closes: #385512
  165. again.
  166. -- Joey Hess <joeyh@debian.org> Sun, 3 Sep 2006 15:46:45 -0400
  167. ikiwiki (1.23) unstable; urgency=low
  168. * Allow inline directives to be nested inside eg, sidebars. Closes: #385512
  169. -- Joey Hess <joeyh@debian.org> Sun, 3 Sep 2006 12:14:45 -0400
  170. ikiwiki (1.22) unstable; urgency=low
  171. * Change how the stylesheet url is determined in the templates: Remove
  172. STYLEURL and add BASEURL to all templates (some already had it). This
  173. new more general variable can be used to link to other things (eg, images)
  174. from the template, as well as stylesheets.
  175. * Fix a bug introduced last version to do with nested inlines.
  176. * Allow preprocessor directives to span multiple lines, both to make
  177. long ones with lots of values easier to write, and to allow for ones with
  178. multi-line quoted values.
  179. * Allow preprocessor directives to contain python-like triple-quoted
  180. text blocks, for easy nesting of quotes inside.
  181. * Add a template plugin.
  182. * Make pagespec merge code smarter about merging duplicate pagespecs.
  183. * Patch from Jordà Polo to make Setup::Standard support hashes in config
  184. files.
  185. * Change order of linkify and preprocess; first preprocess and then linkify.
  186. This allows passing a wikilink inside a parameter to a preprocessor
  187. directive without it being expanded to html, and leaking out of the
  188. parameter, which had required some non-obvious use of triple-quoting
  189. to avoid. Note that any preprocessor plugins that output something
  190. that looks like a wikilink will now have it treated as such; AFAIK
  191. this doesn't change any behavior though except for the template plugin.
  192. * Enable preprocessor directives when previewing an edit.
  193. * Make all pages pull in a local.css style sheet, if present. This won't
  194. be included in ikiwiki, but can be created to make local styling changes
  195. w/o needing to merge in every new change to the distributed style.css.
  196. * Use DESTDIR and not PREFIX to specify installation prefix for packaging.
  197. * Support running "perl Makefile.PL PREFIX=foo" to build ikiwiki to run
  198. from a different directory.
  199. * Generalised preprocesser loop protection code.
  200. * Patch from James Westby to allow a description to be set for rss feeds.
  201. * Patch from James Westby to add a template for the search form.
  202. * Added a ddate plugin.
  203. * Patch from James Westby to add a --sslcookie switch, which forces
  204. cookies to only be sent over ssl connections to avoid interception.
  205. * Fix preferences page on anonok wikis; still need to sign in to get
  206. to the preferences page.
  207. * Add toc (table of contents) plugin.
  208. * Change htmlize, format, and sanitize hooks to use named parameters.
  209. * Patch from James Westby to add an actions option to inline; this
  210. adds Edit and Discussion links at the end of blog entries.
  211. * Due to some css changes, you'll want to rebuild your wiki on upgrade
  212. to this version. Will be handled automatically by the deb.
  213. * Add processed date to aggregate preprocessor directive status output.
  214. -- Joey Hess <joeyh@debian.org> Fri, 1 Sep 2006 22:03:34 -0400
  215. ikiwiki (1.21) unstable; urgency=low
  216. * Add a tail fin^W^Wsidebar plugin by Tuomo Valkonen.
  217. * If a page links to itself, mark up the link text in a span with
  218. class="selflink" so that it can be styled. I don't have a useful style
  219. defined for that though.
  220. * Call filter hooks on inlined page content.
  221. * Support inlining pages raw, rather than creating a blog.
  222. * Clean up yes/no parameter parsing in inline plugin.
  223. * Implemented better cycle detection in the inline plugin; nested inlines
  224. will now work.
  225. * Add a map plugin contributed by Alessandro Dotti Contra.
  226. * Add otl format plugin, which handles files as created by vimoutliner.
  227. * Fix ikiwiki-mass-rebuild to work in the way the postinst uses it.
  228. * Add first draft at a Restructured Text (rst) plugin, by Sergio
  229. Talens-Oliag. Note that this has many known issues -- see the caveats on
  230. the plugin's page.
  231. * Credit everyone who wrote a plugin on the plugins' wiki pages.
  232. * Fix utf-8 in blog post form.
  233. -- Joey Hess <joeyh@debian.org> Sun, 20 Aug 2006 16:42:54 -0400
  234. ikiwiki (1.20) unstable; urgency=low
  235. * Relicense the templates and basewiki under the 2-clause BSD license.
  236. Since these can easily become part of other people's websites, they
  237. should be under as permissive a license as possible.
  238. * Add --syslog config option, to log to the syslog.
  239. * Catch failing IPC::Open2 in tidy plugin and retry in case this is a
  240. transient failure to fork (which I've seen happen in the wild).
  241. * Fix a bug in the aggregator introduced last version that caused all
  242. aggregator state to be lost during a non-aggregating build.
  243. -- Joey Hess <joeyh@debian.org> Thu, 17 Aug 2006 19:05:56 -0400
  244. ikiwiki (1.19) unstable; urgency=low
  245. * Fix several related bugs in page type determination during online editing.
  246. * Add some locking to prevent 2 aggregators from running at once.
  247. * Fix an infinite loop in the aggregator when finding a unique filename.
  248. -- Joey Hess <joeyh@debian.org> Wed, 16 Aug 2006 13:46:25 -0400
  249. ikiwiki (1.18) unstable; urgency=low
  250. * The last release accidentially installed ikiwiki as ikiwiki.pl, now fixed.
  251. * Add --version.
  252. * Man page format fixups.
  253. * If the meta plugin overides the page title, set a title_overridden
  254. variable in the template to true. This allows doing things with the
  255. templates conditional on the title being overriden.
  256. * Add a %pagecase which maps lower-case page names to the actual case
  257. used in the filename. Use this in bestlinks calculation instead of
  258. forcing the link to lowercase.
  259. * Also use %pagecase in various other places that want to check if a page
  260. with a given name exists.
  261. * This means that links to pages with mixed case names will now work,
  262. even if the link is in some other case mixture, and mixed case pages
  263. should be fully supported throughout ikiwiki.
  264. * Recommend rebuilding wikis on upgrade to this version.
  265. -- Joey Hess <joeyh@debian.org> Sat, 12 Aug 2006 22:10:48 -0400
  266. ikiwiki (1.17) unstable; urgency=low
  267. * Disable tidy generator tag.
  268. * Move tidy back to sanitize hook, found out how to only show body.
  269. * Turn off tidy indentation too.
  270. * Turn on HTML::Template loop_context_vars; not actually used in stock
  271. templates but can be useful for things like making comma-delimited lists
  272. of tags or what have you.
  273. * Remove <br> from end of aggregate preprocessor directive output.
  274. * Ship ikiwiki executable as ikiwiki.pl in source to avoid issues on
  275. case-sensative filesystems like OSX.
  276. * Improve markdown loading. First, try to load it as a proper perl module,
  277. in case it was installed as one. Then fall back to trying
  278. /usr/bin/markdown.
  279. * Document in install page how to install markdown, since it has no
  280. installation procedure in the upstream tarball.
  281. * Set die_on_bad_params => 0 for all templates, to allow users to modify
  282. them without annoyances.
  283. * Suck in the page content when generating an inline archive page, to work
  284. around the meta plugin's lack of caching of title metadata across runs.
  285. -- Joey Hess <joeyh@debian.org> Sat, 12 Aug 2006 12:52:13 -0400
  286. ikiwiki (1.16) unstable; urgency=low
  287. * Try to handle relative links in aggregated feeds. However,
  288. the current support is a crude hack due to limitations of XML::Feed:
  289. xml:base is not supported, neither is Content-Location. And of course,
  290. relative links in RSS feeds are ill-undefined..
  291. * Make aggregator save permalinks and author name to pages as metadata.
  292. * Add permalink and author support to meta plugin, affecting RSS feeds
  293. and blog pages.
  294. * Various CSS and formatting changes.
  295. * Encode link and guid urls in rss feeds to avoid illegal utf8 slipping in.
  296. * Add xhtml files to the default prune regexp.
  297. * Also generate rel=bookmark links for permalinks.
  298. * Fix the htmltidy plugin, which wasn't working due my breaking it when
  299. I added it..
  300. * Don't run tidy with -xml as that fails if the input is not well-formed.
  301. Run it with -asxhtml instead, so it will output well-formed xhtml no
  302. matter what the input.
  303. * Disable tidy warnings too.
  304. * Add a new format hook, and make tidy use it, since tidy can really only
  305. operate on and output complete html documents, not the body chunks
  306. that sanitise gets.
  307. * Fix dates in rss feeds if running localised, so they're still rfc 822.
  308. -- Joey Hess <joeyh@debian.org> Fri, 4 Aug 2006 20:48:36 -0400
  309. ikiwiki (1.15) unstable; urgency=low
  310. * Remove CDPATH and other env vars perl taint checking doesn't like.
  311. Closes: #381279
  312. * Added created_before and created_after PageSpec limits.
  313. -- Joey Hess <joeyh@debian.org> Thu, 3 Aug 2006 13:00:57 -0400
  314. ikiwiki (1.14) unstable; urgency=low
  315. * Memoize pagespec translation, this speeds up a build of the ikiwiki tree
  316. by 10% or so.
  317. * Fix stupid bug in date matching, patch from Roland Mas. Closes: #381132
  318. * Added many unit tests for pagespec_match.
  319. -- Joey Hess <joeyh@debian.org> Wed, 2 Aug 2006 11:34:06 -0400
  320. ikiwiki (1.13) unstable; urgency=low
  321. * ikiwiki can now download and aggregate feeds with its new aggregate
  322. plugin, so it's possible to implement a Planet using ikiwiki!
  323. * Add a run_hooks function for the common task of running all hooks of a
  324. given type.
  325. * Add a savestate hook.
  326. * Don't put blog post forms on pages if there's no cgiurl set.
  327. * --setup --refresh no longer rebuilds wrappers. Use --setup --refresh
  328. --wrappers to do that.
  329. * Add %IkiWiki::forcerebuild to provide a way for plugins like aggregate
  330. to update pages that haven't changed on disk.
  331. * Change meta tags to use html entity-escaped text for values, so that
  332. quotes and such can be represented in title tags.
  333. * Depend and build-depend on HTML::Parser for HTML::Entities which is used
  334. for the above.
  335. * Make --rebuild also cause --aggregate to re-download and write aggregated
  336. pages.
  337. * Avoid outputting duplicate meta info.
  338. * Include title metadata on aggregated posts for capitalised and un-munged
  339. titles.
  340. * Title metadata of inlined pages now shows up in blogs and rss feeds.
  341. * Fix issue with unicode filenames and updating the hyper estradier search
  342. index. (Aka Please Please Please, let that be the last one.)
  343. * Patch from Roland Mas to support an rss=no parameter to inline directives.
  344. Closes: #380743
  345. * Renamed GlobLists to PageSpecs.
  346. * PageSpecs can now include nested parens, "and", and "or". This remains
  347. backwards compatible to the old GlobList format. It's implemented by
  348. treating the GlobList as a very limited microlanguage that is transformed
  349. to perl code that does the matching.
  350. * The old GlobList format is deprecated, and I encourage users to switch to
  351. using the new PageSpec format. Compatability with the old format will be
  352. removed at some point, possibly by 2.0.
  353. * Wiki rebuild needed on upgrade to this version due to PageSpec change.
  354. * Add support for creation_month and creation_year to PageSpec.
  355. Closes: #380680
  356. * Changes to index file encoding.
  357. -- Joey Hess <joeyh@debian.org> Tue, 1 Aug 2006 21:21:19 -0400
  358. ikiwiki (1.12) unstable; urgency=low
  359. "Viva l'Italia!"
  360. * New pagestats plugin from Enrico, which can generate a table counting
  361. the backlinks for each page, or a del.icio.us style cloud.
  362. * Build-depend on libtext-wikiformat-perl, so that the syntax check of
  363. the wikiformat plugin works. Thanks, Emanuele Aina.
  364. * Patch from Alessandro Dotti Contra to clean up backlinks and navbar
  365. display, running them through pagetitle. This removes ugly underscores and
  366. other gunk from the display, much nicer. You may want to rebuild your wiki
  367. when upgrading to get the cleanup globally.
  368. * Polygen plugin from Enrico.
  369. * htmltidy plugin from Faidon.
  370. * Locale patch from Faidon:
  371. - Adds a locale setting to setup files.
  372. - Proper local time, if the locale configuration option is used.
  373. - Support for UTF-8 (or ISO-8859-X) filenames in SVN. Before this patch,
  374. commiting (or even rcs_updating) on repositories with UTF-8 filenames was
  375. impossible.
  376. * Add getopt hook type, this allows plugins to add new command-line options.
  377. * Add --tagbase option to tag plugin.
  378. * Add exclude option in setup files, works same as --exclude.
  379. * Put categories in rss feeds for tagged items.
  380. * Allow preprocessor directives to be expanded in inlined blog pages.
  381. However, to avoid inlining loops etc, don't expand inline directives in
  382. inlined pages.
  383. * fortune plugin (trivial)
  384. * Tag plugins according to type.
  385. -- Joey Hess <joeyh@debian.org> Sat, 29 Jul 2006 17:12:56 -0400
  386. ikiwiki (1.11) unstable; urgency=low
  387. * Patch from Enrico that
  388. - Adds a tag plugin that allows more easily tagging pages.
  389. The meta plugin can also still be used for that, but the tag plugin
  390. also lists a page's tags at the bottom of the page.
  391. - Allows preprocessor directives to have parameters with no specified
  392. value.
  393. - Fixes preprocessor directive parameter parsing so that
  394. foo=bar baz now means "foo=bar" and a "baz" with no value.
  395. * Run pagetemplate hooks when inlining pages so that inlined pages also
  396. list their tags.
  397. * Make all plugins with pagetemplate hooks check that variables exist
  398. on the template before setting them, for robustness.
  399. * Switch pagetemplate hooks to using named parameters.
  400. * Pass a destpage parameter to preprocessor and pagetemplate hooks.
  401. This will be the page that a source page will be part of, which is
  402. different than the source page for inlined pages.
  403. * Audited all plugins to endure they pass (page, destpage) to htmllink
  404. appropriatly. This means inlining of various plugins will not work
  405. properly, with correct links generated.
  406. -- Joey Hess <joeyh@debian.org> Thu, 27 Jul 2006 20:51:23 -0400
  407. ikiwiki (1.10) unstable; urgency=low
  408. * Run page through any relevant filters when generating a page preview.
  409. * Noticed a bug in the wikitext markup plugin -- it made CamelCase links the
  410. default throughout the wiki, not only on wikitext pages. Decided to call
  411. this a feature, and split the camelcase support out into a separate plugin
  412. that is independant of wikitext.
  413. * Fix CamelCase regexp to not break [[FooBar|BazBar]] WikiLinks.
  414. -- Joey Hess <joeyh@debian.org> Wed, 26 Jul 2006 18:06:35 -0400
  415. ikiwiki (1.9) unstable; urgency=low
  416. * Improve display of parentlinks and page title of toplevel index page.
  417. * Patch from Faidon to use svn --limit when possible for recentchanges,
  418. speeds up recentchanges a lot for wikis with more history.
  419. * Patch from Recai to fix utf8 issues in git backend.
  420. * Add wikitext markup plugin, which supports ".wiki" pages written in the
  421. original wiki syntax, CamelCase links and all.
  422. * Support a w3mmode, which lets w3m run ikiwiki using its local CGI
  423. support, to edit pages etc without a web server.
  424. * Display CGI processing errors if present.
  425. * Fix from Faidon for a XML parser issue that breaks utf-8 for
  426. RecentChanges. Avoid using XML::SAX::PurePerl, which is buggy in this
  427. area, and also way slow.
  428. * Match 'web commit from' in SVN and git, these are web commits too.
  429. (Faidon)
  430. * Consolidated all decode_utf8 in FormBuilder's fields to make the code more
  431. readable and avoid future mistakes. The patch seems to work and for the
  432. first time I have a UTF-8 username ;-) (Faidon)
  433. * Use form->field consistently, not form->param.
  434. * Patch from Recai to allow selection of page type when creating a new page.
  435. Default page type is inherited from the link clicked on to create the new
  436. page.
  437. -- Joey Hess <joeyh@debian.org> Wed, 26 Jul 2006 17:25:30 -0400
  438. ikiwiki (1.8) unstable; urgency=low
  439. * Fix orphans plugin to not count a link to a nonexistant page as a reason
  440. for a page not being an orphan.
  441. * Support pinging services such as Technorati using XML-RPC to notify them
  442. about changes to rss feeds.
  443. * Parse svn log as xml for improved utf8 and security. Note that this makes
  444. ikiwiki depend on XML::Simple. Patch by Faidon Liambotis.
  445. * POSIX::strftime doesn't know about encodings and doesn't return a utf8
  446. flagged string even if the locale causes it to generate utf8 output,
  447. so make sure to let perl know it should be handled as utf8. Also,
  448. the optimised version used for standard time formats won't work if the
  449. user has changed locale, so drop it. Thanks, Faidon Liambotis.
  450. * Fix re-encoding of the comments field to utf8 if a commit fails
  451. due to a conflict. Thanks, Faidon Liambotis.
  452. * Let svn know that commits have utf8 commit messages. Thanks, Faidon
  453. Liambotis.
  454. * Add insane double encode/decode to utf8 around call to markdown.
  455. This works around a truely strange bug, which is apparently a bug in
  456. perl, #376329. Also added a test case for it.
  457. * Improve layout of edit page so formatting help link is always visible w/o
  458. getting in the way of the preview.
  459. * Centralised all calls to HTML::Template and force all the templates
  460. to be read as utf8.
  461. * Support pages with utf8 filenames. Patch by Faidon Liambotis.
  462. * Introduce add_plugins and disable_plugins config options in setup files.
  463. This allows adding or removing plugins w/o overriding the whole list of
  464. default plugins, which makes it easier to upgrade when new default plugins
  465. are added.
  466. * Support htmlize plugins and make mdwn one such plugin, which is enabled by
  467. default (of course!). Based on a patch by Faidon Liambotis.
  468. * Add a html plugin, which can be used to write wikis in raw html,
  469. if you'd ever want to do such a thing. Slightly tricky, since ikiwiki
  470. defaults to not processing .html files, since w/o this plugin they would
  471. be copied unsanitised. With this plugin, it will process and html
  472. sanitise them, like any other page type.
  473. * Rebuilding wrappers is necessary on upgrade to this version.
  474. * Make ikiwiki --setup --refresh rebuild wrappers, so wrapper rebuild
  475. will be automatically done on all upgrades.
  476. * Don't send pings if the wiki is being rebuilt.
  477. * Work around very innefficient behavior in File::Spec::abs2rel. Result
  478. is a savings of 2 pointless fork/execs per link calculation, which
  479. results in ~25% speedup of ikiwiki building its own doc wiki, and
  480. about 35% speedup displaying RecentChanges!
  481. * Make RecentChanges use a table and some CSS, should be much more readable.
  482. No code changes involved.
  483. * Encode & in diffurl in examples, to conform to pedantic rules.
  484. * Speed up RecentChanges by another 40% or so with some memoization.
  485. * Memoize abs2rel, which is still kinda slow, for another 30% speedup
  486. in time to build the doc wiki.
  487. -- Joey Hess <joeyh@debian.org> Tue, 4 Jul 2006 12:46:29 -0400
  488. ikiwiki (1.7) unstable; urgency=low
  489. * Updated logo from Recai with some kerning and alingment tuning.
  490. * Patch from Recai to fix git recentchanges code to work with git 1.4 which
  491. changed some output.
  492. * Copyright update.
  493. -- Joey Hess <joeyh@debian.org> Sun, 18 Jun 2006 23:33:35 -0400
  494. ikiwiki (1.6) unstable; urgency=low
  495. * YA utf-8 patch from Recai, this time to fix previewing a page so that
  496. the text in the input box is re-encoded back to utf-8.
  497. * -CSD does not affect modules, so readfile() was not using the utf-8 input
  498. layer, which led to lots of problems; make it force read files as utf-8.
  499. Closes: #373203
  500. * Note that as a consequence, this version of ikiwiki will actually try to
  501. parse utf8 in source files for the first time, which may expose broken
  502. utf8 in wiki sources that was hidden before. Most common will be
  503. perl warnings like "utf8 "\xE9" does not map to Unicode"
  504. * writefile() likewise needs to use the utf8 output layer.
  505. * Remove the -CSD from ikiwiki's hashbang since it's useless to have it
  506. there.
  507. * Revert some of the decode_utf8 changes in CGI.pm that seem unnecessary
  508. given the readfile fix.
  509. * Add utf-8 testcases for readfile and htmlize.
  510. * Put back the encode_utf8 in the input to markdown; it's really not utf-8
  511. safe.
  512. * More utf-8 fixes from Recai, partly to things I broke above:
  513. - The serious problem is that writefile() saves the content in undecoded
  514. format in CGI, hence all (non-ascii) chars are corrupted permanently.
  515. - Comment field in edit page is not decoded and all the non-ascii chars in
  516. this field are corrupted as the result. We should decode it as we do it
  517. for the content.
  518. - Add 'use encoding "utf8"' to CGI.pm to avoid warnings about wide
  519. character in print.
  520. * New SVG logo from Recai.
  521. -- Joey Hess <joeyh@debian.org> Sun, 18 Jun 2006 19:18:46 -0400
  522. ikiwiki (1.5) unstable; urgency=low
  523. * Add --timeformat config option to allow changing how dates are displayed.
  524. Note that as a side effect, dates will now be displayed using the local
  525. timezone, not as GMT.
  526. * More security review.
  527. * Patch from Dr. Zini to add link() and backlink() to globlists. This allows
  528. for some handy stuff like:
  529. - Using links as a kind of tag; creating blog pages that list all pages
  530. containing a given tag/link or not containing some other tag.
  531. - Subscribing to mail notifications whenever a change is made to a page
  532. that is a backlink of page foo. Ie, "Please notify me of changes in all
  533. pages that link to my home page in the wiki"
  534. - Locking any pages that are linked to from a particular page, so that
  535. lists of locks can be exposed in the wiki.
  536. * Reorganised the doc wiki's todo/* pages, using a link/tag to flag
  537. when a todo item is done, instead of the previous moving it to a different
  538. subdir.
  539. * Allow pagetemplate plugins to override *anything* in the template.
  540. * Add a meta plugin, which allows specifying various metadata about pages,
  541. like license and author. It also allows for inserting html link and meta
  542. tags into html, overriding the title, and adding hidden WikiLinks, which
  543. can be useful when using link-based globbing for page categorisation.
  544. * Remove preprocessor directives from inlined pages.
  545. * Allow simple preprocessor directive values to be specified w/o quotes.
  546. * Add support for using git instead of subversion as the RCS backend,
  547. tremendous thanks to Recai Oktaş for this.
  548. * Doc updates for git.
  549. * Fix absolute url munging in rss generation to support https, ftp, etc urls
  550. not just http urls.
  551. * Patch from Recai Oktaş to improve utf-8 support, it should now use proper
  552. utf-8 for edit and other fields, and for recentchanges. There may still
  553. be utf-8 issues with the preferences page though.
  554. -- Joey Hess <joeyh@debian.org> Sun, 11 Jun 2006 19:56:54 -0400
  555. ikiwiki (1.4) unstable; urgency=low
  556. * Tell HTML::Scrubber to treat "/" as a valid attribute which is its
  557. very strange way of enabling proper XHTML <br /> type tags. Output html
  558. should be always valid again now.
  559. * The page name and parent links has switched from using a <h1> to a styled
  560. <span>, so pages can use <h1> internally instead of needing to use <h2>.
  561. * Updated all of ikiwiki's own wiki pages for that.
  562. * Add pagetemplate hook, which can be used by plugins that want to mess
  563. around with adding new stuff to the page template.
  564. * Remove headercontent; the search plugin now adds the search box to the
  565. header by registering a pagetemplate hook, and other plugins should do
  566. similarly.
  567. * Rebuilding on upgrade to this version is recommended.
  568. * Add a html validity check to the test suite, using the wdg-html-validator,
  569. if available.
  570. * Make the html valid when there is nothing in the actions list.
  571. * Reordered some function call parameters for consistency.
  572. * Enable full utf-8 support for page input and output.
  573. * Add a workaround for markdown, which does not work well with utf-8
  574. strings.
  575. * --getctime had bitrotted (well I only ever used it the once so far..),
  576. fix and make it a bit more flexible
  577. * rcs_getctime is changed, now rather than needing to loop over all pages,
  578. it should just use the rcs to get the ctime of the passed file.
  579. * When inlining a page in another one, links from the inlined page are now
  580. expanded the same as they are when rendering the inlined page as a
  581. standalone page. So rather than being expanded from the POV of the
  582. inlining page, they are expanded from the POV of the inlined page.
  583. For example, a link from blog/foo to "bar" will now link to blog/bar
  584. if it exists. Previously this needed to be a link explicitly to
  585. "blog/bar"; such links will also continue to work.
  586. (This was slightly complex to do as the link still has to be constructed
  587. relative to the inlining page.)
  588. * Make page edit textarea resize to fit browser window.
  589. * Add -refresh option to ikiwiki-mass-rebuild and use that on upgrades that
  590. do not need a full rebuild, in order to update any basewiki pages.
  591. -- Joey Hess <joeyh@debian.org> Sat, 27 May 2006 15:08:49 -0400
  592. ikiwiki (1.3) unstable; urgency=low
  593. * Fix the preinst introduced in the last version. Closes: #367458
  594. -- Joey Hess <joeyh@debian.org> Tue, 16 May 2006 02:43:02 -0500
  595. ikiwiki (1.2) unstable; urgency=low
  596. * Remove dups from the brokenlinks list.
  597. * Add libc6-dev to dependencies, needed to build wrappers.
  598. * Install wikilist in correct location. Closes: #367371
  599. -- Joey Hess <joeyh@debian.org> Mon, 15 May 2006 10:53:49 -0500
  600. ikiwiki (1.1) unstable; urgency=low
  601. * Rename inlinepage to depends, so that it can be used to refer to more
  602. dependency relationships than just inlining. This will require a rebuild
  603. on upgrade to this version.
  604. * Move the rss link, put it in the blogpost form if there is one and at the
  605. top if not. This is both nicer because easier to find, and it cleans up
  606. the code which had used inlinepage as a flag for adding the link later.
  607. * Allow the depends GlobList to be built up from multiple sources (such as
  608. plugins) during a page render.
  609. * Which means that more than one blog is now supported to appear on a
  610. single page. (With some limitations, like only the last one getting an
  611. rss file.)
  612. * Added a plugin system.
  613. * Added a pagecount plugin, enabled by default.
  614. * Support PreProcessorDirectives with no parameters, ie "[[pagecount ]]".
  615. * Fixed/optimised backlinks code, to avoid rebuilding pages to update
  616. backlinks when the backlinks hadn't really changed.
  617. * Moved inline page support, rss generation etc into the inline plugin,
  618. enabled by default.
  619. * Added brokenlinks plugin, not enabled by default, but rather handy.
  620. * Fix several broken links in the doc wiki.
  621. * Smarter behavior when creating a page and a page of the same name (but
  622. different location) already exists.
  623. * Add an orphans plugin for finding pages that nothing links to.
  624. * Removed backlinks page, which it turns out nothing used.
  625. * Split off an IkiWiki.pm out of ikiwiki and have all the other modules use
  626. it, this will allow for adding a unit test suite.
  627. * Add unit tests for several core functions, including globlist_match,
  628. dirname, basename, bestlink, linkify, pagetitle, titlepage.
  629. * Smart globlist merging.
  630. * Patch from Thomas Schwinge to switch from --svn to --rcs=svn, etc,
  631. to pave the way for adding other RCS support. This also changes the
  632. setup files, where before they had svn => 1 or svn => 0, now they have
  633. rcs => "svn" or rcs => "".
  634. * Add a debian/NEWS file with upgrade notes.
  635. * Load whatever rcs module is specified, so new ones can be just dropped in
  636. as plugins and work. (Well, in theory.)
  637. * Add some basic docs about writing RCS modules.
  638. * Broke search capability out into a plugin, removed the --hyperestraier
  639. switch.
  640. * Added smiley plugin, nicely controlled and documented by the smileys page.
  641. * Copied in some smileys from Moin Moin.
  642. * Allow links of the form [[some page|page]], with whitespace in the link
  643. text.
  644. * Removed --sanitize and --no-sanitize, replaced with --plugin htmlscrubber
  645. and --disable-plugin htmlscrubber.
  646. * Allow discussion links on pages to be turned off with --no-discussion.
  647. * Add ikiwiki-mass-rebuild script, ripped out of the postinst.
  648. * Add some new config items to the estseek.conf template, which are needed
  649. by hyperestraier 1.2.3.
  650. -- Joey Hess <joeyh@debian.org> Fri, 5 May 2006 17:00:41 -0400
  651. ikiwiki (1.0) unstable; urgency=low
  652. * First official release.
  653. -- Joey Hess <joeyh@debian.org> Tue, 25 Apr 2006 02:08:17 -0400