- ikiwiki (1.6) UNRELEASED; urgency=low
- * YA utf-8 patch from Recai, this time to fix previewing a page so that
- the text in the input box is re-encoded back to utf-8.
- * -CSD does not affect modules, so readfile() was not using the utf-8 input
- layer, which led to lots of problems; make it force read files as utf-8.
- Closes: #373203
- * Note that as a consequence, this version of ikiwiki will actually try to
- parse utf8 in source files for the first time, which may expose broken
- utf8 in wiki sources that was hidden before. Most common will be
- perl warnings like "utf8 "\xE9" does not map to Unicode"
- * writefile() likewise needs to use the utf8 output layer.
- * Remove the -CSD from ikiwiki's hashbang since it's useless to have it
- there.
- * Revert some of the decode_utf8 changes in CGI.pm that seem unnecessary
- given the readfile fix.
- * Add utf-8 testcases for readfile and htmlize.
- * Put back the encode_utf8 in the input to markdown; it's really not utf-8
- safe.
- * More utf-8 fixes from Recai, partly to things I broke above:
- - The serious problem is that writefile() saves the content in undecoded
- format in CGI, hence all (non-ascii) chars are corrupted permanently.
- - Comment field in edit page is not decoded and all the non-ascii chars in
- this field are corrupted as the result. We should decode it as we do it
- for the content.
- - Add 'use encoding "utf8"' to CGI.pm to avoid warnings about wide
- character in print.
- * New SVG logo from Recai.
- -- Joey Hess <joeyh@debian.org> Sun, 18 Jun 2006 17:18:23 -0400
- ikiwiki (1.5) unstable; urgency=low
- * Add --timeformat config option to allow changing how dates are displayed.
- Note that as a side effect, dates will now be displayed using the local
- timezone, not as GMT.
- * More security review.
- * Patch from Dr. Zini to add link() and backlink() to globlists. This allows
- for some handy stuff like:
- - Using links as a kind of tag; creating blog pages that list all pages
- containing a given tag/link or not containing some other tag.
- - Subscribing to mail notifications whenever a change is made to a page
- that is a backlink of page foo. Ie, "Please notify me of changes in all
- pages that link to my home page in the wiki"
- - Locking any pages that are linked to from a particular page, so that
- lists of locks can be exposed in the wiki.
- * Reorganised the doc wiki's todo/* pages, using a link/tag to flag
- when a todo item is done, instead of the previous moving it to a different
- subdir.
- * Allow pagetemplate plugins to override *anything* in the template.
- * Add a meta plugin, which allows specifying various metadata about pages,
- like license and author. It also allows for inserting html link and meta
- tags into html, overriding the title, and adding hidden WikiLinks, which
- can be useful when using link-based globbing for page categorisation.
- * Remove preprocessor directives from inlined pages.
- * Allow simple preprocessor directive values to be specified w/o quotes.
- * Add support for using git instead of subversion as the RCS backend,
- tremendous thanks to Recai Oktaş for this.
- * Doc updates for git.
- * Fix absolute url munging in rss generation to support https, ftp, etc urls
- not just http urls.
- * Patch from Recai Oktaş to improve utf-8 support, it should now use proper
- utf-8 for edit and other fields, and for recentchanges. There may still
- be utf-8 issues with the preferences page though.
- -- Joey Hess <joeyh@debian.org> Sun, 11 Jun 2006 19:56:54 -0400
- ikiwiki (1.4) unstable; urgency=low
- * Tell HTML::Scrubber to treat "/" as a valid attribute which is its
- very strange way of enabling proper XHTML <br /> type tags. Output html
- should be always valid again now.
- * The page name and parent links has switched from using a <h1> to a styled
- <span>, so pages can use <h1> internally instead of needing to use <h2>.
- * Updated all of ikiwiki's own wiki pages for that.
- * Add pagetemplate hook, which can be used by plugins that want to mess
- around with adding new stuff to the page template.
- * Remove headercontent; the search plugin now adds the search box to the
- header by registering a pagetemplate hook, and other plugins should do
- similarly.
- * Rebuilding on upgrade to this version is recommended.
- * Add a html validity check to the test suite, using the wdg-html-validator,
- if available.
- * Make the html valid when there is nothing in the actions list.
- * Reordered some function call parameters for consistency.
- * Enable full utf-8 support for page input and output.
- * Add a workaround for markdown, which does not work well with utf-8
- strings.
- * --getctime had bitrotted (well I only ever used it the once so far..),
- fix and make it a bit more flexible
- * rcs_getctime is changed, now rather than needing to loop over all pages,
- it should just use the rcs to get the ctime of the passed file.
- * When inlining a page in another one, links from the inlined page are now
- expanded the same as they are when rendering the inlined page as a
- standalone page. So rather than being expanded from the POV of the
- inlining page, they are expanded from the POV of the inlined page.
- For example, a link from blog/foo to "bar" will now link to blog/bar
- if it exists. Previously this needed to be a link explicitly to
- "blog/bar"; such links will also continue to work.
- (This was slightly complex to do as the link still has to be constructed
- relative to the inlining page.)
- * Make page edit textarea resize to fit browser window.
- * Add -refresh option to ikiwiki-mass-rebuild and use that on upgrades that
- do not need a full rebuild, in order to update any basewiki pages.
- -- Joey Hess <joeyh@debian.org> Sat, 27 May 2006 15:08:49 -0400
- ikiwiki (1.3) unstable; urgency=low
- * Fix the preinst introduced in the last version. Closes: #367458
- -- Joey Hess <joeyh@debian.org> Tue, 16 May 2006 02:43:02 -0500
- ikiwiki (1.2) unstable; urgency=low
- * Remove dups from the brokenlinks list.
- * Add libc6-dev to dependencies, needed to build wrappers.
- * Install wikilist in correct location. Closes: #367371
- -- Joey Hess <joeyh@debian.org> Mon, 15 May 2006 10:53:49 -0500
- ikiwiki (1.1) unstable; urgency=low
- * Rename inlinepage to depends, so that it can be used to refer to more
- dependency relationships than just inlining. This will require a rebuild
- on upgrade to this version.
- * Move the rss link, put it in the blogpost form if there is one and at the
- top if not. This is both nicer because easier to find, and it cleans up
- the code which had used inlinepage as a flag for adding the link later.
- * Allow the depends GlobList to be built up from multiple sources (such as
- plugins) during a page render.
- * Which means that more than one blog is now supported to appear on a
- single page. (With some limitations, like only the last one getting an
- rss file.)
- * Added a plugin system.
- * Added a pagecount plugin, enabled by default.
- * Support PreProcessorDirectives with no parameters, ie "[[pagecount ]]".
- * Fixed/optimised backlinks code, to avoid rebuilding pages to update
- backlinks when the backlinks hadn't really changed.
- * Moved inline page support, rss generation etc into the inline plugin,
- enabled by default.
- * Added brokenlinks plugin, not enabled by default, but rather handy.
- * Fix several broken links in the doc wiki.
- * Smarter behavior when creating a page and a page of the same name (but
- different location) already exists.
- * Add an orphans plugin for finding pages that nothing links to.
- * Removed backlinks page, which it turns out nothing used.
- * Split off an IkiWiki.pm out of ikiwiki and have all the other modules use
- it, this will allow for adding a unit test suite.
- * Add unit tests for several core functions, including globlist_match,
- dirname, basename, bestlink, linkify, pagetitle, titlepage.
- * Smart globlist merging.
- * Patch from Thomas Schwinge to switch from --svn to --rcs=svn, etc,
- to pave the way for adding other RCS support. This also changes the
- setup files, where before they had svn => 1 or svn => 0, now they have
- rcs => "svn" or rcs => "".
- * Add a debian/NEWS file with upgrade notes.
- * Load whatever rcs module is specified, so new ones can be just dropped in
- as plugins and work. (Well, in theory.)
- * Add some basic docs about writing RCS modules.
- * Broke search capability out into a plugin, removed the --hyperestraier
- switch.
- * Added smiley plugin, nicely controlled and documented by the smileys page.
- * Copied in some smileys from Moin Moin.
- * Allow links of the form [[some page|page]], with whitespace in the link
- text.
- * Removed --sanitize and --no-sanitize, replaced with --plugin htmlscrubber
- and --disable-plugin htmlscrubber.
- * Allow discussion links on pages to be turned off with --no-discussion.
- * Add ikiwiki-mass-rebuild script, ripped out of the postinst.
- * Add some new config items to the estseek.conf template, which are needed
- by hyperestraier 1.2.3.
- -- Joey Hess <joeyh@debian.org> Fri, 5 May 2006 17:00:41 -0400
- ikiwiki (1.0) unstable; urgency=low
- * First official release.
- -- Joey Hess <joeyh@debian.org> Tue, 25 Apr 2006 02:08:17 -0400
|