summaryrefslogtreecommitdiff
path: root/debian/changelog
blob: d248d2689c6158eb0579e679d55843f9a354e7a6 (plain)
  1. ikiwiki (1.8) UNRELEASED; urgency=low
  2. * Fix orphans plugin to not count a link to a nonexistant page as a reason
  3. for a page not being an orphan.
  4. * Support pinging services such as Technorati using XML-RPC to notify them
  5. about changes to rss feeds.
  6. * Parse svn log as xml for improved utf8 and security. Note that this makes
  7. ikiwiki depend on XML::Simple. Patch by Faidon Liambotis.
  8. * POSIX::strftime doesn't know about encodings and doesn't return a utf8
  9. flagged string even if the locale causes it to generate utf8 output,
  10. so make sure to let perl know it should be handled as utf8. Also,
  11. the optimised version used for standard time formats won't work if the
  12. user has changed locale, so drop it. Thanks, Faidon Liambotis.
  13. * Fix re-encoding of the comments field to utf8 if a commit fails
  14. due to a conflict. Thanks, Faidon Liambotis.
  15. * Let svn know that commits have utf8 commit messages. Thanks, Faidon
  16. Liambotis.
  17. * Add insane double encode/decode to utf8 around call to markdown.
  18. This works around a truely strange bug, which is apparently a bug in
  19. perl, #376329. Also added a test case for it.
  20. * Improve layout of edit page so formatting help link is always visible w/o
  21. getting in the way of the preview.
  22. * Centralised all calls to HTML::Template and force all the templates
  23. to be read as utf8.
  24. * Support pages with utf8 filenames. Patch by Faidon Liambotis.
  25. * Introduce add_plugins and disable_plugins config options in setup files.
  26. This allows adding or removing plugins w/o overriding the whole list of
  27. default plugins, which makes it easier to upgrade when new default plugins
  28. are added.
  29. * Support htmlize plugins and make mdwn one such plugin, which is enabled by
  30. default (of course!). Based on a patch by Faidon Liambotis.
  31. * Add a html plugin, which can be used to write wikis in raw html,
  32. if you'd ever want to do such a thing. Slightly tricky, since ikiwiki
  33. defaults to not processing .html files, since w/o this plugin they would
  34. be copied unsanitised. With this plugin, it will process and html
  35. sanitise them, like any other page type.
  36. * Rebuilding wrappers is necessary on upgrade to this version.
  37. * Make ikiwiki --setup --refresh rebuild wrappers, so wrapper rebuild
  38. will be automatically done on all upgrades.
  39. * Don't send pings if the wiki is being rebuilt.
  40. * Work around very innefficient behavior in File::Spec::abs2rel. Result
  41. is a savings of 2 pointless fork/execs per link calculation, which
  42. results in ~25% speedup of ikiwiki building its own doc wiki, and
  43. about 35% speedup displaying RecentChanges!
  44. * Make RecentChanges use a table and some CSS, should be much more readable.
  45. No code changes involved.
  46. * Encode & in diffurl in examples, to conform to pedantic rules.
  47. * Speed up RecentChanges by another 40% or so with some memoization.
  48. -- Joey Hess <joeyh@debian.org> Tue, 4 Jul 2006 12:16:39 -0400
  49. ikiwiki (1.7) unstable; urgency=low
  50. * Updated logo from Recai with some kerning and alingment tuning.
  51. * Patch from Recai to fix git recentchanges code to work with git 1.4 which
  52. changed some output.
  53. * Copyright update.
  54. -- Joey Hess <joeyh@debian.org> Sun, 18 Jun 2006 23:33:35 -0400
  55. ikiwiki (1.6) unstable; urgency=low
  56. * YA utf-8 patch from Recai, this time to fix previewing a page so that
  57. the text in the input box is re-encoded back to utf-8.
  58. * -CSD does not affect modules, so readfile() was not using the utf-8 input
  59. layer, which led to lots of problems; make it force read files as utf-8.
  60. Closes: #373203
  61. * Note that as a consequence, this version of ikiwiki will actually try to
  62. parse utf8 in source files for the first time, which may expose broken
  63. utf8 in wiki sources that was hidden before. Most common will be
  64. perl warnings like "utf8 "\xE9" does not map to Unicode"
  65. * writefile() likewise needs to use the utf8 output layer.
  66. * Remove the -CSD from ikiwiki's hashbang since it's useless to have it
  67. there.
  68. * Revert some of the decode_utf8 changes in CGI.pm that seem unnecessary
  69. given the readfile fix.
  70. * Add utf-8 testcases for readfile and htmlize.
  71. * Put back the encode_utf8 in the input to markdown; it's really not utf-8
  72. safe.
  73. * More utf-8 fixes from Recai, partly to things I broke above:
  74. - The serious problem is that writefile() saves the content in undecoded
  75. format in CGI, hence all (non-ascii) chars are corrupted permanently.
  76. - Comment field in edit page is not decoded and all the non-ascii chars in
  77. this field are corrupted as the result. We should decode it as we do it
  78. for the content.
  79. - Add 'use encoding "utf8"' to CGI.pm to avoid warnings about wide
  80. character in print.
  81. * New SVG logo from Recai.
  82. -- Joey Hess <joeyh@debian.org> Sun, 18 Jun 2006 19:18:46 -0400
  83. ikiwiki (1.5) unstable; urgency=low
  84. * Add --timeformat config option to allow changing how dates are displayed.
  85. Note that as a side effect, dates will now be displayed using the local
  86. timezone, not as GMT.
  87. * More security review.
  88. * Patch from Dr. Zini to add link() and backlink() to globlists. This allows
  89. for some handy stuff like:
  90. - Using links as a kind of tag; creating blog pages that list all pages
  91. containing a given tag/link or not containing some other tag.
  92. - Subscribing to mail notifications whenever a change is made to a page
  93. that is a backlink of page foo. Ie, "Please notify me of changes in all
  94. pages that link to my home page in the wiki"
  95. - Locking any pages that are linked to from a particular page, so that
  96. lists of locks can be exposed in the wiki.
  97. * Reorganised the doc wiki's todo/* pages, using a link/tag to flag
  98. when a todo item is done, instead of the previous moving it to a different
  99. subdir.
  100. * Allow pagetemplate plugins to override *anything* in the template.
  101. * Add a meta plugin, which allows specifying various metadata about pages,
  102. like license and author. It also allows for inserting html link and meta
  103. tags into html, overriding the title, and adding hidden WikiLinks, which
  104. can be useful when using link-based globbing for page categorisation.
  105. * Remove preprocessor directives from inlined pages.
  106. * Allow simple preprocessor directive values to be specified w/o quotes.
  107. * Add support for using git instead of subversion as the RCS backend,
  108. tremendous thanks to Recai Oktaş for this.
  109. * Doc updates for git.
  110. * Fix absolute url munging in rss generation to support https, ftp, etc urls
  111. not just http urls.
  112. * Patch from Recai Oktaş to improve utf-8 support, it should now use proper
  113. utf-8 for edit and other fields, and for recentchanges. There may still
  114. be utf-8 issues with the preferences page though.
  115. -- Joey Hess <joeyh@debian.org> Sun, 11 Jun 2006 19:56:54 -0400
  116. ikiwiki (1.4) unstable; urgency=low
  117. * Tell HTML::Scrubber to treat "/" as a valid attribute which is its
  118. very strange way of enabling proper XHTML <br /> type tags. Output html
  119. should be always valid again now.
  120. * The page name and parent links has switched from using a <h1> to a styled
  121. <span>, so pages can use <h1> internally instead of needing to use <h2>.
  122. * Updated all of ikiwiki's own wiki pages for that.
  123. * Add pagetemplate hook, which can be used by plugins that want to mess
  124. around with adding new stuff to the page template.
  125. * Remove headercontent; the search plugin now adds the search box to the
  126. header by registering a pagetemplate hook, and other plugins should do
  127. similarly.
  128. * Rebuilding on upgrade to this version is recommended.
  129. * Add a html validity check to the test suite, using the wdg-html-validator,
  130. if available.
  131. * Make the html valid when there is nothing in the actions list.
  132. * Reordered some function call parameters for consistency.
  133. * Enable full utf-8 support for page input and output.
  134. * Add a workaround for markdown, which does not work well with utf-8
  135. strings.
  136. * --getctime had bitrotted (well I only ever used it the once so far..),
  137. fix and make it a bit more flexible
  138. * rcs_getctime is changed, now rather than needing to loop over all pages,
  139. it should just use the rcs to get the ctime of the passed file.
  140. * When inlining a page in another one, links from the inlined page are now
  141. expanded the same as they are when rendering the inlined page as a
  142. standalone page. So rather than being expanded from the POV of the
  143. inlining page, they are expanded from the POV of the inlined page.
  144. For example, a link from blog/foo to "bar" will now link to blog/bar
  145. if it exists. Previously this needed to be a link explicitly to
  146. "blog/bar"; such links will also continue to work.
  147. (This was slightly complex to do as the link still has to be constructed
  148. relative to the inlining page.)
  149. * Make page edit textarea resize to fit browser window.
  150. * Add -refresh option to ikiwiki-mass-rebuild and use that on upgrades that
  151. do not need a full rebuild, in order to update any basewiki pages.
  152. -- Joey Hess <joeyh@debian.org> Sat, 27 May 2006 15:08:49 -0400
  153. ikiwiki (1.3) unstable; urgency=low
  154. * Fix the preinst introduced in the last version. Closes: #367458
  155. -- Joey Hess <joeyh@debian.org> Tue, 16 May 2006 02:43:02 -0500
  156. ikiwiki (1.2) unstable; urgency=low
  157. * Remove dups from the brokenlinks list.
  158. * Add libc6-dev to dependencies, needed to build wrappers.
  159. * Install wikilist in correct location. Closes: #367371
  160. -- Joey Hess <joeyh@debian.org> Mon, 15 May 2006 10:53:49 -0500
  161. ikiwiki (1.1) unstable; urgency=low
  162. * Rename inlinepage to depends, so that it can be used to refer to more
  163. dependency relationships than just inlining. This will require a rebuild
  164. on upgrade to this version.
  165. * Move the rss link, put it in the blogpost form if there is one and at the
  166. top if not. This is both nicer because easier to find, and it cleans up
  167. the code which had used inlinepage as a flag for adding the link later.
  168. * Allow the depends GlobList to be built up from multiple sources (such as
  169. plugins) during a page render.
  170. * Which means that more than one blog is now supported to appear on a
  171. single page. (With some limitations, like only the last one getting an
  172. rss file.)
  173. * Added a plugin system.
  174. * Added a pagecount plugin, enabled by default.
  175. * Support PreProcessorDirectives with no parameters, ie "[[pagecount ]]".
  176. * Fixed/optimised backlinks code, to avoid rebuilding pages to update
  177. backlinks when the backlinks hadn't really changed.
  178. * Moved inline page support, rss generation etc into the inline plugin,
  179. enabled by default.
  180. * Added brokenlinks plugin, not enabled by default, but rather handy.
  181. * Fix several broken links in the doc wiki.
  182. * Smarter behavior when creating a page and a page of the same name (but
  183. different location) already exists.
  184. * Add an orphans plugin for finding pages that nothing links to.
  185. * Removed backlinks page, which it turns out nothing used.
  186. * Split off an IkiWiki.pm out of ikiwiki and have all the other modules use
  187. it, this will allow for adding a unit test suite.
  188. * Add unit tests for several core functions, including globlist_match,
  189. dirname, basename, bestlink, linkify, pagetitle, titlepage.
  190. * Smart globlist merging.
  191. * Patch from Thomas Schwinge to switch from --svn to --rcs=svn, etc,
  192. to pave the way for adding other RCS support. This also changes the
  193. setup files, where before they had svn => 1 or svn => 0, now they have
  194. rcs => "svn" or rcs => "".
  195. * Add a debian/NEWS file with upgrade notes.
  196. * Load whatever rcs module is specified, so new ones can be just dropped in
  197. as plugins and work. (Well, in theory.)
  198. * Add some basic docs about writing RCS modules.
  199. * Broke search capability out into a plugin, removed the --hyperestraier
  200. switch.
  201. * Added smiley plugin, nicely controlled and documented by the smileys page.
  202. * Copied in some smileys from Moin Moin.
  203. * Allow links of the form [[some page|page]], with whitespace in the link
  204. text.
  205. * Removed --sanitize and --no-sanitize, replaced with --plugin htmlscrubber
  206. and --disable-plugin htmlscrubber.
  207. * Allow discussion links on pages to be turned off with --no-discussion.
  208. * Add ikiwiki-mass-rebuild script, ripped out of the postinst.
  209. * Add some new config items to the estseek.conf template, which are needed
  210. by hyperestraier 1.2.3.
  211. -- Joey Hess <joeyh@debian.org> Fri, 5 May 2006 17:00:41 -0400
  212. ikiwiki (1.0) unstable; urgency=low
  213. * First official release.
  214. -- Joey Hess <joeyh@debian.org> Tue, 25 Apr 2006 02:08:17 -0400