summaryrefslogtreecommitdiff
path: root/debian/changelog
blob: 2bacb206c915c656a5ccd5a88b991203d5daa883 (plain)
  1. ikiwiki (1.10) unstable; urgency=low
  2. * Run page through any relevant filters when generating a page preview.
  3. * Noticed a bug in the wikitext markup plugin -- it made CamelCase links the
  4. default throughout the wiki, not only on wikitext pages. Decided to call
  5. this a feature, and split the camelcase support out into a separate plugin
  6. that is independant of wikitext.
  7. * Fix CamelCase regexp to not break [[FooBar|BazBar]] WikiLinks.
  8. -- Joey Hess <joeyh@debian.org> Wed, 26 Jul 2006 18:06:35 -0400
  9. ikiwiki (1.9) unstable; urgency=low
  10. * Improve display of parentlinks and page title of toplevel index page.
  11. * Patch from Faidon to use svn --limit when possible for recentchanges,
  12. speeds up recentchanges a lot for wikis with more history.
  13. * Patch from Recai to fix utf8 issues in git backend.
  14. * Add wikitext markup plugin, which supports ".wiki" pages written in the
  15. original wiki syntax, CamelCase links and all.
  16. * Support a w3mmode, which lets w3m run ikiwiki using its local CGI
  17. support, to edit pages etc without a web server.
  18. * Display CGI processing errors if present.
  19. * Fix from Faidon for a XML parser issue that breaks utf-8 for
  20. RecentChanges. Avoid using XML::SAX::PurePerl, which is buggy in this
  21. area, and also way slow.
  22. * Match 'web commit from' in SVN and git, these are web commits too.
  23. (Faidon)
  24. * Consolidated all decode_utf8 in FormBuilder's fields to make the code more
  25. readable and avoid future mistakes. The patch seems to work and for the
  26. first time I have a UTF-8 username ;-) (Faidon)
  27. * Use form->field consistently, not form->param.
  28. * Patch from Recai to allow selection of page type when creating a new page.
  29. Default page type is inherited from the link clicked on to create the new
  30. page.
  31. -- Joey Hess <joeyh@debian.org> Wed, 26 Jul 2006 17:25:30 -0400
  32. ikiwiki (1.8) unstable; urgency=low
  33. * Fix orphans plugin to not count a link to a nonexistant page as a reason
  34. for a page not being an orphan.
  35. * Support pinging services such as Technorati using XML-RPC to notify them
  36. about changes to rss feeds.
  37. * Parse svn log as xml for improved utf8 and security. Note that this makes
  38. ikiwiki depend on XML::Simple. Patch by Faidon Liambotis.
  39. * POSIX::strftime doesn't know about encodings and doesn't return a utf8
  40. flagged string even if the locale causes it to generate utf8 output,
  41. so make sure to let perl know it should be handled as utf8. Also,
  42. the optimised version used for standard time formats won't work if the
  43. user has changed locale, so drop it. Thanks, Faidon Liambotis.
  44. * Fix re-encoding of the comments field to utf8 if a commit fails
  45. due to a conflict. Thanks, Faidon Liambotis.
  46. * Let svn know that commits have utf8 commit messages. Thanks, Faidon
  47. Liambotis.
  48. * Add insane double encode/decode to utf8 around call to markdown.
  49. This works around a truely strange bug, which is apparently a bug in
  50. perl, #376329. Also added a test case for it.
  51. * Improve layout of edit page so formatting help link is always visible w/o
  52. getting in the way of the preview.
  53. * Centralised all calls to HTML::Template and force all the templates
  54. to be read as utf8.
  55. * Support pages with utf8 filenames. Patch by Faidon Liambotis.
  56. * Introduce add_plugins and disable_plugins config options in setup files.
  57. This allows adding or removing plugins w/o overriding the whole list of
  58. default plugins, which makes it easier to upgrade when new default plugins
  59. are added.
  60. * Support htmlize plugins and make mdwn one such plugin, which is enabled by
  61. default (of course!). Based on a patch by Faidon Liambotis.
  62. * Add a html plugin, which can be used to write wikis in raw html,
  63. if you'd ever want to do such a thing. Slightly tricky, since ikiwiki
  64. defaults to not processing .html files, since w/o this plugin they would
  65. be copied unsanitised. With this plugin, it will process and html
  66. sanitise them, like any other page type.
  67. * Rebuilding wrappers is necessary on upgrade to this version.
  68. * Make ikiwiki --setup --refresh rebuild wrappers, so wrapper rebuild
  69. will be automatically done on all upgrades.
  70. * Don't send pings if the wiki is being rebuilt.
  71. * Work around very innefficient behavior in File::Spec::abs2rel. Result
  72. is a savings of 2 pointless fork/execs per link calculation, which
  73. results in ~25% speedup of ikiwiki building its own doc wiki, and
  74. about 35% speedup displaying RecentChanges!
  75. * Make RecentChanges use a table and some CSS, should be much more readable.
  76. No code changes involved.
  77. * Encode & in diffurl in examples, to conform to pedantic rules.
  78. * Speed up RecentChanges by another 40% or so with some memoization.
  79. * Memoize abs2rel, which is still kinda slow, for another 30% speedup
  80. in time to build the doc wiki.
  81. -- Joey Hess <joeyh@debian.org> Tue, 4 Jul 2006 12:46:29 -0400
  82. ikiwiki (1.7) unstable; urgency=low
  83. * Updated logo from Recai with some kerning and alingment tuning.
  84. * Patch from Recai to fix git recentchanges code to work with git 1.4 which
  85. changed some output.
  86. * Copyright update.
  87. -- Joey Hess <joeyh@debian.org> Sun, 18 Jun 2006 23:33:35 -0400
  88. ikiwiki (1.6) unstable; urgency=low
  89. * YA utf-8 patch from Recai, this time to fix previewing a page so that
  90. the text in the input box is re-encoded back to utf-8.
  91. * -CSD does not affect modules, so readfile() was not using the utf-8 input
  92. layer, which led to lots of problems; make it force read files as utf-8.
  93. Closes: #373203
  94. * Note that as a consequence, this version of ikiwiki will actually try to
  95. parse utf8 in source files for the first time, which may expose broken
  96. utf8 in wiki sources that was hidden before. Most common will be
  97. perl warnings like "utf8 "\xE9" does not map to Unicode"
  98. * writefile() likewise needs to use the utf8 output layer.
  99. * Remove the -CSD from ikiwiki's hashbang since it's useless to have it
  100. there.
  101. * Revert some of the decode_utf8 changes in CGI.pm that seem unnecessary
  102. given the readfile fix.
  103. * Add utf-8 testcases for readfile and htmlize.
  104. * Put back the encode_utf8 in the input to markdown; it's really not utf-8
  105. safe.
  106. * More utf-8 fixes from Recai, partly to things I broke above:
  107. - The serious problem is that writefile() saves the content in undecoded
  108. format in CGI, hence all (non-ascii) chars are corrupted permanently.
  109. - Comment field in edit page is not decoded and all the non-ascii chars in
  110. this field are corrupted as the result. We should decode it as we do it
  111. for the content.
  112. - Add 'use encoding "utf8"' to CGI.pm to avoid warnings about wide
  113. character in print.
  114. * New SVG logo from Recai.
  115. -- Joey Hess <joeyh@debian.org> Sun, 18 Jun 2006 19:18:46 -0400
  116. ikiwiki (1.5) unstable; urgency=low
  117. * Add --timeformat config option to allow changing how dates are displayed.
  118. Note that as a side effect, dates will now be displayed using the local
  119. timezone, not as GMT.
  120. * More security review.
  121. * Patch from Dr. Zini to add link() and backlink() to globlists. This allows
  122. for some handy stuff like:
  123. - Using links as a kind of tag; creating blog pages that list all pages
  124. containing a given tag/link or not containing some other tag.
  125. - Subscribing to mail notifications whenever a change is made to a page
  126. that is a backlink of page foo. Ie, "Please notify me of changes in all
  127. pages that link to my home page in the wiki"
  128. - Locking any pages that are linked to from a particular page, so that
  129. lists of locks can be exposed in the wiki.
  130. * Reorganised the doc wiki's todo/* pages, using a link/tag to flag
  131. when a todo item is done, instead of the previous moving it to a different
  132. subdir.
  133. * Allow pagetemplate plugins to override *anything* in the template.
  134. * Add a meta plugin, which allows specifying various metadata about pages,
  135. like license and author. It also allows for inserting html link and meta
  136. tags into html, overriding the title, and adding hidden WikiLinks, which
  137. can be useful when using link-based globbing for page categorisation.
  138. * Remove preprocessor directives from inlined pages.
  139. * Allow simple preprocessor directive values to be specified w/o quotes.
  140. * Add support for using git instead of subversion as the RCS backend,
  141. tremendous thanks to Recai Oktaş for this.
  142. * Doc updates for git.
  143. * Fix absolute url munging in rss generation to support https, ftp, etc urls
  144. not just http urls.
  145. * Patch from Recai Oktaş to improve utf-8 support, it should now use proper
  146. utf-8 for edit and other fields, and for recentchanges. There may still
  147. be utf-8 issues with the preferences page though.
  148. -- Joey Hess <joeyh@debian.org> Sun, 11 Jun 2006 19:56:54 -0400
  149. ikiwiki (1.4) unstable; urgency=low
  150. * Tell HTML::Scrubber to treat "/" as a valid attribute which is its
  151. very strange way of enabling proper XHTML <br /> type tags. Output html
  152. should be always valid again now.
  153. * The page name and parent links has switched from using a <h1> to a styled
  154. <span>, so pages can use <h1> internally instead of needing to use <h2>.
  155. * Updated all of ikiwiki's own wiki pages for that.
  156. * Add pagetemplate hook, which can be used by plugins that want to mess
  157. around with adding new stuff to the page template.
  158. * Remove headercontent; the search plugin now adds the search box to the
  159. header by registering a pagetemplate hook, and other plugins should do
  160. similarly.
  161. * Rebuilding on upgrade to this version is recommended.
  162. * Add a html validity check to the test suite, using the wdg-html-validator,
  163. if available.
  164. * Make the html valid when there is nothing in the actions list.
  165. * Reordered some function call parameters for consistency.
  166. * Enable full utf-8 support for page input and output.
  167. * Add a workaround for markdown, which does not work well with utf-8
  168. strings.
  169. * --getctime had bitrotted (well I only ever used it the once so far..),
  170. fix and make it a bit more flexible
  171. * rcs_getctime is changed, now rather than needing to loop over all pages,
  172. it should just use the rcs to get the ctime of the passed file.
  173. * When inlining a page in another one, links from the inlined page are now
  174. expanded the same as they are when rendering the inlined page as a
  175. standalone page. So rather than being expanded from the POV of the
  176. inlining page, they are expanded from the POV of the inlined page.
  177. For example, a link from blog/foo to "bar" will now link to blog/bar
  178. if it exists. Previously this needed to be a link explicitly to
  179. "blog/bar"; such links will also continue to work.
  180. (This was slightly complex to do as the link still has to be constructed
  181. relative to the inlining page.)
  182. * Make page edit textarea resize to fit browser window.
  183. * Add -refresh option to ikiwiki-mass-rebuild and use that on upgrades that
  184. do not need a full rebuild, in order to update any basewiki pages.
  185. -- Joey Hess <joeyh@debian.org> Sat, 27 May 2006 15:08:49 -0400
  186. ikiwiki (1.3) unstable; urgency=low
  187. * Fix the preinst introduced in the last version. Closes: #367458
  188. -- Joey Hess <joeyh@debian.org> Tue, 16 May 2006 02:43:02 -0500
  189. ikiwiki (1.2) unstable; urgency=low
  190. * Remove dups from the brokenlinks list.
  191. * Add libc6-dev to dependencies, needed to build wrappers.
  192. * Install wikilist in correct location. Closes: #367371
  193. -- Joey Hess <joeyh@debian.org> Mon, 15 May 2006 10:53:49 -0500
  194. ikiwiki (1.1) unstable; urgency=low
  195. * Rename inlinepage to depends, so that it can be used to refer to more
  196. dependency relationships than just inlining. This will require a rebuild
  197. on upgrade to this version.
  198. * Move the rss link, put it in the blogpost form if there is one and at the
  199. top if not. This is both nicer because easier to find, and it cleans up
  200. the code which had used inlinepage as a flag for adding the link later.
  201. * Allow the depends GlobList to be built up from multiple sources (such as
  202. plugins) during a page render.
  203. * Which means that more than one blog is now supported to appear on a
  204. single page. (With some limitations, like only the last one getting an
  205. rss file.)
  206. * Added a plugin system.
  207. * Added a pagecount plugin, enabled by default.
  208. * Support PreProcessorDirectives with no parameters, ie "[[pagecount ]]".
  209. * Fixed/optimised backlinks code, to avoid rebuilding pages to update
  210. backlinks when the backlinks hadn't really changed.
  211. * Moved inline page support, rss generation etc into the inline plugin,
  212. enabled by default.
  213. * Added brokenlinks plugin, not enabled by default, but rather handy.
  214. * Fix several broken links in the doc wiki.
  215. * Smarter behavior when creating a page and a page of the same name (but
  216. different location) already exists.
  217. * Add an orphans plugin for finding pages that nothing links to.
  218. * Removed backlinks page, which it turns out nothing used.
  219. * Split off an IkiWiki.pm out of ikiwiki and have all the other modules use
  220. it, this will allow for adding a unit test suite.
  221. * Add unit tests for several core functions, including globlist_match,
  222. dirname, basename, bestlink, linkify, pagetitle, titlepage.
  223. * Smart globlist merging.
  224. * Patch from Thomas Schwinge to switch from --svn to --rcs=svn, etc,
  225. to pave the way for adding other RCS support. This also changes the
  226. setup files, where before they had svn => 1 or svn => 0, now they have
  227. rcs => "svn" or rcs => "".
  228. * Add a debian/NEWS file with upgrade notes.
  229. * Load whatever rcs module is specified, so new ones can be just dropped in
  230. as plugins and work. (Well, in theory.)
  231. * Add some basic docs about writing RCS modules.
  232. * Broke search capability out into a plugin, removed the --hyperestraier
  233. switch.
  234. * Added smiley plugin, nicely controlled and documented by the smileys page.
  235. * Copied in some smileys from Moin Moin.
  236. * Allow links of the form [[some page|page]], with whitespace in the link
  237. text.
  238. * Removed --sanitize and --no-sanitize, replaced with --plugin htmlscrubber
  239. and --disable-plugin htmlscrubber.
  240. * Allow discussion links on pages to be turned off with --no-discussion.
  241. * Add ikiwiki-mass-rebuild script, ripped out of the postinst.
  242. * Add some new config items to the estseek.conf template, which are needed
  243. by hyperestraier 1.2.3.
  244. -- Joey Hess <joeyh@debian.org> Fri, 5 May 2006 17:00:41 -0400
  245. ikiwiki (1.0) unstable; urgency=low
  246. * First official release.
  247. -- Joey Hess <joeyh@debian.org> Tue, 25 Apr 2006 02:08:17 -0400