summaryrefslogtreecommitdiff
path: root/debian/changelog
blob: 5afcf976c2c005a8271b38310eee7882713327a0 (plain)
  1. ikiwiki (1.8) UNRELEASED; urgency=low
  2. * Fix orphans plugin to not count a link to a nonexistant page as a reason
  3. for a page not being an orphan.
  4. * Support pinging services such as Technorati using XML-RPC to notify them
  5. about changes to rss feeds.
  6. * Parse svn log as xml for improved utf8 and security. Note that this makes
  7. ikiwiki depend on XML::Simple. Patch by Faidon Liambotis.
  8. * POSIX::strftime doesn't know about encodings and doesn't return a utf8
  9. flagged string even if the locale causes it to generate utf8 output,
  10. so make sure to let perl know it should be handled as utf8. Also,
  11. the optimised version used for standard time formats won't work if the
  12. user has changed locale, so drop it. Thanks, Faidon Liambotis.
  13. * Fix re-encoding of the comments field to utf8 if a commit fails
  14. due to a conflict. Thanks, Faidon Liambotis.
  15. * Let svn know that commits have utf8 commit messages. Thanks, Faidon
  16. Liambotis.
  17. * Add insane double encode/decode to utf8 around call to markdown.
  18. This works around a truely strange bug, which is apparently a bug in
  19. perl, #376329. Also added a test case for it.
  20. * Improve layout of edit page so formatting help link is always visible w/o
  21. getting in the way of the preview.
  22. -- Joey Hess <joeyh@debian.org> Sun, 2 Jul 2006 13:43:56 -0400
  23. ikiwiki (1.7) unstable; urgency=low
  24. * Updated logo from Recai with some kerning and alingment tuning.
  25. * Patch from Recai to fix git recentchanges code to work with git 1.4 which
  26. changed some output.
  27. * Copyright update.
  28. -- Joey Hess <joeyh@debian.org> Sun, 18 Jun 2006 23:33:35 -0400
  29. ikiwiki (1.6) unstable; urgency=low
  30. * YA utf-8 patch from Recai, this time to fix previewing a page so that
  31. the text in the input box is re-encoded back to utf-8.
  32. * -CSD does not affect modules, so readfile() was not using the utf-8 input
  33. layer, which led to lots of problems; make it force read files as utf-8.
  34. Closes: #373203
  35. * Note that as a consequence, this version of ikiwiki will actually try to
  36. parse utf8 in source files for the first time, which may expose broken
  37. utf8 in wiki sources that was hidden before. Most common will be
  38. perl warnings like "utf8 "\xE9" does not map to Unicode"
  39. * writefile() likewise needs to use the utf8 output layer.
  40. * Remove the -CSD from ikiwiki's hashbang since it's useless to have it
  41. there.
  42. * Revert some of the decode_utf8 changes in CGI.pm that seem unnecessary
  43. given the readfile fix.
  44. * Add utf-8 testcases for readfile and htmlize.
  45. * Put back the encode_utf8 in the input to markdown; it's really not utf-8
  46. safe.
  47. * More utf-8 fixes from Recai, partly to things I broke above:
  48. - The serious problem is that writefile() saves the content in undecoded
  49. format in CGI, hence all (non-ascii) chars are corrupted permanently.
  50. - Comment field in edit page is not decoded and all the non-ascii chars in
  51. this field are corrupted as the result. We should decode it as we do it
  52. for the content.
  53. - Add 'use encoding "utf8"' to CGI.pm to avoid warnings about wide
  54. character in print.
  55. * New SVG logo from Recai.
  56. -- Joey Hess <joeyh@debian.org> Sun, 18 Jun 2006 19:18:46 -0400
  57. ikiwiki (1.5) unstable; urgency=low
  58. * Add --timeformat config option to allow changing how dates are displayed.
  59. Note that as a side effect, dates will now be displayed using the local
  60. timezone, not as GMT.
  61. * More security review.
  62. * Patch from Dr. Zini to add link() and backlink() to globlists. This allows
  63. for some handy stuff like:
  64. - Using links as a kind of tag; creating blog pages that list all pages
  65. containing a given tag/link or not containing some other tag.
  66. - Subscribing to mail notifications whenever a change is made to a page
  67. that is a backlink of page foo. Ie, "Please notify me of changes in all
  68. pages that link to my home page in the wiki"
  69. - Locking any pages that are linked to from a particular page, so that
  70. lists of locks can be exposed in the wiki.
  71. * Reorganised the doc wiki's todo/* pages, using a link/tag to flag
  72. when a todo item is done, instead of the previous moving it to a different
  73. subdir.
  74. * Allow pagetemplate plugins to override *anything* in the template.
  75. * Add a meta plugin, which allows specifying various metadata about pages,
  76. like license and author. It also allows for inserting html link and meta
  77. tags into html, overriding the title, and adding hidden WikiLinks, which
  78. can be useful when using link-based globbing for page categorisation.
  79. * Remove preprocessor directives from inlined pages.
  80. * Allow simple preprocessor directive values to be specified w/o quotes.
  81. * Add support for using git instead of subversion as the RCS backend,
  82. tremendous thanks to Recai Oktaş for this.
  83. * Doc updates for git.
  84. * Fix absolute url munging in rss generation to support https, ftp, etc urls
  85. not just http urls.
  86. * Patch from Recai Oktaş to improve utf-8 support, it should now use proper
  87. utf-8 for edit and other fields, and for recentchanges. There may still
  88. be utf-8 issues with the preferences page though.
  89. -- Joey Hess <joeyh@debian.org> Sun, 11 Jun 2006 19:56:54 -0400
  90. ikiwiki (1.4) unstable; urgency=low
  91. * Tell HTML::Scrubber to treat "/" as a valid attribute which is its
  92. very strange way of enabling proper XHTML <br /> type tags. Output html
  93. should be always valid again now.
  94. * The page name and parent links has switched from using a <h1> to a styled
  95. <span>, so pages can use <h1> internally instead of needing to use <h2>.
  96. * Updated all of ikiwiki's own wiki pages for that.
  97. * Add pagetemplate hook, which can be used by plugins that want to mess
  98. around with adding new stuff to the page template.
  99. * Remove headercontent; the search plugin now adds the search box to the
  100. header by registering a pagetemplate hook, and other plugins should do
  101. similarly.
  102. * Rebuilding on upgrade to this version is recommended.
  103. * Add a html validity check to the test suite, using the wdg-html-validator,
  104. if available.
  105. * Make the html valid when there is nothing in the actions list.
  106. * Reordered some function call parameters for consistency.
  107. * Enable full utf-8 support for page input and output.
  108. * Add a workaround for markdown, which does not work well with utf-8
  109. strings.
  110. * --getctime had bitrotted (well I only ever used it the once so far..),
  111. fix and make it a bit more flexible
  112. * rcs_getctime is changed, now rather than needing to loop over all pages,
  113. it should just use the rcs to get the ctime of the passed file.
  114. * When inlining a page in another one, links from the inlined page are now
  115. expanded the same as they are when rendering the inlined page as a
  116. standalone page. So rather than being expanded from the POV of the
  117. inlining page, they are expanded from the POV of the inlined page.
  118. For example, a link from blog/foo to "bar" will now link to blog/bar
  119. if it exists. Previously this needed to be a link explicitly to
  120. "blog/bar"; such links will also continue to work.
  121. (This was slightly complex to do as the link still has to be constructed
  122. relative to the inlining page.)
  123. * Make page edit textarea resize to fit browser window.
  124. * Add -refresh option to ikiwiki-mass-rebuild and use that on upgrades that
  125. do not need a full rebuild, in order to update any basewiki pages.
  126. -- Joey Hess <joeyh@debian.org> Sat, 27 May 2006 15:08:49 -0400
  127. ikiwiki (1.3) unstable; urgency=low
  128. * Fix the preinst introduced in the last version. Closes: #367458
  129. -- Joey Hess <joeyh@debian.org> Tue, 16 May 2006 02:43:02 -0500
  130. ikiwiki (1.2) unstable; urgency=low
  131. * Remove dups from the brokenlinks list.
  132. * Add libc6-dev to dependencies, needed to build wrappers.
  133. * Install wikilist in correct location. Closes: #367371
  134. -- Joey Hess <joeyh@debian.org> Mon, 15 May 2006 10:53:49 -0500
  135. ikiwiki (1.1) unstable; urgency=low
  136. * Rename inlinepage to depends, so that it can be used to refer to more
  137. dependency relationships than just inlining. This will require a rebuild
  138. on upgrade to this version.
  139. * Move the rss link, put it in the blogpost form if there is one and at the
  140. top if not. This is both nicer because easier to find, and it cleans up
  141. the code which had used inlinepage as a flag for adding the link later.
  142. * Allow the depends GlobList to be built up from multiple sources (such as
  143. plugins) during a page render.
  144. * Which means that more than one blog is now supported to appear on a
  145. single page. (With some limitations, like only the last one getting an
  146. rss file.)
  147. * Added a plugin system.
  148. * Added a pagecount plugin, enabled by default.
  149. * Support PreProcessorDirectives with no parameters, ie "[[pagecount ]]".
  150. * Fixed/optimised backlinks code, to avoid rebuilding pages to update
  151. backlinks when the backlinks hadn't really changed.
  152. * Moved inline page support, rss generation etc into the inline plugin,
  153. enabled by default.
  154. * Added brokenlinks plugin, not enabled by default, but rather handy.
  155. * Fix several broken links in the doc wiki.
  156. * Smarter behavior when creating a page and a page of the same name (but
  157. different location) already exists.
  158. * Add an orphans plugin for finding pages that nothing links to.
  159. * Removed backlinks page, which it turns out nothing used.
  160. * Split off an IkiWiki.pm out of ikiwiki and have all the other modules use
  161. it, this will allow for adding a unit test suite.
  162. * Add unit tests for several core functions, including globlist_match,
  163. dirname, basename, bestlink, linkify, pagetitle, titlepage.
  164. * Smart globlist merging.
  165. * Patch from Thomas Schwinge to switch from --svn to --rcs=svn, etc,
  166. to pave the way for adding other RCS support. This also changes the
  167. setup files, where before they had svn => 1 or svn => 0, now they have
  168. rcs => "svn" or rcs => "".
  169. * Add a debian/NEWS file with upgrade notes.
  170. * Load whatever rcs module is specified, so new ones can be just dropped in
  171. as plugins and work. (Well, in theory.)
  172. * Add some basic docs about writing RCS modules.
  173. * Broke search capability out into a plugin, removed the --hyperestraier
  174. switch.
  175. * Added smiley plugin, nicely controlled and documented by the smileys page.
  176. * Copied in some smileys from Moin Moin.
  177. * Allow links of the form [[some page|page]], with whitespace in the link
  178. text.
  179. * Removed --sanitize and --no-sanitize, replaced with --plugin htmlscrubber
  180. and --disable-plugin htmlscrubber.
  181. * Allow discussion links on pages to be turned off with --no-discussion.
  182. * Add ikiwiki-mass-rebuild script, ripped out of the postinst.
  183. * Add some new config items to the estseek.conf template, which are needed
  184. by hyperestraier 1.2.3.
  185. -- Joey Hess <joeyh@debian.org> Fri, 5 May 2006 17:00:41 -0400
  186. ikiwiki (1.0) unstable; urgency=low
  187. * First official release.
  188. -- Joey Hess <joeyh@debian.org> Tue, 25 Apr 2006 02:08:17 -0400