summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
Diffstat (limited to 'debian')
-rw-r--r--debian/NEWS10
-rw-r--r--debian/changelog38
-rwxr-xr-xdebian/postinst2
3 files changed, 45 insertions, 5 deletions
diff --git a/debian/NEWS b/debian/NEWS
index 808105fd5..7c88ca733 100644
--- a/debian/NEWS
+++ b/debian/NEWS
@@ -1,3 +1,13 @@
+ikiwiki (3.2009XXXX) UNRELEASED; urgency=low
+
+ To take advantage of significant performance improvements, all
+ wikis need to be rebuilt on upgrade to this version. If you
+ listed your wiki in /etc/ikiwiki/wikilist this will be done
+ automatically when the Debian package is upgraded. Or use
+ ikiwiki-mass-rebuild to force a rebuild.
+
+ -- Joey Hess <joeyh@debian.org> Mon, 05 Oct 2009 16:48:59 -0400
+
ikiwiki (3.1415926) unstable; urgency=low
In order to fix a performance bug, all wikis need to be rebuilt on
diff --git a/debian/changelog b/debian/changelog
index 76094e7a6..e9f09a8c6 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,11 +1,41 @@
-ikiwiki (3.20091010) UNRELEASED; urgency=low
-
+ikiwiki (3.2009XXXX) UNRELEASED; urgency=low
+
+ * Added support framework for multiple types of dependencies, including
+ dependncies that are only affected by page precence or link changes.
+ * Rebuild wikis on upgrade to this version to get improved dependency
+ info.
+ * pagecount, calendar, postsparkline, progress: Use a presence dependency,
+ which makes these directives much less expensive to use, since page
+ edits will no longer trigger an unnecessary update.
+ * map: Use a presence dependency unless show= is specified.
+ This makes maps efficient enough that they can be used on sidebars!
+ * inline: Use a presence dependency in quick mode.
+ * brokenlinks: Use a link dependency.
+ This makes it much more efficient, only updating when really necessary.
+ * orphans, pagestats: Use a combination of presence and link dependencies.
+ This makes them more efficient. It also fixes a longstanding bug,
+ where if only a small set of pages were considered by orphans/pagestats,
+ changes to links on other pages failed to cause an update.
+ * linkmap: Use a combination of presence and link dependencies.
+ This makes the map be regenerated much less frequently in many cases,
+ so larger maps are more practical to use now.
+ * Plugins providing PageSpec `match_*` functions should pass additional
+ influence information when creating result objects. This allows correctly
+ handling many more complicated dependencies.
+ * API change: `pagespec_match_list` has completly changed its interface.
+ The old interface will be removed soon, and a warning will be printed
+ if any plugins try to use it.
+ * Transitive dependencies are now correctly supported.
* ikiwiki-calendar: New command automates creation of archive pages
using the calendar plugin.
+ * calendar: Fix midnight rebuild trigger of calendars with explicit
+ month/year.
+ * calendar: Fix bug in next/previous year/month links, which sometimes
+ linked to an archive page from the wrong year, or were missing.
* git: --getctime will now follow renames back to the original creation
of a file.
- -- Joey Hess <joeyh@debian.org> Sun, 11 Oct 2009 15:54:45 -0400
+ -- Joey Hess <joeyh@debian.org> Fri, 09 Oct 2009 19:53:50 -0400
ikiwiki (3.20091009) unstable; urgency=low
@@ -19,7 +49,7 @@ ikiwiki (3.20091009) unstable; urgency=low
* mirrorlist: Display nothing if list is empty.
* Fix a bug that could lead to duplicate links being recorded
for tags.
- * Optimize away most expensive file prune calls, when refreshing,
+ * Optimize away most expensive file prune checks, when refreshing,
by only checking new files.
-- Joey Hess <joeyh@debian.org> Fri, 09 Oct 2009 19:53:50 -0400
diff --git a/debian/postinst b/debian/postinst
index 2ba26e5b6..bf1825ab7 100755
--- a/debian/postinst
+++ b/debian/postinst
@@ -4,7 +4,7 @@ set -e
# Change this when some incompatible change is made that requires
# rebuilding all wikis.
-firstcompat=3.1415926
+firstcompat=3.20091010
if [ "$1" = configure ] && \
dpkg --compare-versions "$2" lt "$firstcompat"; then