summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog3
-rwxr-xr-xdebian/rules3
2 files changed, 5 insertions, 1 deletions
diff --git a/debian/changelog b/debian/changelog
index 3d9f01207..fe3c6b16c 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -59,6 +59,9 @@ ikiwiki (2.16) UNRELEASED; urgency=low
* Re-organise dependencies and recommends now that recommends are installed
by default.
* Don't refuse to render files with ".." in their name. (Anchor the regexp.)
+ * Work around perl taint checking bug #411786, where perl sometimes randomly
+ sets the taint flag on untainted variables, by disabling taint checking
+ in the deb. This sucks.
-- Joey Hess <joeyh@debian.org> Sun, 16 Dec 2007 16:55:23 -0500
diff --git a/debian/rules b/debian/rules
index af33131d9..ef0e7f827 100755
--- a/debian/rules
+++ b/debian/rules
@@ -4,7 +4,8 @@ build: build-stamp
build-stamp:
dh_testdir
perl Makefile.PL PREFIX=/usr INSTALLDIRS=vendor
- $(MAKE)
+ # taint checking disabled due to perl bug #411786
+ $(MAKE) NOTAINT=1
$(MAKE) test
touch build-stamp