summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog4
-rwxr-xr-xdebian/postinst2
2 files changed, 5 insertions, 1 deletions
diff --git a/debian/changelog b/debian/changelog
index 667a49c30..44d324dd8 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -35,8 +35,10 @@ ikiwiki (1.4) UNRELEASED; urgency=low
(This was slightly complex to do as the link still has to be constructed
relative to the inlining page.)
* Make page edit textarea resize to fit browser window.
+ * Add -refresh option to ikiwiki-mass-rebuild and use that on upgrades that
+ do not need a full rebuild, in order to update any basewiki pages.
- -- Joey Hess <joeyh@debian.org> Sat, 27 May 2006 14:28:19 -0400
+ -- Joey Hess <joeyh@debian.org> Sat, 27 May 2006 15:01:52 -0400
ikiwiki (1.3) unstable; urgency=low
diff --git a/debian/postinst b/debian/postinst
index 9135af754..72b457716 100755
--- a/debian/postinst
+++ b/debian/postinst
@@ -9,4 +9,6 @@ firstcompat=1.4
if [ "$1" = configure ] && \
dpkg --compare-versions "$2" lt "$firstcompat"; then
ikiwiki-mass-rebuild
+else
+ ikiwiki-mass-rebuild -refresh
fi