summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog7
-rw-r--r--debian/control2
-rwxr-xr-xdebian/preinst4
-rwxr-xr-xdebian/rules3
4 files changed, 13 insertions, 3 deletions
diff --git a/debian/changelog b/debian/changelog
index 6772aded9..f35606148 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -12,7 +12,12 @@ ikiwiki (3.02) UNRELEASED; urgency=low
that take a page name parameter. Previously, match_created_before(),
match_created_after(), match_sourcepage(), and match_destpage()
did not support that, and the docs were not clear.
- * pinger: Get whole url, don't just head.
+ * pinger: Get whole url, don't just head, avoids problems on
+ the nostromo web server.
+ * Recommend libterm-readline-gnu-perl since that makes auto.setup
+ behave better.
+ * Add auto-blog.setup, which will set up an ikiwiki instance tuned for use
+ in blogging.
-- Joey Hess <joeyh@debian.org> Tue, 06 Jan 2009 15:02:52 -0500
diff --git a/debian/control b/debian/control
index 0db972ff7..fe5c3eee7 100644
--- a/debian/control
+++ b/debian/control
@@ -13,7 +13,7 @@ Vcs-Browser: http://git.ikiwiki.info/?p=ikiwiki
Package: ikiwiki
Architecture: all
Depends: ${perl:Depends}, libtext-markdown-perl | markdown, libhtml-scrubber-perl, libhtml-template-perl, libhtml-parser-perl, liburi-perl
-Recommends: gcc | c-compiler, libc6-dev | libc-dev, subversion | git-core (>= 1:1.5.0) | tla | bzr (>= 0.91) | mercurial | monotone (>= 0.38), libxml-simple-perl, libnet-openid-consumer-perl, liblwpx-paranoidagent-perl, libtimedate-perl, libcgi-formbuilder-perl (>= 3.05), libcgi-session-perl (>= 4.14-1), libmail-sendmail-perl, libauthen-passphrase-perl
+Recommends: gcc | c-compiler, libc6-dev | libc-dev, subversion | git-core (>= 1:1.5.0) | tla | bzr (>= 0.91) | mercurial | monotone (>= 0.38), libxml-simple-perl, libnet-openid-consumer-perl, liblwpx-paranoidagent-perl, libtimedate-perl, libcgi-formbuilder-perl (>= 3.05), libcgi-session-perl (>= 4.14-1), libmail-sendmail-perl, libauthen-passphrase-perl, libterm-readline-gnu-perl
Suggests: viewvc | gitweb | viewcvs, libsearch-xapian-perl, xapian-omega (>= 1.0.5), librpc-xml-perl, libtext-wikiformat-perl, python, python-docutils, polygen, tidy, libhtml-tree-perl, libxml-feed-perl, libmailtools-perl, perlmagick, libfile-mimeinfo-perl, libcrypt-ssleay-perl, liblocale-gettext-perl (>= 1.05-1), libtext-typography-perl, libtext-csv-perl, libdigest-sha1-perl, graphviz, libnet-amazon-s3-perl, sparkline-php, texlive, dvipng
Conflicts: ikiwiki-plugin-table
Replaces: ikiwiki-plugin-table
diff --git a/debian/preinst b/debian/preinst
index c588901df..4158b2ae6 100755
--- a/debian/preinst
+++ b/debian/preinst
@@ -14,3 +14,7 @@ if [ "$1" = upgrade ] && dpkg --compare-versions "$2" lt 1.2; then
fi
fi
fi
+if [ "$1" = upgrade ] && dpkg --compare-versions "$2" lt 3.02; then
+ # replaced by symlink
+ rm -rf /usr/share/doc/ikiwiki/examples
+fi
diff --git a/debian/rules b/debian/rules
index 25b1f57b6..2434d92c8 100755
--- a/debian/rules
+++ b/debian/rules
@@ -25,8 +25,9 @@ binary-indep: build
dh_clean -k
$(MAKE) pure_install DESTDIR=$(shell pwd)/debian/ikiwiki
dh_installdocs html
- dh_installexamples doc/examples/*
+ dh_link usr/share/ikiwiki/examples usr/share/doc/ikiwiki/examples
dh_link usr/share/common-licenses/GPL-2 usr/share/doc/ikiwiki/html/GPL
+ dh_installexamples
dh_installchangelogs
dh_compress -X html
dh_fixperms