summaryrefslogtreecommitdiff
path: root/Makefile.PL
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.PL')
-rwxr-xr-xMakefile.PL25
1 files changed, 13 insertions, 12 deletions
diff --git a/Makefile.PL b/Makefile.PL
index 93f9e89e2..602d8fb5c 100755
--- a/Makefile.PL
+++ b/Makefile.PL
@@ -52,7 +52,7 @@ extra_clean:
rm -f *.man ikiwiki.out ikiwiki.setup plugins/*.pyc
$(MAKE) -C po clean
-extra_install:
+underlay_install:
install -d $(DESTDIR)$(PREFIX)/share/ikiwiki
for dir in `cd underlays && find . -follow -type d ! -regex '.*\.svn.*'`; do \
install -d $(DESTDIR)$(PREFIX)/share/ikiwiki/$$dir; \
@@ -70,6 +70,7 @@ extra_install:
fi \
done
+extra_install: underlay_install
# Install example sites.
for dir in `cd doc/examples; find . -type d ! -regex '.*\.svn.*'`; do \
install -d $(DESTDIR)$(PREFIX)/share/ikiwiki/examples/$$dir; \
@@ -130,16 +131,16 @@ WriteMakefile(
PM_FILTER => './pm_filter $(PREFIX) $(VER) $(PROBABLE_INST_LIB)',
MAN1PODS => {},
PREREQ_PM => {
- 'XML::Simple' => 0,
- 'Text::Markdown' => 0,
- 'Date::Parse' => 0,
- 'HTML::Template' => 0,
- 'HTML::Scrubber' => 0,
- 'CGI::FormBuilder' => 3.02.02,
- 'CGI::Session' => 0,
- 'Mail::Sendmail' => 0,
- 'HTML::Parser' => 0,
- 'URI' => 0,
- 'Data::Dumper' => 2.11,
+ 'XML::Simple' => "0",
+ 'Text::Markdown' => "0",
+ 'Date::Parse' => "0",
+ 'HTML::Template' => "0",
+ 'HTML::Scrubber' => "0",
+ 'CGI::FormBuilder' => "3.02.02",
+ 'CGI::Session' => "0",
+ 'Mail::Sendmail' => "0",
+ 'HTML::Parser' => "0",
+ 'URI' => "0",
+ 'Data::Dumper' => "2.11",
},
);