summaryrefslogtreecommitdiff
path: root/Makefile.PL
diff options
context:
space:
mode:
authorJoey Hess <joey@gnu.kitenet.net>2009-07-20 07:20:43 +0200
committerJoey Hess <joey@gnu.kitenet.net>2009-07-20 07:20:43 +0200
commitbe30203459f6994f650ed56b9f7da88b8c98c137 (patch)
tree1f97d8f50e6f5a05c3b7edb184c06f56145acba1 /Makefile.PL
parente6709f6677f037097744a07cc9c3b58db4fd4595 (diff)
parenta7b813182df7d18a0d1bf2fb28b3ee4c069c86e9 (diff)
Merge branch 'master' into integration
Diffstat (limited to 'Makefile.PL')
-rwxr-xr-xMakefile.PL20
1 files changed, 0 insertions, 20 deletions
diff --git a/Makefile.PL b/Makefile.PL
index 3db5c0d40..93f9e89e2 100755
--- a/Makefile.PL
+++ b/Makefile.PL
@@ -47,30 +47,10 @@ extra_build: ikiwiki.out ikiwiki.setup docwiki
docwiki: ikiwiki.out
$(PERL) -Iblib/lib $(extramodules) $(tflag) ikiwiki.out -libdir . -setup docwiki.setup -refresh
-underlaypo: ikiwiki.out
- # copy all the files we want to translate into the
- # po/underlays scrdir.
- for file in `find underlays -follow -name \*.mdwn`; do \
- install -d po/$$(dirname $$file); \
- cp -aL $$file po/$$file 2>/dev/null || \
- install -m 644 $$file po/$$file; \
- done
- install -d po/underlays/directives/ikiwiki/directive
- for file in doc/ikiwiki/directive/*; do \
- if [ -f "$$file" ]; then \
- cp -a $$file po/underlays/directives/ikiwiki/directive || \
- install -m 644 $$file po/underlays/directives/ikiwiki/directive; \
- fi \
- done
- install -d po/underlays/empty
- $(PERL) -Iblib/lib $(extramodules) $(tflag) ikiwiki.out -libdir . -setup underlaypo.setup -refresh
- find po/underlays -name \*.mdwn | xargs rm -f
-
extra_clean:
rm -rf html doc/.ikiwiki
rm -f *.man ikiwiki.out ikiwiki.setup plugins/*.pyc
$(MAKE) -C po clean
- rm -rf po/html po/underlays/.ikiwiki
extra_install:
install -d $(DESTDIR)$(PREFIX)/share/ikiwiki