summaryrefslogtreecommitdiff
path: root/Makefile.PL
diff options
context:
space:
mode:
authorjoey <joey@0fa5a96a-9a0e-0410-b3b2-a0fd24251071>2006-03-23 06:51:15 +0000
committerjoey <joey@0fa5a96a-9a0e-0410-b3b2-a0fd24251071>2006-03-23 06:51:15 +0000
commit6c8cf5dd571662f981227489f7c4652a1a1f10cd (patch)
tree778453ccf0d85720f37579f6e3c95624fdb5f960 /Makefile.PL
parent7b0346bf8234100f608aa7f24684becc952e8956 (diff)
Major code reoganisation, splitting up the single big file. The two goals
kept in mind during this are a) to reduce load time for common cases like cgi and post-commit and b) make the code easier to navigate. This also modularises RCS support to the extent that it should be possible to drop in a module for some RCS other than svn, add a switch for it, and it pretty much just work. High chance I missed an edge case that breaks something, this is only barely tested at this point.
Diffstat (limited to 'Makefile.PL')
-rwxr-xr-xMakefile.PL5
1 files changed, 3 insertions, 2 deletions
diff --git a/Makefile.PL b/Makefile.PL
index 70d81b806..10015c47c 100755
--- a/Makefile.PL
+++ b/Makefile.PL
@@ -12,8 +12,8 @@ install:: extra_install
pure_install:: extra_install
extra_build:
- ./ikiwiki doc html --templatedir=templates --wikiname="ikiwiki" \
- --verbose --nosvn --exclude=/discussion
+ ./ikiwiki doc html --templatedir=templates \
+ --wikiname="ikiwiki" --verbose --nosvn --exclude=/discussion
./mdwn2man doc/usage.mdwn > ikiwiki.man
extra_clean:
@@ -31,5 +31,6 @@ extra_install:
WriteMakefile(
'NAME' => 'IkiWiki',
+ 'PM_FILTER' => 'grep -v "removed by Makefile"',
'EXE_FILES' => ['ikiwiki'],
);