aboutsummaryrefslogtreecommitdiff
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorNick Wellnhofer <wellnhofer@aevum.de>2014-11-15 19:54:01 +0100
committerNick Wellnhofer <wellnhofer@aevum.de>2014-11-16 21:31:56 +0100
commit76b7e4241c840480beaef5ac6b711301f066251e (patch)
tree04df5b2c9c0281db3c96ae44945e807d42d66bec /src/CMakeLists.txt
parent4dcdc715910b61a2b58f1ea8ae5f86d041e3c229 (diff)
Probe for stdbool.h
Let cmake create a cmark_config.h file to deal with platforms missing stdbool.h.
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 9bae3b5..4378ba6 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -96,6 +96,10 @@ install(FILES cmark.h ${CMAKE_CURRENT_BINARY_DIR}/cmark_export.h
include (CheckIncludeFile)
CHECK_INCLUDE_FILE (stdbool.h HAVE_STDBOOL_H)
+CONFIGURE_FILE(
+ ${CMAKE_CURRENT_SOURCE_DIR}/config.h.in
+ ${CMAKE_CURRENT_BINARY_DIR}/config.h)
+
# Always compile with warnings
if(MSVC)
# Force to always compile with W4