aboutsummaryrefslogtreecommitdiff
path: root/api_test/CMakeLists.txt
diff options
context:
space:
mode:
authorJohn MacFarlane <jgm@berkeley.edu>2015-01-24 21:35:03 -0800
committerJohn MacFarlane <jgm@berkeley.edu>2015-01-24 21:39:07 -0800
commit829b089c80895d9a78938c5bc7747aea1cd48eb6 (patch)
tree53bd534741a90c547c5d87039efa5ee625da8081 /api_test/CMakeLists.txt
parent5ef31853d5161d4b5a2dfc0df94e6eaaeb3215d0 (diff)
Removed implementation-specific material from repository.
The C and JS implementations are being split off into different repositories. This repository will just have the spec itself.
Diffstat (limited to 'api_test/CMakeLists.txt')
-rw-r--r--api_test/CMakeLists.txt25
1 files changed, 0 insertions, 25 deletions
diff --git a/api_test/CMakeLists.txt b/api_test/CMakeLists.txt
deleted file mode 100644
index e3e84f6..0000000
--- a/api_test/CMakeLists.txt
+++ /dev/null
@@ -1,25 +0,0 @@
-add_executable(api_test
- cplusplus.cpp
- harness.c
- harness.h
- main.c
-)
-include_directories(
- ${PROJECT_SOURCE_DIR}/src
- ${PROJECT_BINARY_DIR}/src
-)
-target_link_libraries(api_test libcmark)
-
-# Compiler flags
-if(MSVC)
- # Force to always compile with W4
- if(CMAKE_CXX_FLAGS MATCHES "/W[0-4]")
- string(REGEX REPLACE "/W[0-4]" "/W4" CMAKE_C_FLAGS "${CMAKE_C_FLAGS}")
- else()
- set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} /W4")
- endif()
- set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} /wd4127 /wd4244 /wd4267 /wd4706 /wd4800 /D_CRT_SECURE_NO_WARNINGS")
- set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} /TP")
-elseif(CMAKE_COMPILER_IS_GNUCC OR "${CMAKE_CXX_COMPILER_ID}" STREQUAL "Clang")
- set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -Wall -Wextra -std=c99 -pedantic")
-endif()